RHEL5 display resolution change not sticking

Discussion in 'Linux Guest OS Discussion' started by Bob M, May 7, 2009.

  1. Bob M

    Bob M

    Messages:
    3
    I don't know if this is a purely RHEL5 issue, or influenced by running it as a VM.

    MacBook Pro, OS X resolution currently set to its maximum: 1440x900.

    In the VM, I change the resolution from 1920x1200, to 1024x768 (I've tried other settings as well), then click 'OK'. I'm told:

    "Display settings changed. You need to log out and restart the X server for the changes to take effect. Configuration was written to /etc/X11/xorg.conf [...]".

    I restarted the VM, but changes don't stick.

    If I reopen Display Settings after having attempted to make a change, the resolution remains at 1920x1200. It's as if the change isn't being written properly. If I change colors from Millions to Thousands, that sticks immediately (meaning if I reopen Display Settings, the choice I've changed to is what I changed it to).

    Following show the permissions (I'm logged in as root, and have write privs to that file); a diff; and the video sections of xorg.conf. Most of my VM settings are default. I did increase video memory to 32MB.

    Bob

    -rw-r--r-- 1 root root 764 May 7 08:48 xorg.conf
    -rw-r--r-- 1 root root 775 May 7 08:43 xorg.conf.backup

    # diff /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    28c28
    < Modes "1920x1200" "1680x1050" "1600x1200" "1600x1024" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "800x600" "640x480" "640x480"
    ---
    Modes "1920x1200" "1680x1050" "1600x1200" "1600x1024" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"

    -----------

    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1920x1200" "1680x1050" "1600x1200" "1600x1024" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "800x600" "640x480" "640x480"
    EndSubSection
     
  2. jgadbaw

    jgadbaw Bit Poster

    Messages:
    8
    Use an editor and set your depth to 16 and see if things work as you want.
     
  3. Ed Sutton

    Ed Sutton

    Messages:
    52
    Reproduced problem

    I know it is not helpful, but I have the exact same problem. I had a tough time even installing Parallels tools. I had to copy to my desktop and change a bunch of permissions. This is one area that VMware Fusion does better - installing VM Tools is easy in comparison to enable use of native resolution. I am going to get with a tech support engineer and see if there is a solution. I may switch to Parallels. I'll post the outcome here.

    -Ed
     
  4. Ed Sutton

    Ed Sutton

    Messages:
    52
    Solved - Configure guest Video memory greater than 2GB default

    1 - With VM shutdown, select Configure from the Virtual Machine list
    2 - Select Video under Hardware and increase Video memory. I changed mine to 16MB although less may be sufficient

    Once I did this I could operate at MacBook Pro native 1440 x 900 as well as external native 1920 x 1080 both *before* and after installing Parallel Tools.

    How to Install Parallel Tools Under Red Hat

    1- With VM running, select Install Parallel Tools from the Virual Machine (unmount any mounted CD's first)
    2 - Make a "ParallelTools" folder on your desktop and copy everything in the mounter CD to it
    3 - You need to change owner after copying as root or using sudo. Do a chown -R johnDoe ParallelsTools
    4 - No go into the copy of the ParallelTools folder and do "chmod +x *" of the files in the root and the installer subfolder
    5 - Now you should be able to run the install with out any permission issues

    Now if I could only locate a good deal on a competitive upgrade from VMware Fusion 2.0 I might switch. :)

    -Ed
     

Share This Page