Rosetta stops functioning

Discussion in 'Parallels Desktop for Mac' started by sharkez, Jan 5, 2007.

  1. sharkez

    sharkez

    Messages:
    27
    I'm not sure if this is related to the new (3106) beta or not. I've been running off a boot camp partition with much of my "full work environment" installed (oracle 9i, Java apps and all the MS Office 2003 garbage). Coherance is great... But over the past couple of days I've noticed that eventually I can no longer launch some MAc apps. It turns out these are all apps that need Rosetta--MS apps for Mac and SplashID to name a few. I tested this and Safari will run in Universal mode but will not launch in Rosetta so I think Rosetta gets "blown" somehow. On the Mac side I'm not running anything unusual (Mail, iCal, Skype, Adium, Pathfinder, Launchbar, Firefox) but i do run the MS Mac apps until this dies.

    Is anyone else having this problem? Is it associated with Parallels or something else? I need to run parallels to work so I've not tried to see if i have this problem without parallels running--yet.

    I have a 15" MBP 2.33 C2D with 3GB.
    Thanks
     
  2. rhind

    rhind

    Messages:
    84
    Not sure if it is the same thing, but I do extensive work with Borland C++Builder under WinXP SP2 in parallels (non-bootcamp) and also have entourage running connected to our work exchange server. I have had entourage hang twice now while Parallels is running and have had to force-kill it. The first time was serious as Entourage wouldn't launch again. I deleted all its prefs, rebooted etc but nothing. But it would launch under a fresh user account so ended up having to move to a new user account to fix it. The next time it happened, it at least would launch again which saved a lot of time.

    But I also get a few XP blue screens a day. Usually after I've been using C++Builder for quite a while, debugging. I never saw this on my desktop PC so don't believe it is a Borland problem, but XP under Parallels 3106 isn't that stable for me.

    Running under coherence on a MBP C2D 2.33 with 2GB RAM, 768 allocated to the VM.

    Cheers

    Russell
     
  3. Sheppy

    Sheppy

    Messages:
    145
    I've noticed that Rosetta apps run quite slowly when Parallels is running, but they do still work. To be honest, this won't be an issue for me anymore if and when Adobe finally gets an Intel native version of Photoshop Elements out the door, since that's more or less the only PowerPC app I still run on a regular basis.
     
  4. rhind

    rhind

    Messages:
    84
    I can cope with apps running slowly (and would expect it). Rosetta is effectively an emulator so would expect to be fairly resource intensive, along with Parallels. But for me, Entourage has definitely hung twice but I can't say this is definitely down to Parallels or whether its just a bug with Entourage, but has happened twice in 3 days now and both times have been when I've been working in Parallels, I then click on Entourage in the dock, its menu appears along with the spinning beachball and it never recovers. There is no hard-disk access to indicate memory is being swapped back in for it, but it is using 99% CPU usage according to activity viewer.

    I'm more concerned about the Parallels blue screens for now. But I do suspect there was a bit of corruption on my virtual hard-disk so last night I've restored my VM from a back-up before the corruption occurred so will find out if that fixes it this week.

    Cheers

    Russell
     
  5. rich.mcdonough

    rich.mcdonough

    Messages:
    6
    My Rosetta apps will launch, but run much more slowly when Parallels is up. I suspect that the VMX scheduling is trampling the Rosetta apps. Try turning off the VMX acceleration and see if that helps.
     
  6. sharkez

    sharkez

    Messages:
    27
    Agree that rosetta runs slowly and that's to be expected. I think this is something else, Rosetta apps will not run at all. Upon launching I get a single bounce in the dock--no beachball. All is well again with a re-boot of the Mac. I do so little with rosetta apps without parallels also running that I've had a hard time determining if it's MS apps alone torarching Rosetta or in combination with Parallels but unfortunately I think it may be the latter. Also, no BSOD for me (thankfully.)

    Shark
     
  7. rhind

    rhind

    Messages:
    84
    I've just hit this problem again. My machine has started running incredibly slowly (Parallels 3106 on 2Gb 2.33GHz MBP C2D) and I started to shut parallels down. Suddenly Entourage crashed and neither word nor Entourage would launch again. I'd be unsure how Parallels could afftect this and so can't guarantee it is a conflict between Rosetta and Parallels, but I haven't had it happen when Parallels isn't open.

    Only a reboot fixed this issue, Rosetta apps will now launch again.

    Cheers

    Russell
     

Share This Page