Routing problems with bridge101 aka host-only in Monterey

Discussion in 'Installation and Configuration of Parallels Desktop' started by BallO, Nov 5, 2022.

  1. BallO

    BallO Hunter

    Messages:
    120
    I've been trying to get a simple route working in Parallel Desktop for days with zero success. I had a similar setup working in Mohave using an older version.
    Setup: I have a linux router running on the host-only virtual network at 10.37.129.3. The host OS, Monterey, is at 10.37.129.2. I just want to route traffic through the linux router. The routing table looks fine:
    Code:
    > netstat -nrf inet
    Routing tables
    
    Internet:
    Destination        Gateway            Flags           Netif Expire
    default            10.37.129.3        UGScg       bridge101
    default            link#19            UCSIg       bridge100      !
    default            link#21            UCSIg       bridge101      !
    8.8.8.8            link#21            UHLWIg      bridge101      !
    10.0.0.12          link#21            UHLWIig     bridge101      !
    10.37.129/24       link#21            UC          bridge101      !
    10.37.129.2        b2.be.83.d5.0.65   UHLWIi            lo0
    10.37.129.3        0.1c.42.87.1e.68   UHLWIir     bridge101   1075
    10.37.129.255      ff.ff.ff.ff.ff.ff  UHLWbI      bridge101      !
    10.211.55/24       link#19            UC          bridge100      !
    10.211.55.2        b2.be.83.d5.0.64   UHLWIi            lo0
    10.211.55.255      ff.ff.ff.ff.ff.ff  UHLWbI      bridge100      !
    127                127.0.0.1          UCS               lo0
    127.0.0.1          127.0.0.1          UH                lo0
    127.0.0.2          127.0.0.1          UHW3I             lo0   2068
    224.0.0            link#1             UmCS              lo0
    224.0.0.251        link#1             UHmW3I            lo0   3471
    239.255.255.250    1:0:5e:7f:ff:fa    UHmLWIg     bridge100
    This output looks good, too:
    Code:
    > route get 8.8.8.8
       route to: 8.8.8.8
    destination: default
           mask: default
      interface: bridge101
          flags: <UP,DONE,CLONING,STATIC,IFSCOPE,GLOBAL>
     recvpipe  sendpipe  ssthresh  rtt,msec    rttvar  hopcount      mtu     expire
           0         0         0         0         0         0      1500     -1408
    Running tcpdump on the router I can see when Monterey pings the router, but there is no traffic if I set it as the default gateway.
    I can also use the linux router as the Windows 11 default gateway just fine, so the router doesn't appear to be the problem.
    Anyone have any suggestions?!
     
  2. Will_1231

    Will_1231 Bit poster

    Messages:
    3
    Best Answer
  3. BallO

    BallO Hunter

    Messages:
    120
    I attempted to add the entry in /Library/Preferences/SystemConfiguration/preferences.plist to make the Network Service show up like it used to in Mohave to no avail.
     
  4. BallO

    BallO Hunter

    Messages:
    120
    I managed to manually edit
    Code:
    /Library/Preferences/SystemConfiguration/preferences.plist
    and for the Network Service to show, but the old method to use the virtual gateway which worked in Mojave isn't working in Monterey. The routing table is now automatically set and looks correct (same as I manually set it before), but still can't route and tcpdump on the router shows no attempt. The only curious change is
    Code:
    route get 8.8.8.8
    now takes a long time, but with the same result.
     
  5. HaohaoL

    HaohaoL Bit poster

    Messages:
    1
    I have encountered the same issue, Hi @BallO , have you resolved this issue
    I am on Ventura 13.5 with M1
     
  6. Macn1

    Macn1 Bit poster

    Messages:
    1
    I'm also trying to figure out how to route traffic from host(macOS sonoma) to vm , but fail.
    On linux , I install a virtualbox vm , and setup a route :
    Code:
    # 192.168.56.2 is the IP of vm
     ip r add 10.21.1.0/24 via 192.168.56.2
    then ping 10.21.1.9 on host, I can see icmp message via tcpdump .

    but on macOS , not working .
     
  7. BallO

    BallO Hunter

    Messages:
    120
    At this point I have given up getting any tech support on this issue and am looking for alternatives
     
  8. Will_1231

    Will_1231 Bit poster

    Messages:
    3
    Used wireguard
     
  9. Will_1231

    Will_1231 Bit poster

    Messages:
    3
    Best Answer
  10. BallO

    BallO Hunter

    Messages:
    120
    Is there any way to turn off encryption, which is just a waste of power considering it's all hosted on the same machine?
    If not, I don't see any reason to use wireguard given ssh tunneling works the same way.
     
  11. BallO

    BallO Hunter

    Messages:
    120
  12. AlexW30

    AlexW30

    Messages:
    1
    好兄弟,你讲得太专业了
     
  13. BallO

    BallO Hunter

    Messages:
    120
    So I tried the script @Will_1231 linked and it didn't go so well:
    [​IMG]
     
  14. Will_1231

    Will_1231 Bit poster

    Messages:
    3
    It is not straightforward to configure but I can assure you that it works great!
     
  15. BallO

    BallO Hunter

    Messages:
    120
    Yeah, I think I have some missing packages. The script does things very blindly with fingers crossed. I'm going to try a different script.
     

Share This Page