Run x64 OS on M1

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by TornikeG, Aug 21, 2021.

  1. TornikeG

    TornikeG Bit Poster

    Messages:
    12
    Hi,
    I would like to know if there is a way to run an x64 OS on M1.

    The reason I am asking this is since Apple created Rosetta translation environment to deal with apps that contain x86_64 instructions to be able to run on Mac, maybe there is something similar in Parallels software that would allow that. It would be very convenient to have one bootable flash drive that you could use both on a PC machine and an M1 Mac.
     
  2. kundanno

    kundanno Kilo Poster

    Messages:
    188
    X64 translation works for macOS apps. Emulation of an X64 OS via Parallels is not possible, at least thus far (never say never!). However, you can explore emulators like QEMU.
     
  3. JoeDawson

    JoeDawson Bit Poster

    Messages:
    7
    Thank you for answering this question because sadly this is the exact problem I have. When I travel I use a Mac and for my better half who uses Windows I have a VM for her in Parallels that works great. But it looks like if I jump to an M1 Mac I will only be able to run other VMs that run on the ARM OS. And as of today Microsoft has no real Rosetta equivalent so most of the old applications she runs will not work in the Windows Arm OS. Maybe in a LONG time from now when the Windows ARM OS improves but for now I sadly can't upgrade my laptop to any version of an Apple CPU.
     
  4. AlexR16

    AlexR16 Bit Poster

    Messages:
    14
    Windows 10 for ARM has always been able to emulate 32bit Intel Windows apps and more recently has gained support for 64bit Intel Windows apps ... depending on the apps your better half needs, she may find they work perfectly well under the Windows 10 or 11 for ARM as a guest.
     
  5. RaumD

    RaumD

    Messages:
    1
    Are you running a build of Win10 older than 21292.1010? I just bought Parallels 16 on the 28th of July (unrelated anger about the free upgrade I missed by a few days) and installed the latest build at the time, currently 21354, and I have not been able to launch any x64 apps. The only information I can find suggests that 21292.1010, KB4601937, broke x64 emulation which had only been introduced in build 21277. I've been searching for any sign that it has been fixed since then and that I've just done something wrong which brings me to these forums. I can't uninstall that update because, I assume, it was baked-in to the version I installed. It's far too limiting not being able to install anything x64.
     
  6. Anand48

    Anand48 Bit Poster

    Messages:
    64
    We are researching possibilities for running x86/x64-based VMs on Mac with Apple M1 chip, but unfortunately, it shows itself as an approach that delivers low performance and high energy consumption. Hence, Parallels Desktop doesn't offer this option now.
     
  7. AlexR16

    AlexR16 Bit Poster

    Messages:
    14
    I must admit I'm not a frequent or heavy user of my Windows guest on my M1 but it did run the minor Intel apps a while back when I needed it to.
    I've just booted up the Win10 guest and the Win11 guest it became, the Win 10 Build is 21389.2025, the
    Win 11 Build 22000.160. To be honest, over the past 3-4 months, the only thing I've booted them up for is to update Windows (and partly to have a brief look at Win 11)
    I knew x64 had been removed from previous versions of Win10 ARM but thought it had returned... as a test I've just tried running Putty (not exactly demanding I know) on both the Win10 and Win11 guests and both started, suggesting the x64 emulation is indeed back in the latest builds

    Here is the section of Task Manager showing the 3 versions I tried running.
    upload_2021-8-24_12-53-29.png
     
  8. SamH7

    SamH7 Bit Poster

    Messages:
    3
    I've just installed Parallels 17 Pro with hope that the only two x64 programs I need to use in Windows 10 would work, turns out neither do so sadly this VM ware is of no use to me.. is this something that will be resolved in the coming months? ..or should I just give in and go back to a PC?
     
  9. AlexR16

    AlexR16 Bit Poster

    Messages:
    14
    Sam, sorry to say but difficult to answer without details. If you care to name the couple of apps maybe people already on the forum can answer or give advice, but x64 emulation in Windows 10/11 is barely within Parallels control (bar graphics drivers and USB connectivity), it's purely Microsoft. As RaumD mentioned, it's also rather dependant on which build of Windows you're running in the guest, some definitely don't work, some do to a lesser or greater extent, but all are pre-release versions so bugs are to be expected to some extent.
     

Share This Page