Safari Beta 3 on XP on Parallels doesn't work

Discussion in 'Parallels Desktop for Mac' started by SanDiegoJim, Jun 12, 2007.

  1. SanDiegoJim

    SanDiegoJim Bit Poster

    Messages:
    15
    I have tried installing the new Safari beta v3 on my XP set up under parallels. After the install, all menus are blank of text. :confused: I can pull down menus but they are blank. :eek: I guessed where the preferences item was and the preference window is also blank of text. :(

    This is way below Apple's standards. There are no directions provided. There is no feedback site listed. The Safari page on Apple.com only lists links for downloads. I cannot find any support to a badly flawed Apple program.

    Any suggestions? Any other ideas?

    Jim
     
  2. mikechadwick

    mikechadwick

    Messages:
    28
    i put the Safari beta on a windows laptop today and it worked just fine. not sure why you're having the problem under parallels though:confused:
     
  3. maltbym

    maltbym

    Messages:
    1
    My Safari Beta is working just fine, maybe try reinstalling it
     
  4. danws

    danws

    Messages:
    15
    I have tried to run Safari on regular Windows and it ran fine. You should probably try reinstalling Safari or it could be something wrong with Parallels.
     
  5. dkp

    dkp

    Messages:
    1,367
    Safari 3 didn't work worth a damn on my G3. It still lacks several features I'd like to have like the ability to not underline links on the screen. I'm not impressed yet. However - it is just one more bit of beta code to add to the already jumbled mix of new releases and existing beta code with Boot Camp 1.3, Vista 1.0, Parallels 3.0, etc. OS X is amazingly tolerant of this flogging but not impervious.
     
  6. AlanH

    AlanH Kilo Poster

    Messages:
    316
    No problem with Safari in XP in Parallels here, though I only tried it for a few minutes. I really don't see any need to browse in Windows except for specific sites with downloads I want to use in XP. Even then I can download to a shared folder on the OS X side and then install to XP from there.
     
  7. wingdo

    wingdo Kilo Poster

    Messages:
    314
    I just have to ask .......

    Why are you running Safari in XP in Parallels? Besides teh geek factor, why would you want to actually "use" this setup?
     
  8. Jack Dumphy

    Jack Dumphy

    Messages:
    21
    Safari 3 beta even doesn't work on my 3 native XP-PCs
    So I don't think, the problem is up to Parallels.
     
  9. rmf

    rmf

    Messages:
    32
    Same here. Works fine.
     
  10. jsisler

    jsisler

    Messages:
    6
    I am running xp on macbook pro 1.8 ghz,80 mb hd, 2mb mem., sys.10.4.9.

    I did not have any trouble installing and running Safari on windows. Have been running it for two days and its flawless so far.
     
  11. Shidayu

    Shidayu

    Messages:
    50
    I installed Safari under Parallels with no problems whatsoever. Not sure what is going on here...
     
  12. SanDiegoJim

    SanDiegoJim Bit Poster

    Messages:
    15
    I tried all that stuff


    Thanks for all the responses but I must say that I have tried it all. Installed. Uninstalled. Installed with Quicktime. Downloaded new versions. Nothing.

    I am wondering if I may not have some screen font installed that they use. I don't think it is parallels related either but there is not place on Apple.com to complain. There are numerous reports of the same problem(s) on Apple Insider too. The installer program isn't up to Apple standards. It doesn't even make a desktop icon or taskbar icon.

    Interestingly, I cannot install the Mac version either. Rather than list everything, I have the latest systems/parallel everything version running on my Intel iMac 2 ghz with plenty of ram and HD space. Everything work fine on the Mac and Parallels.

    As for why I would want to try it, I like Safari on the Mac and now I would be able to share bookmarks etc with the PC version.
     
  13. SanDiegoJim

    SanDiegoJim Bit Poster

    Messages:
    15
  14. BenInBlack

    BenInBlack

    Messages:
    372
    for me when parallels came out, I turned off my windows PCs and just use parallels. so for me to test it, it is my only option ;-)

    and also, I had no problems installling and running it on XP
     
  15. SanDiegoJim

    SanDiegoJim Bit Poster

    Messages:
    15

Share This Page