Safe/Good way to uninstall?

Discussion in 'Parallels Desktop for Mac' started by s.cresswell, Apr 6, 2006.

  1. ibepc2

    ibepc2

    Messages:
    5
    How do you apply this shell script to uninstall?
     
  2. missiled

    missiled

    Messages:
    10
    Sooo...

    Will this script work or not for Beta 6?

    I still find it completely unbelievable that Parallels is on Beta #6 and STILL hasn't released an approved uninstaller.

    Parallels is getting massive compliments for how frequently they're releasing upgrades, and how well they're listening to "potential" customers' requests - EXCEPT FOR AN UNINSTALLER.
     
  3. drtimhill

    drtimhill

    Messages:
    85
    Incidentally, AppZapper (nice tool, btw) seems to be able to find all these items when told to zap PW.

    --Tim
     
  4. drtimhill

    drtimhill

    Messages:
    85
    Well, as you say, it's a beta. It's hard to argue priorities until you look at the GA. I would agree that if they don't get uninstall in the final product that would be pretty poor.
    --TIm
     
  5. Djoh

    Djoh

    Messages:
    42
    Photoshop doesn't have an uninstaller. It's fine. It leaves piles of stuff behind if you just delete the application. This ain't windows, it's pretty easy to look for things called "parallels" and delete them (try the "find" command, or that spotlight thing). They said they'll have a "professional" looking uninstaller for you soon, till then the find command does in fact uninstall everything! Including the Kernel extensions (which some have said "alter the kernel", true, and definitely not irreversible).

    As someone said, that's the mac way. throw it in the trash or just move the files out of the way and it's done. Empty the trash too if you're really paranoid!
     
    Last edited: May 15, 2006
  6. s.cresswell

    s.cresswell

    Messages:
    16
    Uninstaller in the RC

    I haven't tried it yet but I see there is an uninstaller in the RC
    Thanks Parallels :)
     
  7. maxslomoff

    maxslomoff

    Messages:
    10
    the uninstaller does not work because i've tried to uninstall 3186 and go back to 3120 in an attempt to get parallels to boot my boot camp partition which it complains it can't find the drivers for.

    i ran the uninstall tool, reinstalled 3120 and checked the about screen which still lists 3186. i only thought to check the about screen because i've been trying to solve this problem for a couple days and have uninstalled and reinstalled parallels, but it never asks me for the serial anymore, so i know it's not completely uninstalled.

    it looks like i'm going to have to rebuild my whole system.
     
  8. paulingraham

    paulingraham

    Messages:
    3
    uninstall at least partially failed

    After installing Parallels on my 24" iMac, I started experienced hard hangs about once every couple of hours of usage. These are the only bad hangs I've ever seen on an OS X machine!

    Even though Parallels wasn't running, I noted that Parallels was appearing a lot in system.log. I got suspicious and started researching and soon found other comments on the forums here about Parallels causing kernel panics and hangs. I decided I wanted it off my system immediately. I used some of the information in this thread (for which I'm grateful), and also ran the installer that comes with the product.

    Parallels is mostly gone, and my hangs have stopped. Phew.

    However, Parallels still appears in my system.log. About twenty of these messages appear during boot:

    Mar 10 13:37:02 localhost kernel[0]: ParallelsConnectUSB(0x43a8480)::start() Control service not started!​

    So it's not completely gone! Anybody know what I missed?

    Good riddance to the rest of it, though. Technical support from this developer is among the worst I've ever seen, either nonexistent or illiterate. The only reply I ever got was late arriving and hilariously incompetent: a few lines of bad typing, bad spelling, and missing the point. Good grief!
     
  9. paulingraham

    paulingraham

    Messages:
    3
    parallels won't go away

    Update a few days later...

    I don't understand kextstat all that well, but I am pretty darn sure that this...

    ...means that Parallels is still on my system. And I am still getting Parallels-related output in system.log. Can anyone shed any light on this? I do not know how to track down the source of these kexts. I have searched thoroughly for them, can't find any trace of Parallels using Spotlight, and all the components discussed in earlier posts are definitely gone.
     
  10. nddigi

    nddigi

    Messages:
    1
    So if I follow those steps (deleting parallels from applications, etc.) does that get rid of the XP install and whatever else I've installed in Parallels? (games, etc.)

    Thanks,
    -R
     
  11. zuiko

    zuiko

    Messages:
    5

    I have the same issue. System.log shows...

    May 18 19:42:16 localhost kernel[0]: ParallelsConnectUSB(0x39af000)::start() Control service not started!
    May 18 19:42:16 localhost kernel[0]: ParallelsConnectUSB(0x3c7e600)::start() Control service not started!
    May 18 19:42:16 localhost kernel[0]: ParallelsConnectUSB(0x3a01780)::start() Control service not started!
    May 18 19:42:16 localhost kernel[0]: ParallelsConnectUSB(0x3c7e800)::start() Control service not started!
    May 18 19:42:16 localhost kernel[0]: ParallelsConnectUSB(0x3c7ec80)::start() Control service not started!
    May 18 19:42:16 localhost kernel[0]: ParallelsConnectUSB(0x3c77600)::start() Control service not started!



    How can I get rid of this last piece? I've removed the other parts manually as above. I think the developers really should put up the instructions for manual removal. They will lose me as a customer forever otherwise.


    If anyone can help I'd truly appreciate it.
     
  12. zuiko

    zuiko

    Messages:
    5
    I have just found the files which belong to Parallels...

    /System/Library/Extensions/ConnectUSB.kext
    /System/Library/Extensions/Pvsnet.kext


    Delete these to uninstall Parallels completely in addition to any other steps.
     

Share This Page