Scrolling in Linux/Ubuntu is either too slow or too fast

Discussion in 'Linux Virtual Machine' started by BryanSmith, Jan 1, 2023.

  1. BenjaminP7

    BenjaminP7 Bit poster

    Messages:
    4
    Hey, I am experiencing the same problem. Is there a solution yet?
     
    Rob18 likes this.
  2. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    499
    hi @BenjaminP7 ,
    Would you share the reproduction steps with us, please?
    Additionally, for us to investigate the issue better, kindly try performing the steps below:
    1. Reproduce the issue again.
    2. Collect a technical report while the issue is being reproduced (click Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in your reply to this post.
     
  3. BenjaminP7

    BenjaminP7 Bit poster

    Messages:
    4
    Hello @Mikhail Ushakov,

    thanks for your response.

    I'll try my best to describe my scenario:

    I am using a M1 MacBook Air running Sonoma 14.0 with a Parallels Desktop for Mac Pro License. After installation, I chose Debian GNU/Linux from the offered options, which installed nicely, boots fast etc.

    Using the TouchPad of my MacBook Air, I notice that when scrolling in a program (doesn't matter which), let's say "Software" app, or any browser, File Explorer, anything that lets you scroll through content, the movement is translated to a very fast scroll speed. A little motion results in a wide scroll distance.
    Reading the attempts of the pre-posters in this thread, I would just like to know: What would be the easiest way to decrease the scroll speed without affecting cursor speed?

    Thanks in advance
     
  4. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    358
    Hello Benjamin,

    Kindly perform the following steps.

    1. Shut down the Virtual Machine. Make sure that the virtual machine is shut down. If it is in a suspended state, please run it and then shut it down (Actions > Shut Down).

    2. Locate your virtual machine (https://kb.parallels.com/10109)

    3. Open your Virtual Machine by right-clicking on it and choosing Show Package Content.

    4. Find and open config.pvs file by right click and choose Open With -> TextEdit

    5. Then you need to find this:
    <SmoothScrolling dyn_lists="">
    <Enabled>0</Enabled>
    </SmoothScrolling>

    and switch from 0 to 1.

    6. Restart Parallels Desktop.

    7. Check if the issue persists.

    In case the issue persists, please collect a technical report (click the Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in a reply.
     
  5. BenjaminP7

    BenjaminP7 Bit poster

    Messages:
    4
    Hello @Adeboye Adeotan,
    thanks for your reply.
    I followed your steps and it indeed changed the scrolling behavior in Linux. Unfortunately, it takes away a lot of precision and doesn't feel very accurate anymore. Movements are getting buffered and I wonder if there are any alternatives to this solution?

    To rephrase my request: This solution seems to do more than just decrease the scroll speed. Is there are way to achieve this?
     
  6. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    80
    Hello Benjamin,

    Could you please share the technical report after reproduction with us, so we could investigate: collect a technical report (click the Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in a reply message.

    And to comment on your question, unfortunately, at present this setting is the only possibility to modify the scrolling behavior in Linux VM's, but if the modified behavior is more detrimental to your experience, you can reverse the change by switching the SmoothScrolling back to the original value, while the issue is being looked into, pending a report ID from your side.

    Thank you!
     
  7. BenjaminP7

    BenjaminP7 Bit poster

    Messages:
    4
    Hello Maxim,
    thanks for the response.
    I just sent the report and received the ID: 442066145.
     
  8. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    705
    Hey @BryanSmith, @SkylerT, @sfgvieira, @MarcinK7, @BenjaminP7, better late than never, we are currently investigating the situation with the scrolling experience in Linux VMs and hoping to improve it in future product updates. Stay tuned for updates, and wish you happy holidays ahead.
     
    Zshrc and BenjaminP7 like this.
  9. SkylerT

    SkylerT Bit poster

    Messages:
    6
    Hey @Dmitry@Parallels - thanks for the update. I do hope this is an early 2024 item as it is the primary reason I unsubscribed on my primary laptop and am going to let my secondary laptop sub lapse as well when it is up. Please post back here when this is resolved.
     
    Dmitry@Parallels likes this.
  10. Zshrc

    Zshrc Member

    Messages:
    21
    Honestly the only quirk that makes Linux VMs feel like a second-class citizen, otherwise Parallels works great with Linux. Hope this can be resolved soon.
     
    Dmitry@Parallels likes this.
  11. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    705
    Hey folks,

    I am glad to announce that we've just released an update, 19.3.0, that significantly improves the scrolling experience with a Trackpad across the entire Linux OS (not just a browser). This improvement applies to Mac computers with both Intel processors and Apple silicon chips. Check for updates via the Parallels menu to get the new version.

    Once you install version 19.3.0 and update Parallels Tools in your Linux virtual machines, you should feel the difference in scrolling sensitivity -- it becomes much smoother. If you wish to personalize scrolling sensitivity, you can easily do that by executing the following command in macOS Terminal (applies to all Linux virtual machines):

    $ defaults write "com.parallels.Parallels Desktop" "HID Host Hook.Scroll Sensitivity" X

    , where X = 20 is the default value; 1 = minimum value (the highest sensitivity); 120 = maximum value (the lowest).

    Please give it a try and let us know whether you like it or not. Thank you very much for your feedback reported in this thread!
     
  12. KasperP1

    KasperP1 Bit poster

    Messages:
    3
    I notice absolutely no difference. Have upgraded Parallels Tools and restarted the VM, but trackpad scrolling behaves the same as before and changing the sensitivity has no effect. Am I missing some hidden setting? This is with an Ubuntu 22.04 guest.
     
  13. KasperP1

    KasperP1 Bit poster

    Messages:
    3
    To elaborate on the above: if I have SmoothScrolling set to '0' (as in an earlier post), then the setting has an effect. But I would rather use SmoothScrolling set to '1'. In that case, I do not see any difference. I am still having the problem that whenever I start scrolling with the trackpad, it takes a while for the system to recognise that I am scrolling, and then suddenly the page jumps. Once I am scrolling it is smooth, but this first jump is quite unlike what happens on real hardware, and unlike what the macOS trackpad scroll behaves like.

    So maybe this is not what the 19.3.0 patch is supposed to fix?
     
  14. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    705
    Thanks for bringing this up regarding the smooth scrolling option. This new improvement is supposed to work with the default smooth scrolling condition which is off by default. Since we have not promoted using smooth scrolling for many years, most users don't even know about its existence.

    1. The problem you're having with the scrolling lag - is this reproducible with smooth scrolling enabled or disabled? Or both?
    2. Why do you prefer using smooth scrolling? What benefit do you see in using it?
     
  15. jerrya6

    jerrya6 Bit poster

    Messages:
    1
    I am using a Macbook Pro M1 2021, and only using the built-in trackpad, to run a Linux guest.
    I understand that Linux/Ubuntu has moved towards using libinput, and that this means that trackpad scroll speed is not customizable.
    Further, the virtual mouse provided by Parallels is not a trackpad, and doesn't have configurable parameters.
    It is possible to adjust scroll speed in Firefox
     
  16. Nikolo

    Nikolo Bit poster

    Messages:
    2
    I have a similar problem.
    I tested Parallels 19.4.0 and 19.3.

    The problem with scrolling using a trackpad on Debian, Ubuntu, Kali has not disappeared, it remains.
    I tested changing SmoothScrolling 0 and 1. It didn't help at all.
     
  17. Nikolo

    Nikolo Bit poster

    Messages:
    2
    I also tested
    $ default write "com.parallels.Parallels Desktop" "HID Host Hook.Scroll Sensitivity" X
    with different values from 1 to 120, in combination with SmoothScrolling 0 and 1

    This doesn't solve the problem.
     
  18. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    705
    Hey, does the command make a difference in the scrolling sensitivity at all? I use https://cpstest.org/scroll-test.php to measure the sensitivity.
     

Share This Page