Scrolling not as smooth as in v8

Discussion in 'Windows Guest OS Discussion' started by Patrick Mast, Aug 31, 2013.

  1. Patrick Mast

    Patrick Mast Bit Poster

    Messages:
    11
    Hello,

    Scrolling with 2 fingers on the mousepad is not so smooth as it was in version 8. Scrollbar in Windows moves with chunks. How can we get it smoothly again?

    Thanks!

    Patrick
     
  2. ØyvindS

    ØyvindS

    Messages:
    1
    Got the same issue. In Visual Studio 2012 in Windows 8 the scroll-speed is fast in some windows, while in others the scroll-speed is super-slow :( Kind of annoying.. Both on the trackpad and with my magic mouse.
     
  3. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Try this, should work around the problem.

    - start Regedit and expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\H ID subtree
    - fully expand both VID_203A&PID_FFFC&MI_00 and VID_203A&PID_FFFC&MI_01 branches and find Device Parameters keys
    - under Device Parameters set VScrollHighResolutionDisable and HScrollHighResolutionDisable values to 1
    - reboot Windows

    (This tip was passed on to me by 'serv' here in another thread).
     
  4. NamezaM

    NamezaM

    Messages:
    1
    Worked!

    I just want to pass along to everyone that this worked perfectly for me. I was extremely bummed when I updated to 9 and this happened. Thanks a ton Olivier!
     
  5. bucweat@rushpost.com

    bucweat@rushpost.com Bit Poster

    Messages:
    17
    I second that...

    This worked with Windows 7 64 bit. Trying in other versions also...I thought I remembered something like this happening before...is this a case of new version just like the old version?
     
  6. Robert Grether

    Robert Grether Bit Poster

    Messages:
    13
    Can't find the VIDs

    Olivier, I was really excited when I saw that you had solved this problem, but when I navigated to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\H ID subtree and fully expanded both branches and keys, I couldn't find either VID_203A&PID_FFFC&MI_00 or VID_203A&PID_FFFC&MI_01. There are only 4 things (sorry, don't know technical term) in Device Parameters: Default, FlipFlopWheel, ForceAbsolute, and Migrated. Any thoughts? I considered adding the VIDs, but didn't know if I should use Key, String, Binary, DWORD, etc.

    Much thanks in advance.

    Rob



     
  7. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Rob,

    Anyway this was a temporary workaround with those PD9 builds at that time.
    Since then, this is fixed and supported by a GUI switch in the VM configuration and you should not attempt to change anything in the registry anymore.
    See VM Configuration, Hardware, Keyboard&Mouse section, you'll find it easily. I had to UNCHECK that new setting (about smooth scrolling) to get things working like in previous versions (with Visual Studio 2012 & 2013 which doesn't itself support support smooth scrolling correctly - a pity).
     
    Last edited: Nov 21, 2013
  8. I'm You Know Who.

    I'm You Know Who. Bit Poster

    Messages:
    2
    Another thing that helps a lot is to go your mouse settings in windows and set the mouse wheel to scroll 1 line at a time instead of 3.

    So to recap:
    - Parallels > Config > Hardware > Mouse : Disable smooth scrolling
    - Parallels > Config > RAM : 2GB per MS Office requirements
    - Windows > Control Panel > Mouse : Scroll Wheel set to scroll 1 line
    - Windows > Reg Edit > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\VID_203A&PID_FFFC&MI_00 [and] VID_203A&PID_FFFC&MI_01\Device Parameters\VScrollHighResolutionDisable [and] HScrollHighResolutionDisable set to 1 just for good measures.
     

Share This Page