Shared Folders in beta5

Discussion in 'Parallels Desktop for Mac' started by STim, Apr 26, 2006.

  1. riri


    two questions:

    will it be possible to share folders with suse 10 as vm os? in beta6 this feature is not yet available. i hope it will be soon done. i can scp between suse and os x but it would be nicer to have a folder.

    second question: i can't install parallels tools. is that only possible once paralles is bought? i intend to buy soon but don't wan't to have to reinstall everything. i want to resize my vm harddrive for which i need paralles tool.

    help appreciated


  2. Adam


    Got it working

    Yes, that was it. I didn't realize that the VM had to be running. Thank you.
  3. bps1


    Shared folder problem

    I'm using beta 6 and shared folders doesn't appear to be working. I can see my home directory and my Idisk but when I try to click on the shared folders I get: \\psf\g is not accessible and that I might not have the proper permission. G is the name I have assigned to this shared folder. Any help?


  4. Patrick Lee

    Patrick Lee

    SMB sharing

    This may seem obvious to some, but if you are on a network or can set up a LAN, you can enable SMB sharing on another Mac, or a linux/unix machine, and both the Windows VM and and the Mac will be able to access their share, the mac by using the Go menu from the finder, and the Windows VM using Tools from My Computer to mount a network drive. This had the added benefit of providing a backup method (at least for files), if you are testing Parallels for new users.
  5. Jerry

    Jerry Bit Poster

    Another way of dealing with and sharing files, would be to implement the wonderful feature Virtual PC has, where you can just drag & drop files from your mac environment onto the VM environment, and visa-versa.
    Would it be possible for you guys to implement this feature, PLEASE?

  6. DrewDS


    Is there going to be correct free space reporting on shared folders?

    Copying stuff to them through explorer is fine, but some programs check for free space and when they see it reporting 0.97MB they say "no way!"
  7. snit


    Shared folders break when most VPNs are connected. Can you please implement shared folders so that they look like a real disk to the guest?
  8. Bit Poster

    Shared folder in Beta6 are slow and crashes windows explorer


    The sticky says "beta5" but my guess is that it also relates to Beta 6. I find the stability of Shared folders in beta 6 to be "limited".

    In the few cases where it works (with a winxp sp2 VM) it is extremely slow. And in most cases it crashes the windows Explorer ?

    What about drag-and-drop :) Now that would also be cool. But getting shared folders working properly would also be amazing.

    Keep up the good work (awaiting the next beta where keyboard mapping issues have been resolved, Shared folders and network connectivity solved as well..... then we might call it an RC instead).

  9. Bit Poster

    I've just found out that it only crashes the explorer on the first attempt to access the shared folders. On all subsequent access attempts it works although everytime i click on a folder it waits (4-8) seconds before displaying the results of the next folder.

  10. ahlgren


    I'm using Beta 6 and I can't share anything... the connection always falls apart.

    I tried creating a home network and sharing a folder from XP, but OS X can't quite seemt to recognize the folder on the network.
  11. Ricochet


    I have had mostly a pretty good success rate using the shared folders. They certainly don't seem to work particularly quickly for browsing, although the file copies were swift.

    It seems that the shortcut to the shared folders on the deskotp is recreated each time you launch the virtual machine? (I changed the icon and it always changes back). Also I tried mapping a drive upon login which went to the network path that the shared folders use, but that doesn't seem to successfully access them, whereas going back to the desktop and using the icon there generally works fine.
  12. ahlgren


    I've never once been able to access files from XP on the Mac side, using the shared folders. Sometimes -- although rarely -- the icon will bring up the folder I have chosen on the MacPro side, but never does it allow me to access anything before either shutting down, or displaying a memory-read error. I must be doing something terribly wrong.
  13. Bandito


    Its rubbish.
  14. davert

    davert Bit Poster

    I find it works at times but not reliably.
  15. janiner


    I find that it works quite well (my only need is to write from XP to OS X, so haven't tried to go the other way) except for one small problem. If I have suspended the VM, the first access to the Shared Folders shortcut will crash Windows. If I simply try to write to a shared folder I get a warning from the program I'm running (Quickbooks) that the directory I'm trying to write to does not exist. I've never let it try to create it but I'm guessing that would cause a crash too.

    If I instead shut Windows down instead of suspending the VM, the crash does not occur and all works as expected.

    This is in the updated version of Beta 6.
  16. michel


    Thumbs up Adam. I've tried everything possible on this thread with no success. I found your solution which worked very well. The only issue I have is with speed. Very slow but it's working!
  17. nicholst


    Explorer.exe crashes on Shared Folder open

    This is exactly what happens to me. However...

    ... I can't get this to work. As far as I know the drive isn't mapped, so I don't know how to navigate to that drive.

    When I use Explorer to open my \\PSF folder I get "... is not accessible. You might not have permission to use this network resrouce.... The network name cannot be found."

    Anyone made any headway on this?

    (*When* I'm on a network, I've been using Windows sharing from the Mac (host) to the PC (guest), but I'm often offline with no internet, and then that solution doesn't work.)

  18. FI_Flyer


    Firewire HD

    After reinstalling Parallels Tools and following the instructions here, I am now able to see the files on my (internal) Macintosh HD on my MacBook Pro. Unfortunately, I am not able to see an external (FAT32) 500MB HD that is connected with Firewire.

    Can someone please help? I need clear instructions -- especially on the OS X side as I am still fairly new to the Mac.
  19. jonrobs


    Problem with running simple apps from the shared folder

    I am running XP Pro Sp2 With beta 6 on an MacBook Pro 2.0Ghz with 2GB ram.

    I had downloaded MSDOS 6.22 (English) from MSDN's web site to the shared folder and this works great. My shared folder is called Vpc-Shared and it is stored in my documents folder on the mac. as soon as i doubled clicked inside XP Pro the Msdos extraction program my whole documents folder dissapeared from mac os. It looks like XP pro removed all my permissions to my documents. Resetting the permisions in Mac OS for this folder (using share points) solved the problem.
  20. Jay Levitt

    Jay Levitt

    I just started using Parallels at beta 6. I too cannot seem to get shared folders working. I see the Parallel Shared Folders shortcut on the XP desktop, and when I click on that in Explorer, I see the shared folder.

    The first time I click on that shared folder, I can see the files in it. However, once I attempt to access them from an application, or double-click them to launch the associated application, I get "[foldername] is not accessible[...]the network name cannot be found". If I try to copy the files directly in Explorer after rebooting, I get a read error of some sort (I can't duplicate it now).

Share This Page