Sluggish performance and long pauses

Discussion in 'Parallels Desktop for Mac' started by Mac421, Jun 12, 2007.

  1. Mac421

    Mac421

    Messages:
    3
    I am using Parallels v3.4124 on a MBP 2G with a Windows XP SP2 VM. The VM has 648 Megs of ram available, and plenty of extra hard drive space. I am normally in Coherence mode.

    I am experiencing really sluggish behavior in the VM. I spend a lot of time in Outlook 2007, so much of my experience is there, but I don't think it's just an Outlook issue. Symptoms include periods of time where each key press take 10-15 seconds to appear, then seems to speed up for no reason.

    I also can experience 10-15 second waits for windows to be repainted, or if I click on a particular message in Outlook.

    Since the MBP doesn't have a hdd light, I can't tell if it is swapping causing the problem, but when I look in both the XP VM and in OS X Host, it appears both still have memory available.

    Is this normal? Are others experiencing pretty snappy performance of Outlook and other apps?
     
  2. non-troppo

    non-troppo

    Messages:
    51
    Can you check in the OS X Activity monitor for Parallels AND windowserver activity?

    Do you have problems controlling your mouse / other apps when it happens in OS X?
     
  3. DerekS

    DerekS

    Messages:
    60
    When this happens to me I can speed it up by closing the Parallels Tools tasktray app.

    I was hoping for this bug to be fixed in 3.0. :(
     
  4. Mac421

    Mac421

    Messages:
    3
    OS X performance remains good while this is going on. How do I check the OS X activity monitor?
     
  5. mmischke

    mmischke

    Messages:
    155
    It's in your Applications/Utilities folder.
     
  6. mmischke

    mmischke

    Messages:
    155
    Have you tried the 4128 update? I don't know if it addresses the problem you mention but some posts I've seen suggest it includes several performance-related improvements. The one you mention could be among them. FWIW, 4128 has been pretty solid in my hands. I've been using it all day (trial version) and I plan to buy the upgrade tomorrow. I haven't used 4124, so I can't say anything about what's better or different in 4128.
     
  7. Rachel Faith

    Rachel Faith

    Messages:
    234
    I have problems for for the first 20 minutes on start up and then if its JUST been sitting for an hour or so. Lags on windows and then causes beachball on OSX.

    HORRID !!
     
  8. mecoolai

    mecoolai

    Messages:
    11
    Slow performance

    For some reason, windows keeps going through disk check in the beginning. After that, once window starts, everything lags, horrible....in activity monitor it hovers from 95% - 105% CPU usage....how do you even get 105!
     
  9. zzmad

    zzmad

    Messages:
    17
    Hi,

    I experience the same problem. 95%/100% processor at idle from parallel.
    I run it on a Macbook Core Duo 1.83 with 2GB ram.
     
  10. non-troppo

    non-troppo

    Messages:
    51
    Has anyone installed MacFUSE? Another thread suggests there may be a conflict.
     
  11. aidan

    aidan

    Messages:
    24
    I had the same pauses (up to 2 or 3 seconds) with Parallels 3. VM: XP SP2, 1.5GB RAM, fixed size virtual drive with about 2 GB spare. Running on Mac Pro 3GHz with 9GB RAM.

    Since then I have downgraded back to 2.5 (for another reason) and the pauses have gone away. It seems much more responsive (instant to activate a window). So I think there is an issue with 3.

    P.S. no MacFUSE
     
  12. STim

    STim Super Moderator

    Messages:
    942
    Do you guys see a spinning beachball when the pause happens?

    Can you open some Mac application and see if it's still responsive while PD is in that "pause"?

    Does it happen after some time of activity within Parallels Desktop? Or it happens immediately after VM startup?

    Do you perform some operation that involves some high HDD activity before these "pauses" start?

    Do these pauses fade away eventually or are they persistent?

    Can you please try rebooting your Mac, starting Parallels Desktop (without starting any Mac application) and see if "pauses" are there or not?
     
  13. wingdo

    wingdo Kilo Poster

    Messages:
    314
    Activity monitor gives a total as a percent of one processor core. If you have 2 cores it is quite easy to go over 100%. The Windows VM can literally take 100% of one core, and then there is of course the actual Parallels program running on the other core.
     
  14. Mac421

    Mac421

    Messages:
    3
    No beachball.

    Yes, Mac apps are still responsive while this is going on.

    I notice it very quickly after VM start. I normally suspend and resume my VMs, rather than rebooting them.

    Not really - just regular office 2007 work.


    They go in spurts for me - long periods of pauses and sluggish behavior, occasional good performance, then back to being slow.

    I'll try this.

    Thanks for your help!
     
  15. typ993

    typ993 Bit Poster

    Messages:
    17
    Parallels was a real slug for me until I went from 2GB to 3GB in my MBP. When starting up XP, the whole interface would freeze up, sometimes to the point where the machine just shut down. This was with build 3128. Once I added the extra gig, things improved considerably. However, I would often be using resource hogs like Omniweb and Mac Excel at the same time, so the extra gig has been nice in letting me work effectively in both Mac and Windoze.
     
  16. darreln

    darreln

    Messages:
    34
    i notice the same. I suspend my vm as well, and when I bring it back, it sits there for 1-2 minutes before it "kicks in"....this is repeatable for me.


    D
     
  17. non-troppo

    non-troppo

    Messages:
    51
    Activity monitor allows you to sample the parallels process - that may provide clues as to what is going wrong here... Just click on parallels in activity monitor and click "sample process"
     
  18. fso

    fso

    Messages:
    37
    My experience in the last 24 hrs has been that it is definitely slower than 3188, but not by a great deal.

    What I do find to be significantly slow(er) is when doubling clicking a file in Windows XP (under Parallels) to open up a file. It seems to hang for a couple of seconds before something clicks and the associated app then starts to launch. Before P3, it would just start to load the app straight away.

    Does anyone experience the same?
     
  19. looter

    looter

    Messages:
    24
    I'm seeing a severe lag in 2.5 3212. I hear the hard drive spinning up/being accessed all the time now as compared to whatever the build was prior to 3188. I Skipped 3188 and went to 3212.

    I get the beach ball. All apps on the Mac and the VM XP Pro SP 2 are severely delayed.

    I'll check activity monitor and see if it helps.

    I also installed Safari 3 beta and wanted to make sure it's Parallels not Safari 3b.
     
  20. sbnoble

    sbnoble

    Messages:
    2
    Shared folder slowdowns

    I've noticed two severe performance problems with parallels 3.0 for the Mac, which may or may not be related to this thread.

    The most severe one occurs when parallels tries to mount the windows drive on the mac desktop (it shows up with a network drive icon). When this happens, both the virtual windows environment and the OS X environment slow to a crawl or freeze up. There are with occasional moments of where things seem to work for a few seconds. But the problemlasts until Parallels is force-quit (if possible) or OS X is forcibly restarted (it won't log out or restart on its own while Parallels in in this state). Disabling the shared windows drive fixed the problem. I suspect that Spotlight or the Finder may be heavily accessing the shared drive, causing a critical performance bottleneck. But since the situation involves a substantial likelihood of freezing my MacOS X system, I can't afford anymore experimentation. This was on a new 15" MacBook Pro.

    Sharing a Mac folder in windows also has performance problems, though not as severe. When windows programs access files in the Parallels Shared Folder, it takes two to four times longer than it used to under Parallels 2.x. The windows programs also tend to freeze for up to ten seconds at a time during these accesses. Here I suspect the Parallels networking modules. My syslog shows the startup of DHCP/NAT, InternetSharing, and CiscoVPN from parallels. I'm not using any of those features (the virtual machine has its own static IP address), but piping traffic through all those modules could hose performance. This was on a 2GHz Core Duo 20" iMac.
     

Share This Page