Smart Select and Firefox

Discussion in 'Parallels Desktop for Mac' started by russv, Jun 7, 2007.

  1. russv

    russv Member

    I prefer to view my PDF files inside Windows but I do all my web browsing in Firefox in OS/X. I was really hoping SmartSelect would let me set Acrobat in Windows as the default and then Firefox would open PDFs that way.

    I was able to set PDFs to open in Windows by default and now double clicking one works fine but Firefox still uses Preview and refuses to see the "new" Acrobat.

    Anyone know how to fix this?
  2. STim

    STim Bit poster

    Go to Parallels Desktop menu->Preferences->Shared Web Applications and set the "Web Pages" choice to "Open in MacOS X".

    Assuming that Firefox is default browser in MacOS X, all web pages will be openinig by it.
  3. russv

    russv Member

    Thanks for the quick response Tim. However, that's not quite the feature set I was referring to (though there's another thread on that topic). I'm trying to use Acrobat as the default PDF viewer when downloading/opening a PDF from Firefox. I suspect this is more of a Firefox problem than Parallels but was hoping someone could help out.

    When clicking on a PDF link inside Firefox (Mac), there's no "Open With" Acrobat option - only Preview. I was hoping that perhaps even choosing Preview would somehow short circuit once the file went to be opened but sadly not. It ends up opening in Preview...
  4. mcowger

    mcowger Member


    This isn't happening that way.....I'm experiencing the same problem.

    I even went so far as to make 'Safari' an alias to firefox - no go, it still launched my renamed version (Safari.real).
  5. russv

    russv Member

    This sounds more like the other two threads -

    I'm not worried about the browser selected but rather the behavior of opening files from a link in the browser. I want to be able to tell Firefox (Mac) to open PDF files inside Windows.
  6. RCF2616

    RCF2616 Member

    File Associations

    Hey Parallel folks --- Suggest the following:
    A. Somehow get Windows apps (or perhaps selected subsets) listed in the OSX 'Open With' dialog listing so that the app can be selected by right-clicking of any existing file with the type/extension of concern, clicking 'Open With', clicking on 'Others', selecting the OSX or Windows app desired and checking the 'Always Open With' box.

    B. A dialog in Preferences similar to the File Type dialog in Windows Explorer where a given file type can be associated with a specific Windows or OSX app.

    BTW--- I installed the new 4124 using the activation code I received when I placed my advance order. The install went smoothly, and everything seems to be working fine!:) .

    For my install, I did the following: Closed my Windows XP Pro, shut down Parallels, as a precaution I dragged the Parallels '.app' files to the trash as well as the corresponding Dock icons. I installed the new Parallels, started XP in 'Safe' mode ( with the F8 key), installed the Parallels Tools, and re-started XP.

    (I used the 'Safe' mode because I'm using ZoneAlarm Security Suite (ZA), which is particular about installing .exe, .dll, and driver files into the Windows OS, and in 'Safe' mode, ZA is not launched. When I opened Windows, I got the usual ZoneAlarm dialogs as the drivers, etc., loaded, to which I selected 'Always Allow'.)

    Great job, all!

    Now you can focus on making the Workstation folks just as happy by making their VMs as great as the Mac's!

  7. jasonw

    jasonw Member

    This is a Firefox issue. I had the same problem when trying to get Firefox (Mac) to open PDF files directly in Adobe Reader (Mac).

    Here's what I did:

    • Set PDF files to save directly to the desktop by choosing "Save to disk" and "Do this automatically for files like this from now on."
    • Open Firefox preferences (Cmd-,), Content, File Types, Manage
    • Double click on PDF
    • Select "Open them with this application"
    • Browse to and select the application bundle you wish to use. If you want a Windows application this will be in ~/Documents/Parallels/Microsoft Windows XP/Windows Applications once you have opened the application at least once.
  8. russv

    russv Member

    Thanks Jason, that works perfectly. I had to remove my mimetypes.rdf file for some reason since my first try didn't actually cause PDF to show in the file type manager. But once it did, changing it as you said now causes it to open inside Windows.

Share This Page