Snapshot deletion slow, hard drive looks full

Discussion in 'macOS Virtual Machine' started by RyanG21, Jun 6, 2023.

  1. RyanG21

    RyanG21 Bit poster

    Running an iMac with macOS 13.4, Parallels Desktop v18.3.0 and Windows 10 (64-bit).
    If I launch Parallels and go to Action > Configure > General the Total size of my PVM is 198.14GB with 162.75GB being snapshots, 24.7 GB is Hard Disk and 10.6 GB is Reclaimable it says....
    If I launch Win 10 and go to Settings > Storage it shows 70.5 GB used and 184 GB Free
    If I click on C drive and get Properties it shows 70.5 used and 184 GB Free.
    I tried going to Action > Manage Snapshots > and deleted one of the 5 or 6 snapshots that was there, a dialog came up and asked if I'm sure I want to delete and I told it to go on and do it...problem is I see no other feedback and it doesn't look like snapshots are being deleted. I tried to delete another snapshot but it says a snapshot is already being deleted....the computer has been sitting for over a hour before I tried this by the way which I would think would be enough time to do what it needed to do. At one point I told it to go on and make a new Snapshot and it couldn't because it says a snapshot is being deleted. So whats going on here? how long am I to wait for a snapshot to be deleted? With the drive being completely full of snapshots it can't be a good thing right, figured it would just slow things down. What is best way to proceed from here? I don't need these current snapshots and they can all go bye bye as far as I'm concerned. Any ideas on what to do next or what to look at next?
  2. Trishna Oobeyram

    Trishna Oobeyram Staff Member

    Kindly check your personal message.

Share This Page