Software Update in Guest OS (Big Sur) doesn't see available 11.1 update

Discussion in 'macOS Guest OS Discussion' started by JonF9, Dec 28, 2020.

  1. JonF9

    JonF9 Bit Poster

    With a Big Sur 11.1 Host running Parallels 16.1.2 (49151):
    The Guest OS running Big Sur 11.0.1 (20B50) doesn't see new system software updates (11.1) from Apple.
    Console on Guest OS returns a number of errors, while the GUI just reports "Your Mac is up to date".

    For example:

    softwareupdated Product Evaluation: 041-87971 (041-87971.English.dist): Installation check failed: Error Domain=PKDistributionError Code=102 "ERROR_3" UserInfo={message=ERROR_3, type=Fatal, NSLocalizedDescription=ERROR_3}

    and others of varied kinds.

    Should upgrading inside the Guest OS be possible, does it work for others, could this be a setup-spesific issue at my end? Thanks for any pointers to solving this!
  2. JohnW58

    JohnW58 Bit Poster

    I too experience this same issue with the added inability to download or update apps in the App Store. I have an open ticket with support that has remained open for over a month now. Here is supports response "It appears that the case requires investigation on code level, so we escalated it to the Development Team."
    FYI, I also have a Catalina guest VM running on this same Host. It has the same Parallels guest configuration and it does not have the issues.
    JonF9 likes this.
  3. EstebanW

    EstebanW Bit Poster

    I've got the same issue. Running Parallels 16 in Catalina latest version, and Parallels 16.1.3 Pro Edition.
    The guest OS Big Sur doesn't recognise the latest release 11.2. It reports the OS is up to date.
    I've opened a ticket
  4. Gimbal

    Gimbal Bit Poster

    Same issue - 2018 MacBook Pro, clean install of macOS Big Sur 11.2 as the Host OS. Then installed Parallels 16 and created a VM with Guest macOS 11.2 from the Recovery Partition. A few days ago Apple release an update to 11.2.1 - I installed it on the Host OS, then after rebooting, opened the Parallels VM, and it could not see any updates. It just reported "Your Mac is up to date - macOS Big Sur 11.2".
  5. PeterL24

    PeterL24 Bit Poster

    Seeing the same issue.
    One guest is on Catalina and shows the update to 11.2
    Another guest that I have already updated to 11.1 does not show the update to 11.2
  6. Sven G

    Sven G Bit Poster

    Shut down the VM and add
    to the hardware boot order advanced settings: this fixed the problem for me (after booting the VM again, the update was available in Software Update)...
    RichardM32 likes this.
  7. JohnW59

    JohnW59 Bit Poster

    Alas, it did not work for me (update form 11.2 to 11.2.1 not offered).
  8. FrancoV1

    FrancoV1 Bit Poster

    Unfortunately, it didn't work here, with a Big Sur 11.0.1 VM. Host is Mojave 10.14.6, Parallels 16.1.3 (49160)
  9. RichardM32

    RichardM32 Bit Poster

    This worked for me; I had a macOS 12 VM not getting updates, rebuilt from 12.2.1 rescue disk, still no updates. Added this board id tweak and 12.2.2 update showed right up.

    Host: macOS 12.2.2 / Parallels Pro 16.1.3 (49160)
    Guest: macOS 12.2.1 w/ Apple hypervisor
  10. EstebanW

    EstebanW Bit Poster

    Worked for me. Many thanks
    My config is a MBP 16 running latest catalina version. VM with Big Sur was 11.2, and now found 11.4
    I've opened a ticket many months ago with Parallels but it was a bit useless.
  11. After Hours

    After Hours Bit Poster

    Nice. Worked for me (I also changed the graphics to be 'best for retina'), so two variables were changed. Was stuck at Big Sur 11.2.3 and getting reported as up to date. Now sees updates. Thank you.

Share This Page