Solaris 10/9 install cpu panic

Discussion in 'Other Guest OS Types Discussion' started by Scarts, Oct 30, 2009.

  1. Scarts

    Scarts

    Messages:
    2
    Trying to install Solaris 10/09 on an iMac running Slow Leopard with Parallels 4.0.3848
    I accepted Solaris 10 as the OS and accepted all defaults (including the 512MB RAM) - I have 4 GB RAM installed in my iMac.
    I get the initial boot screen, press enter, see a row of dots then the SunOS Release 5.10 banner then

    panic[cpu0]/thread=fec20160: page_unlock: page fee09c870 is not locked

    I've played around with increasing then decreasing guest OS memory and fiddled with the guest OS CPU settings but nothing seems to work.

    Any advice would be appreciated as I need to study Solaris 10 for my work, and I really don't want to have to move to a different virtualisation product that works with this guest OS :(
     
  2. TomokiM

    TomokiM

    Messages:
    1
    I saw same error with default 512M RAM setting for Solaris 10/09 on my mac mini 4GB RAM running Snow Leopard with Parallels 4.0.3848.
    For me, I allocated 768M and installation became able to proceed. However, after the installation, Solaris guest crashes right after GRUB screen and cannot boot :(
     
  3. Scarts

    Scarts

    Messages:
    2
    Found a solution but not what I wanted

    I submitted an official tech support query and have heard nothing. These forums are invaluable and I hope my post doesn't get deleted.

    I found another virtulisation product that runs on osx which supports solaris without issue - as it should as it's made by the same people so unfortunately parallels is no longer on my mac.

    If the problems ever get sorted out I'll be happy to come back to it - the speed and feature set are fantastic.
     
  4. schwartz

    schwartz

    Messages:
    54
    I've been using Parallels since the beta for the very first version and unfortunately they've always treated Solaris like it doesn't exist. I don't think they have ever replied to any of my solaris related questions whether it be on this forum or on the beta tester forums when there's a beta going on.

    Fusion is better for Solaris but not great. VirtualBox is light years ahead for Solaris support. full screen, seamless modes, etc. Which it should be since it's made by the same company.

    I use Parallels for my Windows vm's but either Fusion or VirtualBox for other OS's as Parallels is very much slanted towards windows only (which they excel at).

    Bill
     
  5. RandomWalk

    RandomWalk

    Messages:
    6
    I had the same problem with my new iMac under Snow Leopard. Parallels should remove Solaris from the list of supported OSs.
     
  6. MrBungleBear

    MrBungleBear Bit Poster

    Messages:
    9
    Same here - worked fine in v3, then I got distracted and updated it for v4 and only ran it once (and it worked fine) but now, in Parallels v5.0, it can't boot from the GRUB screen:

    panic: cannot open kernel/amd64/unix
    Press any key to reboot

    So, it starts up fine in single user mode, and there is no /kernel/amd64/unix file, in fact there is no /kernel/amd64 directory... But, I have not changed the install - the only change has been to version 5 of Parallels...

    What gives?!!

    G>
     
  7. Elric

    Elric Parallels Developers

    Messages:
    1,718
  8. Alexander Skwar

    Alexander Skwar

    Messages:
    1
    In the Sun Forums, I found a solution (which at least allows to pass by this issue): Assign more than 512mb to the virtual system!

    I gave it 712 MB and that works for me. In the Sun Forums thread, they say that 609 MB is the lowest you can go. Didn't try it - 712 is fine for me.
     
  9. VinodK

    VinodK

    Messages:
    1
    I had the same issue, for now i am using "/platform/i86pc/multiboot kernel/unix" while booting

    ---
    THIS IS DONE BY PRESSING SPACE BAR DURING GRUB COMMAND
    ---
     

Share This Page