Solaris on MacBookPro

Discussion in 'Parallels Desktop for Mac' started by xtothez, Apr 8, 2006.

  1. xtothez


    What should I set the display (video device, resolution) to? Can you post a guide on what to set during the install?
  2. c0l245


    macbook pro too!

    I'm looking for information on how to configure (Solaris 10 01/06) the video on my mac book pro as well. I was able to get it up and running, but the screen was enormous and I couldn't re-size b/c of the worst feature in OS X -- can only resize from the bottom right. I tested several configurations with the XSun set of drivers, but didn't find a good one. Also, the mouse wouldn't work. . .

    Anyone have the configuration that they used for video / keyboard / mouse on a MacBookPro?


    ------------- update ---------
    After a call to AppleCare, they were unable to give me the vertical and horizontal Sync rate for the 15" mac book pro, but they did give it to me for the 17" which turns out to be horizontal: 30 - 82 kHz
    vertical: 40 - 120Hz. Just by simply using the Xorg default setup it would come up on my laptop huge, so I re-did the configuration and choose an 800-600 resolution that seems to work fine. I haven't yet gotten the built in mouse to work, nor the USB mouse that I usually use, but now it's time to search the forums for those answers.

    Last edited: Apr 25, 2006
  3. rpjenner


    These were the instructions I posted in other threads, most of the keys seem to work except tilda (~), and the @ and " are the wrong way round. It works ok on a 20" iMac and I'm guessing 1024x768 shoul be ok on your macbook pro. The mouse might need changing though.

    After you've got it working, it's worth copying the /etc/X11/xorg.conf file so if you re-install Solaris you can just copy the file rather than having to remember all the details from below.

    Hope this helps



    I'm running Beta3 of the Parallels Software. I've installed Solaris 10 01/06 and got the graphics / keyboard and mouse working. You can see a screenshot at

    I used the following commands :

    and then the following entries (the --> denotes my comments - don't type these
    5 --> PS/2 Mouse
    Y --> emulate 3 button mouse
    [ENTER] --> default for /dev/kdmouse
    7 --> Generic 104-Key PC
    87 --> UK Keyboard
    [ENTER] --> for keyboard variant
    n --> additional XKB options
    6 --> Non-interlaced SVGA 1024x768
    2 --> 50-90 vertical sync rate
    apple20 --> identifier for your monitor
    y --> yes, you would like to look at the card database
    0 --> Generic Vesa compatible option
    [ENTER] --> to continue
    5 --> 4096K of memory
    ati1600 --> identifier for you graphics card
    4 --> the modes are ok
    4 --> 16 bits
    then say Y to write to /etc/X11.conf

    Then you should only have to logout and login again for the new settings to take effect (although with all the experimentation I've done, I may have had to reboot).

    I also had problems with some Solaris Express builds which wouldn't install (but I had the same issues on my Toshiba laptop as well - problem is documented at :
    the message is titled "X.cpio.bz2 : Odd Problem with various versions"

    It took about 40 minutes to install from the ISO image stored on the disk (I didn't use a physical DVD image).

    I going to try to create a flash archive from a later Solaris Express build and see if that works as I want to experiment with ZFS and also get Linux containers running under Brandz.

    Hope this helps

  4. keirnna


    Thanks again for posting this, it got Solaris working on my Mac Mini.
  5. brettw


    echo the above .....

    btw though its been silent in the opensolaris forum about solaris on macintel from what I've seen there is really good progress. I'm looking forward to getting a bootable sol10 as the only OS on the system.
  6. cadi9122


    Trying installation now...

    Thanks for the information! Keep updating Solaris news. :D
  7. gamars


    Solution to MacBookPro (MBP) for Solaris Screen resolution

    Looking around the web I found several xorg.config file from either Ubuntu or other distro... After playing a bit with then on my Solaris install I have been able to use the full 1440x900 full screen...

    thanks to this particular site:

    The relevant information in this file are:

    The monitor configuration:

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    HorizSync 31.5 - 100.0
    VertRefresh 59.0 - 75.0
    Option "dpms"
    Modeline "1440x900" 108.84 1440 1472 1800 1912 900 918 927 946​

    And the Screen specification:

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1440x900"​

    I hope this get you all running in full fledge :).
  8. gamars


    I just realized this configuration is broken (after updating the Parrallels software). Has anyone fixed it since?
  9. alvins


    I have it working - this is what you do -

    - login to terminal
    - type 'kdmconfig'
    - change the 'Xsun'
    - leave the vesa driver
    - change the monitor to a 'notebook 1024x768
    - change resolution to 1024x768 at 16.7mill colours.
    - reboot
  10. gamars


    That works, but you do not get the full 1440x900 resolution do you?
  11. alvins


    Don't know - haven't tried.
  12. zeker00


    30" Cinema Pro

    What would one use for the Apple 30" Cinema display for horizontal/vertical scan rates? I have Solaris10 with SUN CDE 1.6.2 booting and the window equals a 23" diagonal monitor - too big for me.:confused:
  13. Rainy


    What settings for xorg.conf and Parallels for Macbook Core 2 and Solaris 10?

    Does anyone have a Solaris 10 xorg.conf and Parallels screen settings that can get 1280x800 resolution on a Macbook? Using the posted Macbook Pro suggestions I can't get bigger than1024x768.

    Xorg.log shows:

    (II) VESA(0): Prepend User mode name (u) "1280x800" to validation list
    (II) VESA(0): Prepend User mode name (u) "1024x768" to validation list
    (II) VESA(0): Not using (U) "1280x800" 0.0 MHz (no mode is found)
    (II) VESA(0): Valid mode on top: "1024x768" 0.0 MHz 0.0 KHz, 0.0 Hz with --
    (--) VESA(0): Virtual size is 1024x768 (pitch 1024)

    Any help would be appreciated.
  14. sunapple


    Error trying to run xorgconfig

    I'm having a bit of trouble trying to intall solaris in parallels. I ran xorgconfig once and possibly chose a wrong setting, because the display ony showed the black and gray screen-door looking screen. I had difficulty returning to the command line, and just rebooted with the Paralles reboot button. Now when I try to re-run xorgconfig I get the following error:

    Cannot create directory /tmp/ .xorg.conf72

    can someone suggest a reason or solution as to why I'm seeing this error.

    Thank You.

Share This Page