Some keystrokes don't work

Discussion in 'Installation and Configuration' started by pjbusto, Feb 9, 2009.

  1. pjbusto

    pjbusto

    Messages:
    6
    I have Parallels 4.0 Build 3810 running on my new MacBook Pro Leopard. Windows XP Pro installed on the VM.
    I noticed at times certain keystrokes won't work.

    Once a single letter didn't work; "T" for example. After closing the VM and relaunching it was fine.

    Just now four letters don't respond when I press them, but all others do. "T, H, C, V" Those four keys, when pressed, do nothing. I can't seem to get them to work by minimizing, going full-screen, using other apps, nothing seems to get these keys to work except shutting down and restarting the VM.

    Thoughts?
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    just make sure you have the same layout on Mac and Windows, if you have some national layout, please install Boot Camp drivers for keyboard and select the same layout
     
  3. BetaBlocker

    BetaBlocker

    Messages:
    6
    Keystrokes

    I have the same problem. It's really nasty, cause it cost's lots of time to restart always the VM. As far as I know I have the same layout on both systems. I wrote some reports and got no anwer.
     
  4. Ed Stembridge

    Ed Stembridge Bit Poster

    Messages:
    18
    I'm having a similar problem, which seems to happen after I copy something from OS X and paste in PD/WinXP. The key mappings go haywire, and just typing (as in responding to an email) makes Windows go crazy - windows opening and closing, launches programs. Can't type anything, and have to close everything and reboot WinXP to fix it.

    Has happened three times today.

    What's up, Parallels?

    es
     
  5. BetaBlocker

    BetaBlocker

    Messages:
    6
    Today it's a mess! It's the fifth(!!!) time that I restart and there is always a different key that doesn't work. Sometimes the simple "t", then the backspace key, then a combination ctrl+1 that I need in a program ... This should not be a toy, people, I need it to WORK with! And time is REAL Money! I'm quite sure the IT industry would have collapsed long before the banks if the users would charge the time spend with wiry work arounds, odd reparings, tricky configurations etc. etc.
     
  6. smccord

    smccord

    Messages:
    2
    I am running into the same problem but with Quicken and the key pad not working on my iMac.
     
  7. BetaBlocker

    BetaBlocker

    Messages:
    6
    Still keeping restarting. I noticed that sometimes some keys not only don't work, but they set off different functions from the intended. For example: the "1" turns to be the tab key etc. It's a strange world ...
     
  8. BetaBlocker

    BetaBlocker

    Messages:
    6
    It's really ridiculous. Every time I start the VM I have to try out the keys to prevent surprises during work! And NO answer at all from the support.
     
  9. Sarah Bearse

    Sarah Bearse

    Messages:
    1
    Hi Everyone,
    I am having the same issue as is being discussed in this thread. It is extremely frustrating to have to restart Parallel Desktop everytime I find a key has stopped responding. I've also noticed that when this happens it can also stop the double-click operation from functioning in Windows. Is there any way to gain traction on this issue with the tech support staff?

    I am running:
    MacBook (2GHz Intel Core 2 Duo) OS X 10.5.6
    Parallels v 4.0 Build 4.0.3047, Windows XP Pro v2002 SP2

    Thanks,
    Sarah
     
  10. STim

    STim Super Moderator

    Messages:
    942
    Is there any specific sequence of actions that leads to such nasty behavior? I don't think I ever noticed this on my MacBook with 3810.

    From what you describe, I can only conclude that some modifier key gets stuck. Please, next time you observe such behavior, press Shift, Ctrl, Option, Command keys one by one. If my guess is right, this will unstick the stuck key. If it works - please let us know.
     
  11. Marco van het Hoog

    Marco van het Hoog

    Messages:
    3
    It just happened to me ... I am in coherence mode.

    a works,
    b doesn't work,
    c works
    d = "Show Windows Desktop"
    e = "My Computer" button
    f = "Search Results"
    g works
    h works
    etc ...

    Unloading and reloading the keyboard in Parallels doesn't solve the problem.

    I will be rebooting and lose a lot of time.
     
  12. Alan Shutko

    Alan Shutko

    Messages:
    4
    I have the same problem, and have had it since P4 came out. P3 never had problems.

    For me, it's often the case that modifiers are just plain lost. Intermittently, they are unrecognized. For example, Shift D often takes me several tries to get to come out. It seems to be more correlated with higher system loads.

    This is a problem when trying to type passwords, since they all need punctuation and uppercase these days, and you can't see when Parallels has dropped your shift key.
     
  13. Khronos IT

    Khronos IT

    Messages:
    2
    Modifier Keys (Shift, etc.) under Parallels 3.0 build 5636

    I'm running into a similar issue with Parallels 3.0 build 5636 - Shift and other modifier keys are intermittent. Sometimes they work, some times they don't.

    I reverted back to 5626, and everything seems to be working normally again.

    It's not a function of the Parallels tools, as I ran into the same problem when I uninstalled them in the process of attempting to troubleshoot. I brought up Notepad on Windows, and the same passwords that I could type easily in TextEdit on Leopard, were darn near impossible to type in Windows XP SP3 due to the problems with the shift key. Rebooting the VM did not help.
     
  14. Khronos IT

    Khronos IT

    Messages:
    2
    FWIW, Marco van het Hoog's problem sounds like his Windows key is stuck / being detected as being held down - the symptoms he is describing are the same ones I've seen when someone has a bad keyboard, and that key is stuck. (Win+D is Desktop, Win+E is Explorer, etc. - useful if you know about them and like keyboard shortcuts.) Whether it's actually stuck on his keyboard, or Parallels is just registering it as pressed, is another story...

    What I did NOT get to try is swapping in multiple keyboards for extensive testing - it was too critical for me to get back up and running, versus experimenting to the cause. I'm running 10.5.6 on a 2008 Mac Pro, and it was happening to me with both a Microsoft Wireless keyboard (with a USB pod for RF), and an Apple Aluminum Mac keyboard (I thought it was a bad keyboard at first, so I swapped it out, but the problem persisted).
     
  15. BetaBlocker

    BetaBlocker

    Messages:
    6
    No, there is definitely no "specific action that leads to" this behaviour. Of course you have to start MacOSX first, then you start the VM and you may guess which keys will work today and which ones will not ... As far as I can see, it can affect EVERY key and every time different ones!
    Sounds like sheer mockery to me when I read:
    "Easy
    Get complete, instant access to all of your programs, files and folders across Windows and Mac OS X
    in a single, seamless experience."
     
  16. Marco van het Hoog

    Marco van het Hoog

    Messages:
    3
    Hello ... it happened again :)

    I can confirm that none of the key are physically stuck.

    I changed the keyboard for an identical one from another Mac, and the keys still reacted the same.

    I don't have to reboot anymore, though. By just hiding parallels and playing for a couple of minutes with a Mac program, the keys in parallels get back to normal.
     
  17. nosodualie

    nosodualie Bit Poster

    Messages:
    27
    This is happening to me too. The several keys will suddenly stop workin after about 20 minutes. Rebooting is the only way to get it working again.

    Very frustrating/annoying.


    ANY fixes, speculative or otherwise?
     
  18. Kenny Smith

    Kenny Smith Bit Poster

    Messages:
    1
    Same problem for me. Mac OS X Version 10.5.6. Parallels Desktop 4.0 for Mac. Build 4.0.3810. Windows XP SP3.
    After 20 minutes of work in Microsoft Visio & Quicken on Windows XP, I noticed that:
    - the "e" key press started Windows explorer.
    - the "s" key press tried to save a file.
    - the "r" key press brought up the Windows run menu.
    My keyboard was acting like the "command" key was always pressed.
    So I pressed the "command" key and "e" key. Then Windows Explorer started as expected. After that, the "e" key started being an "e" again.
    Work around solution: while in Windows, press the "stuck" key combination to "unstick" it.
     
  19. jwjohnson99

    jwjohnson99 Bit Poster

    Messages:
    73
    I'm having the same problems on a Mac Pro (late 2006) with Leopard 10.5.6 and parallels build 3810. Mine acts like the command key is stuck. It is not physicially stuck - the computer just thinks it is. If I press it again a few times it sometimes fixes it, but sometimes I need to restart windows. Seems to happen after I have used the Command Shift 4 combo to do a screen capture. Quite annoying. It's the only real gripe I have with Parallels 4 at this time. I'm running XP 32 with SP3 installed.
     
  20. BetaBlocker

    BetaBlocker

    Messages:
    6
    After downloading of the newest Update (4.0.3844) the problem persists. Software programers proof again to be either one of the most cynical professional groups or one of the most sloppy ones. Thank you for the quick help!
     

Share This Page