SQL Server on Windows 11 - M1 MACS

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by Karthikeyan1, Nov 6, 2021.

  1. Karthikeyan1

    Karthikeyan1 Bit Poster

    Messages:
    1
    Hi Guys,

    I have M1 Mac with Windows 11 installed on Parallels desktop. I have tried to install SQL Server 2019, 2017 & 2014. But, the Database engine services is failing to install. I have attached the screenshots.

    Kindly let me know how to solve this issue.

    Thanks,
    Karthik.
     

    Attached Files:

    OveE, LeventY1 and TiagoC4 like this.
  2. LeventY1

    LeventY1 Bit Poster

    Messages:
    7
    I have the same issue and haven't found a solution yet
     
  3. Ahmed6

    Ahmed6

    Messages:
    1
    same here
     
  4. ThomasF28

    ThomasF28

    Messages:
    1
    Has anyone else figures out the SQL cross over issues with windows and parallels?
     
  5. BudR1

    BudR1 Bit Poster

    Messages:
    11
    Same problem for me. Really need an answer on this!!
     
  6. RaoulS

    RaoulS Bit Poster

    Messages:
    1
    I have the same issue. It looks like there are a few other threads on this but their fixes haven't worked either...
     
  7. BudR1

    BudR1 Bit Poster

    Messages:
    11
    I run the Act! CRM system in a Parallels system with my Intel MacBook Pro and using the new M1 you can't copy a VM over from one to the other and have to recreate it from scratch. In that process it would NOT install SQL 2019 which Act! - uses for the DB. I was able to finally manually install SQL 2014 and link it to Act! - even the latest version v24 and got it to work. Shouldn't be this tough and should install SQL 2019 normally but it doesn't.
     
  8. IanC15

    IanC15 Bit Poster

    Messages:
    6
    Hi Bud, I'm trying to get Act up and running. I was wondering if you had loaded it on one of the Windows 10 ARM builds, and then upgraded to Windows 11 ARM, or did you do a clean install of Windows 11 ARM and then load SQL 2014 first, then load Act V24?
     
  9. BudR1

    BudR1 Bit Poster

    Messages:
    11
    I did it on a new fresh install of Windows 11 ARM.
     
  10. BudR1

    BudR1 Bit Poster

    Messages:
    11
    Ian let me know if you want to speak off line regarding getting Act! - to work with Parallels.
     
  11. Savec

    Savec Bit Poster

    Messages:
    2
    Hey Bud, could you maybe help me with this problem?
     
  12. DanielD24

    DanielD24 Bit Poster

    Messages:
    4
    All - you can install Azure SQL Edge on Docker Desktop or a Linux VM running Docker and use that with your Parallels windows machine to run SQL.
    Most functionality of Azure SQL Edge is consistent with SQL Server 2019 - though there are some very noticeable issues. The first is that Windows Authentication is not available, but many applications use SQL Log-In anyway. The second is that DB Mail functionality is not available.
     
  13. BudR1

    BudR1 Bit Poster

    Messages:
    11
    Hi Savec: Yes IanC15 another forum member is now up and running. What version of Act! did you want to use with your M1 ARM system? -Bud
     
  14. Savec

    Savec Bit Poster

    Messages:
    2
    Hey Bud,

    I'm sorry for my late reaction. For my study I need to run MS SQL server 2019. I can't run it on Parallels because I think the M1 Chip doesn't work with Windows MS Sql 2019. Is there a way we can communicate with each other through an other platform btw?

    Hope to hear from you soon!
     
  15. BudR1

    BudR1 Bit Poster

    Messages:
    11
  16. MarcinP2

    MarcinP2 Bit Poster

    Messages:
    4
    So MS SQL 2019 works on M1 Windows ARM? How?
     
  17. BudR1

    BudR1 Bit Poster

    Messages:
    11
    No MS SQL 2019 doesn't work but MS SQL 2014 does. The issue was trying to use Act! CRM with Parallels and M1.
     
  18. Alexander24

    Alexander24 Bit Poster

    Messages:
    1
    MS SQL 2012 x32 works fine!
     
  19. YasarE

    YasarE Bit Poster

    Messages:
    2
    I tried sql server express 2014 not does'nt work. Which download link did you use?
     
  20. BudR1

    BudR1 Bit Poster

    Messages:
    11
    You have to use Act! v23 or earlier and then use SQL 2014 32 bit. The file in located in the installer folder.
     

Share This Page