Star Wars: The Old Republic

Discussion in 'Windows Guest OS Discussion' started by Jeaz, Dec 16, 2011.

  1. Jeaz

    Jeaz

    Messages:
    19
    Hey there,

    Bioware's new MMO is now live and I'm running it in OSX 10.7 with Parallels Desktop 7.

    It runs really well actually and I can run it on max res with most visual treats turned on using my mid-2010 27" iMac.

    BUT, there is a problem, and not something that's unique for this game, and that's the "spinning camera"-problem.
    Using mouse-look spins the camera uncontrollably. Also, occasionally, it locks the mouse buttons.

    There is a fix for this, turning off smart mouse. But that instead causes the cursor to disappear completely in the game.
    In turn, there is a fix for that as well, which is running the game in fullscreen windowed. But, that drains a lot of resources, and running the game using a VM is pushing it already, so you have to cut down a lot on the visual side.

    So, ideally, a fix for the SmartMouse would be lovely. This is as I said, not unique for SW:ToR but something I've seen in quite a few 3D games.
     
  2. gaygeek

    gaygeek

    Messages:
    1
    I can't get the mouse working right even with smart mouse off and in fullscreen windowed--it works, but the video shimmers as I move the mouse around, so it's not really playable. I also can't get the game to play right in bootcamp either--the video is all squished no matter the resolution settings.
     
  3. ilans333

    ilans333

    Messages:
    3
    Spinning Camera Problems with Old Republic

    I'm having the same issue.


    "spinning camera"-problem.
    Using mouse-look spins the camera uncontrollably.

    Also, occasionally, it locks the mouse buttons.
     
  4. jed100n

    jed100n

    Messages:
    1
    Thanks

    Thanks for the info on this guys.

    I use Parallels 7 (Windows 7 Enterprise 64 bit) on a late 2009 Macbook Pro and was wondering whether or not to buy this game on the basis that I wasn't sure it would work satisfactorily.

    I might hold off now.

    Mike.
     
  5. ReeceJ

    ReeceJ

    Messages:
    2
    Hey guys, the mouse works fine for me for some reason, but i've also got another question to ask.
    I've got a MBP with a 2.4ghz 4gb of ram and a 330gtm. Can you recommend settings for parallel? I'm fine with the settings for SWTOR :)
     
  6. AndrewJP

    AndrewJP

    Messages:
    1
    does any one know if you can run the Game on the Windows XP side of Parallels? if please let me know i had problems with the beta i could open the game in all the way through the character creation but no dice after that. the game froze in the loading screen each time. please let me know if you have any tips.
     
  7. cgmpowers

    cgmpowers Bit Poster

    Messages:
    2
    I'm getting an error code 7 and cannot run the game. I then tried to install the latest version of Active X and .Net stuff.

    I'm on OS X Lion, Parrallels version 7 and Windows 7 64 bit.
     
  8. FeltonL

    FeltonL

    Messages:
    1
    I'm trying to run it in XP on my machine. Character creation is giving me deformed renderings of the characters.

    Tried to advance out of it and the session black screens and locks up.

    Any advice would be appreciated.

    (Got a new '11 MacBook Pro, 8Gigs RAM (4 dedicated to Parallels), XP Pro SP3)
     
  9. ThierryP

    ThierryP

    Messages:
    13
    Hello,

    I got the same problem, mouse beeing uncontrollably and pointing always to top of my environment.

    The problem still the same with trackpad.

    I must reboot natively on my BootCamp Windows Seven to play correctly.

    Some help please ?

    Thanks
     
  10. Julusp

    Julusp

    Messages:
    15
    There is a workaround, plug mouse directly to VM.
     
  11. EdGonz

    EdGonz Bit Poster

    Messages:
    16
    Make sure you get the latest video drivers for Windows, that could help; I don't know if you've tried that.
     
  12. Julusp

    Julusp

    Messages:
    15
    EdGonz: The mouse problem discussed here is well known issue in Parallels Desktop. In most games the workaround with plugin mouse directly to VM helps, but there can be issue with missing cursor (for example Ufo: Extraterrestrials, in win 7 the cursor disappear, and in Win XP it causes screen flickering (need to change colors to 16bit)).
     
  13. ThierryP

    ThierryP

    Messages:
    13
    By plugin it directly, you mean desactivate "smartmouse" in Options / Advanced ?

    A definitive solution for SmartMouse to work with that games would be definitely appreciated Parallels Developers.

    Thanks.
     
  14. EdGonz

    EdGonz Bit Poster

    Messages:
    16
    Smartmouse 'off' just removes the mouse altogether for me - even in Full screen mode (even when Smartmouse is on, the pointer tends to disappear once in a while). I'm sure they'll update Parallels soon, but for now this game, at least in my case, can only be played in Bootcamp.

    My Win7 VM is: 2 CPUs, 3GB RAM and 1GB vRAM.
     
  15. Julusp

    Julusp

    Messages:
    15
    Forget about smartmouse.

    Here is OderWat's workaround from http://forum.parallels.com/showthread.php?t=113589 :

    Use second mouse (!) and plug it into an USB Port. Then enable that Mouse using the USB Devices Menu of Parallels 7. Windows will install driver software for the new mouse detected.

    After this you have 2 working mouses in Windows. And the USB connected one seems to just work as expected for mouselook and scrollweel funktions!

    Besides of this irritating problem I found that a lot of games work pretty well with my iMac i7 with Parallels 7 booting my Bootcamp partition based Windows 7 64Bit.


    This worked for me as well.
     
  16. Thacan

    Thacan

    Messages:
    4
    Updating Video Drivers

    How are Windows video drivers updated? Windows Device manager shows that Parallels is the video driver and I presume that is controlled by Parallels and Apple updates. Is there another way to update the ATI drivers?

    I am thinking that if I ran under Bootcamp that I would have direct control over the video drivers. If anyone has experience with this please comment. Thanks
     
  17. Thacan

    Thacan

    Messages:
    4
    Swtor

    I am finding SWTOR to be unstable under Parallels and Windows XP. SWTOR hangs up when video scenes are initiated. If anyone finds a combination of updates/settings that works with Windows XP and Parallels Desktop 7, please reply. As others have indicated I have a spinning mouse too and will try a hardwired as suggested.
     
  18. Julusp

    Julusp

    Messages:
    15
    No. When running Windows in Parallels (does not matter if bootcamp or virtual machine) the video card is always Parallels, only way to update it is via Parallels tools (that means waiting for new version of PD).
     
  19. MichaelaE

    MichaelaE

    Messages:
    1
    Hey, I have Parallel Desktops 6 and Mac OSX 10.6.4, and I have been trying to run SWTOR in Windows 7 but it is moving so slow it is impossible to play. Will upgrading Parallels and my Mac OS fix this problem, or did you make other changes to get it to run smoothly? I've already set the CPU to 2 for Parallels, but are there other settings I could change, or any settings I should change on the computer or game? I have a 2010 15 inch MacBook Pro. Thanks so much!
     
  20. EdGonz

    EdGonz Bit Poster

    Messages:
    16
    The latest version of Parallels allows you to set up to 1GB of video ram, this is supposed to help. Also, giving the VM more RAM also helps. There are mixed results here, some people can play the game just fine, and others (like me) can't play it even after throwing all those resources to the VM.
     

Share This Page