Steam stopped working, several other features never did

Discussion in 'Parallels Desktop 16 for M1 Mac Technical Preview' started by JaredJ3, Jan 28, 2021.

  1. JaredJ3

    JaredJ3 Bit Poster

    Messages:
    4
    I have installed steam, but when I open it, it only shows me a black screen. Only the header menu shows. And when I try to run a game (the .exe file) it pops up "Do you want to share macOS applications with Windows?" I must click yes to run the game, and then it opens the game in the MAC version of steam (or streams it from my windows version to Mac steam.) Steam ran perfectly the day I installed the technical preview. This is one of the only reasons I have parallels.
    I will post the other issues I've been having on a separate thread.
     
  2. PastorM

    PastorM Bit Poster

    Messages:
    4
    Stem star correctly in my Mac M1 and i can Download a game.
    But i have problems when i start the game its cant install: i try whith Age of empires
     
  3. DanielT22

    DanielT22 Bit Poster

    Messages:
    1
    I have this issue too.
    I have been unable to use Steam for the last 3 days. (But have not played anything for over two weeks, so unsure when issue first manifested)

    I use it on a new MacBook Pro with M1 chip, loading Parallels for a windows instance.
    This usually allows me to play windows-only games.

    However, since Weds I have not been able to get the Steam app to work at all.
    Parallels loads as usual and the Steam app 'wrapper' loads, but the content window inside the main nav is totally black.
    No info at all. When I try to click to different parts of the app it just blanks and non-responds.

    I tried updating software for both the Mac, and Parallels.
    I uninstalled and reinstalled Steam.
     
  4. TadL

    TadL Bit Poster

    Messages:
    4
    Broken for me too - was working well -
     
  5. ParallelsU542

    ParallelsU542 Bit Poster

    Messages:
    6
    Same issue here..
    Steam is loading ok but I get a white screen but big picture mode works
    Strange..and you guys see black screen, I see a white screen
     
  6. TadL

    TadL Bit Poster

    Messages:
    4
    Actually - I get white windows as well, with black borders. I just meant what was working very well is now unusable -
     
  7. ParallelsU542

    ParallelsU542 Bit Poster

    Messages:
    6
    What build of Win10 arm are you guys using?
    I am running dev build 21301.1000
    Build 21313 just came out, but has arm issues, according to this forum.
    I might try rolling back to build 21286, that one worked fine. Or it is just a bad steam update, which is hard to roll back
     
  8. BobW11

    BobW11 Bit Poster

    Messages:
    29

    Assuming you mean Windows not Steam. The Steam bug I've seen in some places when running Windows versions on Linux funny enough. It's some weird thing syncing with the browser. I wish Steam has a non-web option for low-tech so this is a non-issue.

    However, here is a tip for those with this issue: use "small mode"
    You can see your library at least.
     
  9. ParallelsU542

    ParallelsU542 Bit Poster

    Messages:
    6
    Yes correct, I was talking about windows mainly.
     
  10. GuillaumeP1

    GuillaumeP1 Bit Poster

    Messages:
    4
    Hi all, I confirm that
    • all Steam pages are blank
    • Steam is quite slow and takes a lot of ressources
    • It takes more than 10 hours to install a 200mo update of a game (1 minutes to download, 10hs to install the files)
    My setup
    • Last Parallels Desktop M1 Technical Previem
    • Last Window Insider version (21301)
    • Last Steam Client Update (14 feb)
    Do someone has a different configuration ?
    Everything was fine and I could play all Age of Empires Definitive Edition with my last set up
    • First Parallels Desktop Preview
    • Windows Insider 21296
    • Steam Client of 21 december 2020
     
  11. MeaghanH

    MeaghanH

    Messages:
    2
    I'm running Windows 10 Parallels M1 Technical Preview 21286 and installed the most recent update. Steam stopped working for me, too, with the latest Feb 14 update. I was able to stream play to my mac steam for local play but it didn't work for online. Unfortunately, after uninstalling steam for windows and reinstalling, i can no longer play the game because i can't access my library to redownload it. Hope there's a fix soon
     
  12. GuillaumeP1

    GuillaumeP1 Bit Poster

    Messages:
    4
    Hi,
    You can try in Big Pictures mode. It's working.
     
  13. BobW11

    BobW11 Bit Poster

    Messages:
    29
    Or small view as well.
     
  14. TadL

    TadL Bit Poster

    Messages:
    4
    No updates on this problem?
     
  15. BobW11

    BobW11 Bit Poster

    Messages:
    29
    Likely a Steam problem with embedded Chrome.
     
  16. TadL

    TadL Bit Poster

    Messages:
    4
    Except it was working very well - until a couple of updates ago. Maybe it's my imagination, but a few things seemed to work much faster and more reliably, a couple updates ago -
     
  17. ParallelsU542

    ParallelsU542 Bit Poster

    Messages:
    6
    Same issue. It's kinda of annoying, mainly since it was working well. I think it is related to the windows arm builds. I have been keeping track. Window 10 arm build 21296.1000 still works properly, ie steam pages load with graphics and all..but every build since then, including the current build 21322.1000, steam runs but just displays a white screen. I just setup 2 VMs..one runs 21296 with steam working and another one that always runs the latest windows 10 arm insider builds. This will help me keep track of when it might be fixed.
    Ps..Small mode and Big picture also work as workarounds for Steam but the cpu usage is higher.
     
  18. MikeH27

    MikeH27

    Messages:
    4
    Big picture works sorta.. but I can't uninstall some games now.. e.g. GTA 4 or DeadPool. Control Panel just directs me to steam, which I can't see. Big picture mode, I select the game, do the little gear/settings icon and say uninstall and it doesn't do anything.
     
  19. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    101
    Steam works again with Build 21327.
     
  20. JeromeL6

    JeromeL6 Bit Poster

    Messages:
    2
    I confirm that Steam works again Build 21327
     

Share This Page