stop windows 10 automatic updates

Discussion in 'Windows Guest OS Discussion' started by Levoy Hurley, Aug 23, 2016.

  1. Levoy Hurley

    Levoy Hurley Bit Poster

    Messages:
    46
    I am visiting a friend with a metered connection, so need to stop Windows from chewing up my friend's data. On a Win10 PC this would be easy - just go to the "Wi-Fi" option under Settings and tell Windows the connection is metered. But the VM sees the connection as Ethernet so there is nothing to set. I am running Win 10 Pro.
     
  2. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Hi, please check this KB for more information about VM connection to the real Wi-Fi
     
  3. Levoy Hurley

    Levoy Hurley Bit Poster

    Messages:
    46
    That doesn't help, Maria. That KB tells me to plug a USB wireless adapter into my Mac so I can download drivers. But I'm using the Mac's internal wi-fi adapter and don't even have a USB adapter I could plug in.

    Again, the problem is how to shut off the Windows auto updates. I don't care how. Right now I'm forced to turn off the VM network connection entirely.
     
  4. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    which version of parallels desktop are your running? If version 12 you can easily turn off windows updates from you parallels configuration menu. Go to Options< Maintenance < Check Start Maintenance and set a time and day. This will Block all updates until the specified time. If you are not using Parallels Desktop 12 you can just go into your windows 10 Vm and click the start menu and type "windows update settings" hit return or click the icon that comes up. when the window opens click advanced options and change "Automatic" to "Notify Me" and check the defer upgrades box. This will manually turn off the windows updates. After these changes restart the machine.
     
  5. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    I'd like just let you know that virtual machine that underlies Parallels Desktop does not have a wireless adapter.
    Parallels Desktop does not natively offer Wireless support, that is why you got an Ethernet in the network connection
     
  6. Levoy Hurley

    Levoy Hurley Bit Poster

    Messages:
    46
    Maria - I'm very well aware of the issue with wireless support; that doesn't help solve my problem. What is becoming apparent is that there is a huge hole in the Parallels configuration options that haven't caught up with Win 10. I can't believe I'm the first to bring this up - metered connections aren't all that unusual (though I've never had one at home). The only option I see now is to shut off the VM network connection entirely. I only use the VM for running Quicken Windows and the account downloads don't use a lot of data, but if I turn on the connection for Quicken, Windows will start downloading updates and I can't allow that. You have me between a rock and the ol' hard place.

    And btw - according a tech at VMWare, Fusion does not have this issue as you have the option to select "Wi-fi" for your Win10 VM, which gives you the options you need to limit downloads on a metered connections. And also btw, metered connections aren't just limited to wi-fi. (I haven't tried Fusion - yet - so I can't verify this claim.)
     
  7. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Did you try what I posted above? Just. Turn off windows updates until your on a good connection. It's very easy to do and with parallels desktop 12 it's right in your vm settings
     
  8. Levoy Hurley

    Levoy Hurley Bit Poster

    Messages:
    46
    Sorry, I missed your post the first time. The "Notify Me" setting in Win 10 is only for the installation - it does not stop the actual download. This was a change to Win 10 some time ago. There is no way to stop all downloads. I did shut off the upgrades (which is the bigger problem) but there is still network traffic with updates.

    The VM options settings for maintenance is interesting but there is one little problem - there is no option to turn it off entirely. Thanks for trying.
     
  9. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    If you check the defer upgrades box in Windows 10 update setting then go to your services and disable Windows 10 update service all updates are stopped and will not start again until you start them. This is exactly how my machine was configured. Also go a little deeper into the updates setting and you will see the option to send updates to other pic on the internet or on your lan. Disable this also and I promise you will have no updates taking place. I would not give you a solution that I haven't tried myself. I just set my machine this way again and monitored the network for any traffic.
    http://www.forbes.com/sites/gordonk...s-10-how-to-stop-forced-updates/#12ccff85d1f6
    See option one in the provided link about disabling the service
     
    Levoy Hurley likes this.
  10. Levoy Hurley

    Levoy Hurley Bit Poster

    Messages:
    46
    Thanks, dustin, that's exactly what I needed. Now I just have to remember to turn the service back on when I get home in a couple of weeks. (I actually found that Forbes piece in my search but Forbes is pissy about ad-blockers and I'm pissy about turning mine off. :mad: )

    And fwiw, I still hope Parallels will add some capability to deal with this now that Microsoft thinks we are too stupid to make our own decisions. (one of the many reasons I went all Mac at my house many years ago.)
     
  11. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Glad i could help.
     

Share This Page