Strange CPU behaviour - High Clock Speed / Low Utilisation?

Discussion in 'Windows Guest OS Discussion' started by JonS8, Aug 14, 2018.

  1. JonS8

    JonS8 Bit Poster

    Hi all, apologies for the detailed post...

    I'm running a Windows 10 VM (1803 build 17134.191) in Parallels 13 Pro on a mid-2012 retina MacBook Pro (2.6 GHz Intel Core i7).
    I am monitoring CPU usage and temperatures using Activity Monitor and Intel Power Gadget (IPG).

    - With the VM switched off IPG reports CPU temperatures in the 50-70 degrees (C) range and CPU clock frequencies scale up and down depending on demand as I use the machine as expected.
    - When I switch the VM on, the clock frequencies immediately turbo boost to the maximum 3.4 Ghz and remain there for the duration that the VM is active.
    - When the VM is active but idle (a minute or two after startup, around 5-10% cpu displayed in Windows Task Manager) IPG reports temperatures in the 80-90 degree range and with CPU utilisation of 5-10%, Activity Monitor reports CPU percentage of around 50% for the VM.
    - As soon as I perform any task on the VM that increases CPU usage (e.g. building a solution in Visual Studio, although something like opening Outlook achieves a similar response) CPU temperatures quickly hit the max 105 degrees and the clock frequencies as reported by IPG start throttling back to prevent heat damage. Task Manager in Windows will report up to 100% CPU utilisation, Activity monitor up to 400% for the VM and, strangely, IPG rarely exceeds a utilisation of 30%.
    - As soon as the task is complete and the temperatures drop a little, the clock frequencies return to full Turbo Boost of 3.4 Ghz.

    Essentially, the CPU throttles as soon as I try to do anything on the VM and my machine constantly runs hot.

    - I have created a brand new Windows VM running the same build with no additional software installed and this does not exhibit the same problem (the clocks correctly step down when idle).
    - I have tried to boot my main VM into safe mode but this crashes during boot!

    If anyone can offer any ideas to help debug this I'm all ears as I'm running out of ideas?!?


    Idle-IPG.png Idle-TaskManager.png Idle-ActivityMonitor.png Loaded-IPG.png Loaded-TaskManager.png Loaded-ActivityMonitor.png
    RomanS4 likes this.
  2. KrisJ1

    KrisJ1 Bit Poster

    I am seeing the exact same behaviours with PD 14.1.3 (45485) with various versions of W10:

    CPU continually pegged at max frequency (or close to it) while overall utilisation is lower than 5%. Since I'm running the illustrious i9 MBP from 2018, this sort of thing means fans are constantly spinning and fans are maxed out with temps close to 100C...

    Not ideal.

    No manner of tweaking assigned cores, re-installing Parallels Tools or changing hypervisors seems to help. Changing windows 10 Power mode or even the power plan has no effect.

    This happens with or without an eGPU pro connected.
  3. Dean Herbert

    Dean Herbert Bit Poster

    I'm seeing this as well. This only happens with one of my windows VMs, and not others for some weird reason... even other Windows VMs on the same windows version. I managed to somehow fix it yesterday for almost 18 hours - thought I had a permanent solution... but in the morning it had returned to old behaviour.

    Here's a graph where the VM was running basically the whole time. The return to full clock speed happened overnight while I was asleep:

    Screen Shot 2019-12-25 at 9.57.27.png

    I've checked all settings and cannot find a good explanation for this. Tried Parallels and Apple hypervisor; disabling adaptive mode etc.
  4. Dean Herbert

    Dean Herbert Bit Poster

    On doing some trial-and-error testing I have discovered that this can be traced to usage of parallels file sharing. I've filed a support ticket with full details, but if this does affect anyone else, a solution can be to check what you are accessing via a parallels file share and whether those accesses are getting the VM into a bad state.

    In my case, I can 100% reproduce by opening a Visual Studio solution from a parallels file share. It does not recover until closing visual studio (closing the solution alone is not enough).

    Previous reproduction of this issue was possible without visual studio open. It occurred overnight, so I can imagine that something like Windows Search Indexing was hitting the same issue.

Share This Page