Suggestions on X11 tweaking (OpenSUSE 11)

Discussion in 'Linux Guest OS Discussion' started by heiko, Oct 26, 2008.

  1. heiko

    heiko

    Messages:
    2
    Hi,

    I've grown tired of X11 not working in parallels, thus I'd like to do some tinkering. I installed OpenSuSE 11, which leads to X restarting shortly after login if Parallels Tools are installed. This can be addressed by setting color depth to 16 bit in xorg.conf:

    Set session type to "failsafe" (german: abgesichert), then log in, type "sudo vim /etc/X11/xorg.conf", type your password, type "/24", type "i", then set DefaultDepth to 16. Type esc, :wq, exit. Reset session type, log in again.

    My experience at this stage is that all while KDE starts up fine and everything seems to work, fonts do shrink to about 2 pt. This is not exactly comfortable to read, so I'd be happy to read your suggestions on how to fix this.

    Heiko
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    You mean KDE4, try to install KDE 3, there is no such problem
     
  3. heiko

    heiko

    Messages:
    2
    Turns out that I needed to manually set the dpi in KDE's System Preferences. After doing that, fonts look normal.
     
  4. mfreidel

    mfreidel

    Messages:
    20
    I just installed KDE4 and have the same small font issues after I installed PTools. How do you manually set the dpi in KDE4?
     
  5. John@Parallels

    John@Parallels

    Messages:
    6,343
    KDE Menu > Configure Desktop > Appereance > Fonts
     
  6. mfreidel

    mfreidel

    Messages:
    20
    Worked

    That worked - fiddled with a couple of the smaller fonts as I have my video settings at 16MB. However, best fix was forcing the DPI to 96.
     

Share This Page