Suppress Windows Key When Cmd+Tab Away From Parallels Desktop

Discussion in 'Windows Guest OS Discussion' started by kelmon, Sep 3, 2009.

  1. kelmon

    kelmon

    Messages:
    3
    This issue has been annoying me for some time but since the upgrade to Snow Leopard it now seems to be happening every time. When invoking the OS X Application Switcher via Cmd+Tab while Parallels Desktop is the front window and a Windows VM is running the Cmd keystroke is always received by the VM and results in opening the Start Menu. This means that whenever I return back to Parallels it is necessary to close the Start Menu before I can interact with the application that I had open in the VM.

    Parallels Desktop (4.0.3846.436204) is currently configured via the Keyboard Preferences to "Enable Mac OS X system shortcuts" yet this shortcut, or at least the Cmd aspect of it, is still being received by the VM. This should not happen.
     
  2. ChristopherP

    ChristopherP

    Messages:
    3
    work-around

    Yeah, this annoyed me, too. What I did was go to Parallels preferences when it wasn't running, and enter a custom keymap option to remap the command key to function as a 'shift' key instead of a 'windows' key. That took care of the problem.

    FWIW, I first tried to delete the key map which makes the command key map to the "windows" function, but simply deleting it didn't work. So I had to map that key to something else (i.e. a shift function), to over-ride the default.

    Chris
     
  3. ChristopherP

    ChristopherP

    Messages:
    3
    Oh, yeah, I moved the Windows key over to the option key, just so I can still open the Windows menu from there, if desired...
     
  4. kelmon

    kelmon

    Messages:
    3
    Yes, I think that has addressed my issue in a "workaroundy" kinda way. I did previous try deleting the Cmd = Win key mapping and was disappointed to discover that this did not seem to make a change. However, I didn't try mapping it to something else so I have now tried the Alt = Win approach and I think that does the business.
     
  5. nvrmore100

    nvrmore100

    Messages:
    21
    Nothing I try seems to get this to work for me. I have tried removing the sequence from both the Windows and Generic profiles (Windows is assigned to my VM) and also making a new one for Alt > Win. Both still result in the same annoyance...
     
  6. JayT

    JayT Bit Poster

    Messages:
    2
    This was driving me nuts but I finally found a combination that worked. I had to assign a different key to call up the Windows key and then also assign the Apple command key to something else as well. Seems to be working now. Start menu no longer pops up when I hit the command key.
     

    Attached Files:

Share This Page