suse 10.3 X fails after tools install

Discussion in 'Linux Guest OS Discussion' started by jondriscoll, Sep 8, 2007.

  1. drchevalier

    drchevalier Bit Poster

    Messages:
    3
    Also an issue with SLED 10

    I am using Parallels 5584. If I install Parallels Tools the X Server will not start. Forcing a start with init=3 on the command line brings up the console.

    I have attempted the fixes on these pages. NONE OF THEM WORK with this version of Parallels.

    I can launch the VM without Parallels tools but of course the screen is so small as to be unusable.

    I am seeking a solution to this clearly ongoing issue. I do have VMWare Fusion and from a tools perspective it is not perfect but at least the display resizes properly.

    Parallels works ok for Windows but is far from useful for Linux.

    Ross
     
  2. paric

    paric

    Messages:
    1
    I can confirm that following the instructions carefully and correctly in post #46 has fixed this issue for me.

    I'm running build 5582. (I'll be installing 5584 shortly.)

    In /etc/X11/xorg.conf, this is my "Modes" section: (bold section is what I edited)

    Section "Modes"
    Identifier "Modes[0]"
    # 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
    Modeline "1024x768_60.00" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync


    EndSection


    and this is my "Parallels Screen" section: (bold section is what I edited)

    #Parallels screen
    Section "Screen"
    Identifier "Parallels Screen"
    Device "Parallels Video"
    Monitor "Parallels Monitor"
    Option "NoMTRR"
    DefaultDepth 24

    SubSection "Display"
    Depth 24
    Modes "1024x768"
    EndSubSection
    EndSection


    After logging out, and back in, my Suse guest machine's display is properly sized, and Parallels Tools is still working.

    Thanks to Parallels Support for the good info in this thread.
     
  3. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Paric, thank you for the feedback. Glad to know this workaround did the trick for you.

    Best regards,
    Xenos
     
  4. ambda76

    ambda76

    Messages:
    2
    Linux tools build 5584

    Hi Xenos,

    I've a question 4U. I'm actually running build 5584 but I found into vmtools-linux.iso version 5582 of linux tools only. Is there also a new version (5584) of linux tools?

    tks

    Regards
     
  5. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello Ambda76,

    There is no special Tools version for the build 5584. Version 5582 of Linux tools is still used.

    Best regards,
    Xenos
     

Share This Page