Taskbar jumping around in Windows 7

Discussion in 'Windows Guest OS Discussion' started by PhilL, Sep 12, 2010.

  1. PhilL


    I thought this would've been fixed in Parallels 6!?! Whenever I go from full screen to Coherence and back and when I restart Windows 7 the taskbar sometimes would mysterous appear on the top of the screen and I need to drag it back down to the bottom. I am using Windows 7 on bootcamp.
  2. joevt

    joevt Kilo Poster

    Is the taskbar locked?
  3. whirlgirlz


    Taskbar and loss of settings: Parallels please address

    Forum searches show that no one from Parallels has addressed this issue - going back to Parallels 4! I'm in Parallels 5 and Stopping the Virtual Machine or Quitting Parallels RESULTS IN A LOSS OF SETTINGS.

    The following is from a Parallels 4 post - and is exactly the same issue I'm experiencing:

    The Windows Taskbar always reverts back to its initial state (loses all pinned applications, goes to the bottom of the screen instead of left, does not auto-hide anymore) whenever I restart the virtual machine.

    I tried to right-click on the taskbar itself, uncheck "Lock the taskbar", apply the changes I want (position and auto-hide), and then lock it again.

    Whatever I do, the pesky taskbar forgets everything as soon as I restart the virtual machine.
  4. whirlgirlz


    Found solution

    I contacted Parallels and this is their answer. It worked for me - and makes sense:

    Windows is also an Operating System like Mac so whenever you want to close Parallels Desktop you have to shut down Windows first.

    When Windows shuts down normally it saves all the settings.

    To shut down Windows click on Start Menu > Turn off Computer/Shut down.

    So the next time when you restart Windows it will show the same settings.

    Or it has to recover and reset the settings.
  5. PhilL


    Solution not applicable

    Actually my issue is completely different, because of two main observations:

    1) I always shut down Windows before I close Parallels. Always. No exception. So I believe Windows always save the settings.

    2) My taskbar, when it jumps, always jumps from the bottom to the top. I have never set the taskbar to the top so the jump is not "reverting", it is "hopping for no reason".

    I tried locking and unlocking the taskbar, which make no difference. I leave the taskbar unlocked so I can drag it back down when it has jumped to the top.
  6. petrovv


    PhilL, hello. I wrote you private message with some technical questions. Please, check it and reply me. I would be grateful.
  7. Lindsay

    Lindsay Bit Poster

    Same issue here guys with the taskbar moving with Windows 7 and Parallels 5. Any solution?
  8. petrovv


    could you tell about your problem: what actions did you do and how often does this bug occur? We're studying this bug now and any help is appreciated.
  9. StephenA


    I see this too, normally after rebooting. The taskbar gets moved to the top of the screen. My taskbar is locked. I have to unlock it, move it back to the bottom, lock it again. Then on a reboot it is back at the top again. It doesn't happen all the time. I run Win 7, 32bit in Windowed mode.
  10. Lindsay

    Lindsay Bit Poster

    Generally happens at the start of the day after turning on the Mac and opening windows after being suspended for the first time.
    Not as often starting windows if it was shut down.
    Windows XP that I also run never does this.
    Also never happened running parallels 3 with XP and windows 7. But in that case I had to use Vista type install for windows 7 if that relevant.
  11. rft


    Same Problem here...

    I have the very same problem. I had the problem in Parallels 5 as well. I do not remember having encountered the problem with Vista. I think only Windows 7 shows the problem.

  12. Mike Noble

    Mike Noble

    Experiencing the dsame problem

    We have 13 units running Parallels 5 with Windows 7 and Windows XP on each one. We have been experiencing the same symptoms sporadically on all Windows 7 VMs. FWIW, the problem occurs even with the Taskbar locked down and all changes disabled with Group Policy edits. Of course, you need unlock the system (unlock the GP edits) before you can correct the Taskbar position.

    I'm glad we aren't alone - we were beginning to suspect we had some pretty clever students. :)

  13. buxtons


    Just to add that I have the same issue. RUnning P6 with Win 7x32. Whenever I start the VM the taskbar is always set to the top and I have to change it back to the bottom. Have not been able to figure it out yet.
  14. EllwoodN

    EllwoodN Kilo Poster

    I am also encountering the Windows7 jumping task bar issue. In my
    case, it only started happening when I updated to Parallels 6. Never
    occurred in P5. Also note, that I use "widowed mode" exclusively and
    never use any other of the modes.

    Current setup:
    OSX 10.6.4,iMac9.1,4GB ram (2 GB assigned to VM)
  15. catdad

    catdad Bit Poster

    It happens to me, too (Paralells 5, Mac OS 10.6.4), most often after installing updates from Kaspersky or MS (I haven't kept a log so I can't provide more details). I have "bottom" set at my preference in the relevant control panel but sometimes after a reboot it's at the top
  16. FriedrichM


    Having the same problem here.

    Parallels 6.0.11822 running Windows 7 Pro on a MacBookPro 5,1 running OS X 10.6.4

    FWIW, I just recently upgraded from Parallels 4 running Vista, and never had the problem there. In the brief time I ran Windows 7 in Parallels 4, the problem never occured, and also not in the very brief time I ran the old Vista VM in Parallels 6.
  17. xmd

    xmd Bit Poster

    Same issue here since parallels 5, I thought I was the only one!

    I have a suspicion that it has something to do with Window size / aspect ratio for the VM? It seems like if I have more than one Win7 VM, it will only affect some VMs but not others. The only real difference is that all the VM windows are different sizes.
  18. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers


Share This Page