The activation key cannot be used with the current version of the Parallels Desktop!

Discussion in 'Installation and Configuration' started by jrumball, Jan 14, 2008.

  1. jrumball

    jrumball Bit Poster

    Messages:
    1
    After updating to build 5582 I get the following error "The activation key cannot be used with the current version of the Parallels Desktop!"

    I know I have a valid 3.0 key any ideas ?

    Macbook Pro 2.33 2GB
    OSX 10.5.1

    Cheers
     
  2. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Hello,

    there are two possible reasons of your problem:
    1. you have installed Parallels Tools 3.0 while your key is for Parallels Desktop 2.x.
    2. you have installed US/UK version while your key is for localized version or vice versa.

    You can send me your key via PM so I will contact OrderSupport about this issue.

    Best regards,
    Stacey
     
  3. Frank Hall

    Frank Hall

    Messages:
    1
    I upgraded from Build 3186 to 5582 but activation freezes. I have MacBook with Mac OS X 10.5.1 What next?
     
  4. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Hello,

    could you please specify how does activation freeze? Did you try to uninstall Parallels Desktop and then directly install Parallels Desktop 3.x?

    Best regards,
    Stacey
     
  5. arog73

    arog73

    Messages:
    2
    Attempted to upgrade from Build 5160 to Build 5584...

    Upgrade worked (or it seems to have worked...) now, when I launch Parallels Desktop, the software is asking me to input an activation key. I put it the one that I used for v3.0 Build 5160 and it says that the key is invalid!

    Help!

    Thanks much!

    Aaron Rogers
     
  6. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Aaron,
    do you have a localized version?
    For now build 5584 is available only with US/UK key. But there will be a localized build released soon.

    Best regards,
    Stacey
     
  7. toadstool

    toadstool

    Messages:
    12
    Cannot get latest update...

    I have been using build 5582 just fine (except for one bug regarding video memory) but I tried to check for updates today and it keeps coming back with the message "To download the updates... you must register your copy...", but it is Registered. In the About menu, it says "This is an active copy of Parallels Desktop." How do I get the latest update?

    Thanks,
    Joel Hegberg
     
  8. mdrutldg

    mdrutldg

    Messages:
    1
    Registered version 5582 asking for activation to upgrade

    I'm having the same issue as "toad". I've been running a registered version 3 - build 5582, which upgraded fine from the previous builds. As soon as I ask for "check" for upgrade from the Parallels menu, it tells me to register. If I go online to download directly, it askes for my email address and password, which I submit. It then tells me I'm not registered? I've made no changes to my system, whatsoever.

    MacPro (2006) 3.0 ghz
    16 GB ram

    Mike
     
  9. Dondi

    Dondi

    Messages:
    12
    Ditto! I'm on 5582 (USA) and I am experiencing the same issue described by toadstool and mdrutldg.
     
  10. Philip Brandes

    Philip Brandes

    Messages:
    9
    I am having the same issue. I have already registered my copy of Version 3 (5582 Premium), but got the same error stating I had to register. I actually followed the link to your site and re-registered using my valid activation key, and got the message "Your product was registered successfully." When I went back to run Check for Updates from within Parallels, I was AGAIN told that I needed to register before downloading updates.

    Please fix this issue.
     
  11. mike457

    mike457

    Messages:
    3
    ditto for me

    I contacted Parallels support about this, as I'm having the same problem. They promptly sent me a link, but it's a link to the version I have, 5582, not to 5584.
     
  12. MattBaker

    MattBaker

    Messages:
    17
    Me, too

    Same as the other folks... the latest update requires me to Register. But I have a purchased/activated copy already.

    Thanks.
     
  13. ajay

    ajay

    Messages:
    153
    I'm in the same boat. Parallels tells me to register my current copy.

    Update: I re-registered my current copy of Parallels and the message went away. Also, and alas, there is now no update available to me that works. I can go to the Parallels site and download the update but nothing happens when I click on the .dmg file. What gives?
     
    Last edited: Jan 22, 2008
  14. arog73

    arog73

    Messages:
    2
    Stacey,

    No...I don't have a localized version.

    One other thing that I've now noticed...

    I can't seem to downgrade!!! I tried uninstalling 5584 and going back to 5160, but every time I install 5160 (or 5582) I get 5584!!! Seriously...! I open 5584 .dmg...run the uninstall, reboot, then open the 5160 .dmg file, install that...then when I open Parallels and go to "About Parallels Desktop", it shows it as v3.0 Build 5584!

    Pretty strange huh?

    I've tried multiple .dmg files for multiple v3 Builds and any one I try gets me to Build 5584 which I can't activate (invalid activation key)!!!

    Any help would sure be appreciated!

    Aaron


     
  15. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Dear Customers,

    you should register your key on our website to use an autoupdate function.

    arog73,
    could you please provide me via PM with a key your are trying to use?

    Best regards,
    Stacey
     
  16. texeter

    texeter

    Messages:
    21
    Through a little trial and error here I have found that you must make sure that you have registered your latest activation key that you received when you upgraded to version 3. The key you received with version 2 of the software is not valid for version 3 and won't work. For me now the latest build is being downloaded as desired.
     
  17. Draklorien

    Draklorien

    Messages:
    2
    Same Problem

    I am currently trying to activate Desktop 3.0 build 5584 to fix the copy/paste issue between os x & windoze and now I am stuck with a valid 3.0 license key that isn't being accepted.

    Things I have tried
    1 - I already verified thru my original order that this was for 3.0 and not 2.5.

    2 - I don't have a localized copy as I did an uninstall and then reinstall.

    3 - I have tried to register my code per yet another thread and that didn't work.

    HELP!!!
     
  18. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Draklorien,
    to help you solve the issue, I need to know where you purchased the product.
    If you bought it from our web site, please forward me the order ID number and the registration mail via PM. Also please send me via PM activation key you are trying to use. I will contact OrderSupport about this issue.

    Best regards,
    Stacey
     
  19. Tonfelix

    Tonfelix

    Messages:
    17
    Same problem here as arog73:

    Since my copy&paste didnt work anymore, I tried to put 5584 "above" my current localized German 5582 install. Of course, the 5584 didnt accept my key anymore. But as Im trying to uninstall Paralles build 5584 and re-install 5582, everytime I check the software version after installing it still says 5584, and doesnt accept my key.

    - How can I solve this problem quickly?
    - Why is all this localized-version-with-special-key stuff necessary in the first place? It has been a remarkable pain ever since!

    I hope for quick help!
    Thank you.
     
  20. rb_stern

    rb_stern

    Messages:
    19
    Problem too

    I have what is essentially the same problem as many others in this thread. Yesterday I posted it to this forum under a different but related thread, but nobody has replied. Is there any chance that someone in the support team at Parallels (if there is one) could look at all these similar questions, and post an answer to what seems to be a frequently seen software problem to do with registration, activation keys and updates - e.g. in the FAQ section?. As well as my own unanswered thread (Problem updating/ registration) there are 3 others on the same subject in the last 2 days. It's very frustrating, and I had hoped for better support when I purchased this program.

    Richard
     

Share This Page