The mouse cursor does not work in parallels.Help!

Discussion in 'Parallels Client for Mac' started by toptop, Jan 18, 2019.

  1. toptop

    toptop Bit Poster

    Messages:
    3
    Good day!
    I have a problem, the mouse cursor does not work in parallels, I have Windows installed. I launch windows, do one click and write "Ctrl + Alt - to free the cursor" to me, I do this, the cursor appears again and after the click, again it writes to me "Ctrl + Alt - to free the cursor",
    please help me, what should I do????
    Thanks
     
  2. AJ@Parallels

    AJ@Parallels Kilo Poster

    Messages:
    752
    Hello toptop, Let us ensure that Parallels Tools are properly installed. Please follow https://bit.ly/2N1mrkW to install Parallels Tools. If you see reinstall or update Parallels Tools then kindly reinstall it. Kindly go to Actions--> Configure--> Hardware--> Mouse & Keyboard and change it to ' Do not optimize for Games '.
     
    howtheyearscondemn likes this.
  3. toptop

    toptop Bit Poster

    Messages:
    3
    Parallels worked fine, just a couple of days ago I started this problem!
    I did, like this, but nothing has changed, before that I had Automatic :Actions--> Configure--> Hardware--> Mouse & Keyboard and change it to ' Do not optimize for Games '.
     
  4. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    @toptop are you using any specific applications in your VM? Also please try these steps in order to resolve the issue.
    Let us know if it doesn't work for you and also the detailed issue description will be very appreciate.
     
  5. toptop

    toptop Bit Poster

    Messages:
    3
    Do you speak Russian?
    Maybe you can talk in skype, telegram, icq, jabber ?
    I did not solve the problem, which I did not do(((
     
  6. JasonF17

    JasonF17 Bit Poster

    Messages:
    14
    I am having the same problem now (on M1 with technical preview). Tried this and still nothing. I don't want to update parallels yet because that gave me more issues before. My mouse/cursor was working normal and all of a sudden nothing.
     
  7. JasonF17

    JasonF17 Bit Poster

    Messages:
    14
    updates ?
     
  8. MatthewB30

    MatthewB30

    Messages:
    1

    I too now have this issue, I have reinstalled tools and changed the mouse option to 'do not optimize for games'. Neither has fixed the problem. The cursor is there when hovering but as soon as I click anywere its disappears. Its literally everytime I click in windows the cursor vanishes.

    Any help on this would be great.

    Thanks,
    Matt
     
  9. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    403
    Hi, Please start Windows virtual machine and click on Actions(On the Mac menu bar) > Reinstall Parallels Tools and check if this works. Please refer to the knowledge base article https://kb.parallels.com/8969
     
  10. ChiN2

    ChiN2 Bit Poster

    Messages:
    4
    Hello, I got this problem as well, no idea how can I fix it out
    Anyone can help plz
     
  11. ChiN2

    ChiN2 Bit Poster

    Messages:
    4
    And I have clicked on Action on the MAC menu bar, but there unable to let me reinstall the parallel tools
    , the button here was dark. Can I know how can I go to the next step.
     

    Attached Files:

  12. ChiN2

    ChiN2 Bit Poster

    Messages:
    4
    Hiya officer,
    Any officer here can help me to fix it out, thanks, this issue has occurred more than a week already, I can't even work at home nowadays.
    I have tried many different methods to solve this problems, but it's sill exist bugs I think.
     
  13. BlainW1

    BlainW1 Bit Poster

    Messages:
    1
    I'm having the same issue: I open parallels and then the first time I click in windows the cursor disappears and I can't type or use the mouse. I have reinstalled the tools, and I have changed the mouse settings to do not optimize for games. What do I do next? It seems like a lot of users are experiencing this issue...
     
  14. howtheyearscondemn

    howtheyearscondemn Bit Poster

    Messages:
    1
    Hello all!
    TL;DR - you might need to configure 'Do not optimize for Games' in two places per VM, and I'm not sure if this is an issue with other guest OSs than macOS 12.4
    --------
    I am a new user of Parallels since about a month ago when I got my first MacBook Pro (2019 15" i9 32GB 512GB SSD Vega20) ;)
    I recently created a new virtual machine using the macOS recovery partition option in Parallels.
    The VM booted-up fine and I installed Parallels tools no problem.
    Then I noticed I had an issue where I could not see the mouse in the VM, just like the users in this thread.
    When I saw the recommendation to configure 'Do not optimize for Games', I remembered that I did enable that option somewhere, but only because I thought I would need it due to what I experienced with a Windows 10 VM using Excel. It turns out, I don't need that setting enabled for macOS.

    At first configuring 'Do not optimize for Games' didn't fix the "missing mouse issue" for me. After I configured 'Do not optimize for Games' in two places in Parallels, the mouse reappeared, and I am using a macOS 12.4 VM without issues!

    Here's how I disabled 'Do not optimize for Games' in Parallels:
    1. Open Parallels Control Center
    2. Right-click the macOS VM then select 'Configure'
    3. Select the 'Options' tab on the top then select the 'Full Screen' tab on the left
    4. Make sure to uncheck 'Optimize full screen for games'
    5. Select the 'Hardware' tab on the top then select the 'Mouse & Keyboard' tab on the left
    6. Make sure 'Auto-detect for games' is selected next to 'Mouse'
      1. Note: The option 'Optimize for games' will cause the mouse to disappear when the VM has focus
      2. Note: You may also be able to select 'Don't optimize for games', too, but I haven't tried that option
      3. Note: I didn't change anything on this tab for the 'Advanced', 'Keyboard', or 'Open Shortcuts Preferences...' settings

    I hope my experience helps someone else. Take care and cheers!
     

Share This Page