time synchronization and suspend/resume bug

Discussion in 'Windows Guest OS Discussion' started by friley, Jun 24, 2007.

  1. friley

    friley

    Messages:
    5
    I believe I've found a bug in build 4128, but I wanted to see if anyone else experiences this. I'm using Windows XP Professional SP2 as my guest OS. If I suspend the VM, and then some time later resume it, the clock in the guest OS is off by the amount of time the VM was suspended. If I shut down the guest OS rather than suspend it, the time is correctly synched. So it seems time synchronization doesn't work when I suspend/resume the VM. Is anyone else experiencing this?
     
  2. aguydude

    aguydude

    Messages:
    42
    This doesn't really sound like a bug. Sounds like Windows is storing time in RAM, so resuming will restore the old time. If set to check the time on a time server, it will fix itself after a while. I suppose restarting causes it to check the CPU clock, which means the time is then set correctly.
     
  3. shawny

    shawny

    Messages:
    1
    Experiencing same problem

    I'm seeing the same problem in the same build of Parallels 3. As to whether it's a bug or not, all that I know is that this was not a problem with the exact same XP SP2 VM under Parallels 2.
     
  4. miker51

    miker51

    Messages:
    41
    Bug or not...

    It's a bug. It was reported some time ago (no pun intended), and I thought that I recalled that it was fixed in one of the 3.0 betas. Must have broken again in the 3.0 release.
     
  5. friley

    friley

    Messages:
    5
    I got a reply from Parallels. It apparently takes "a few minutes" to synchronize. It took 15 minutes when I just tried it. Strange, I would think it would synch right away, then start the synch timer for the amount of time you have set in the preferences. Anyway, it appears I was just too impatient.
     
  6. Parabola

    Parabola

    Messages:
    17
    My PD 2.5 (build 3214) XP(SP2) VM only took 5-6 seconds to correct it's time sync after being paused.

    My PD 3.0 (build 4128) XP(SP2) VM took about 30-40 seconds to correct it's time sync after being paused.

    I did also notice diffent default Time Synchronization settings in Parallels Tools Center. PD 2.5 does not default to having "Keep time difference between primary and guest OS" checked, while PD 3.0 does have this Advanced option checked by default.

    Our Windows Domain Controllers provide time services for Windows clients, although Mac clients are set to time.apple.com (yes, I know: they should all point to same time server, but...).

    Also, both VMs are configured for Bridged Ethernet.
     
    Last edited: Jun 26, 2007

Share This Page