Tools for Solaris

Discussion in 'Other Guest OS Types Discussion' started by schwartz, Mar 5, 2009.

  1. schwartz

    schwartz

    Messages:
    54
    Have the tools for Solaris been improved so more than just the basic network driver is available? I'd like to be able to use full screen mode, shared folders, better mouse integration, etc. with Solaris in a Parallels VM.

    A few months ago I ended up switching to Fusion to get better Solaris support even though I liked my Windows VM's better under Parallels. Since I can't run both together and I need Solaris for work every day I didn't have much choice. Still keeping my fingers crossed that Parallels starts providing better Solaris support so I can change back :)
     
  2. beta_vanjab

    beta_vanjab

    Messages:
    4
    Add me to the waiting list for better Solaris support.

    Aside from parallels tools, why can't I use more than 512M of ram when running OpenSolaris? It panics during boot if more ram is allocated.

    Am I missing something or there is a bug in VM that is not allowing more ram than 512?

    Thanks,
    Vanja
     
  3. rhlrx

    rhlrx

    Messages:
    3
    I've got a VM of Solaris 10 working pretty well for me. The installation itself was a snap -- installed right from the Solaris ISO I downloaded.

    Once I manually installed the network driver (RTL8029) off the Parallels Tools (Other) image , the VM became accessible on the network. I'm masquerading using "Shared Networking" with DHCP so the VM has a 10.211.55 address.

    Video modes were an issue -- took me several hours to get that usable. It comes up by default in some huge resolution which causes Parallels to enable the scroll bars. The trick is to generate a xorg.conf file using /usr/X11/bin/xorgconfig (puts the config file in /etc/X11).

    There are significant issues with Solaris and a newly-configured xorg.conf file. As far as I can tell, you don't really know how it's going to behave until you actually reboot Solaris (DON'T just kill the X-server and let it restart). I went round-and-round (and round) with apparently bad resolutions (the X-server died when I tried to log in) -- rebooting seemed to be the solution. Right now, I have the VM running on an attached monitor, Full Screen @ 1600x1200. No guarantees, but here are what I think are the important parameters (NOTE: DON'T use these on a ~real~ monitor, only for the Parallels Virtual Machine' monitor):

    (incomplete xorg.conf)

    Section "Monitor"
    HorizSync 0-250
    VertRefresh 50-70
    ...
    Section "Device"
    Identifier "Generic VESA"
    Driver "vesa"
    ...
    Section "Screen"
    Identifier "Screen 1"
    Device "Generic VESA"
    DefaultDepth 24
    Subsection "Display"
    Depth 24
    Modes "1600x1200" "1280x800" "800x600" "1440x900"
    ViewPort 0 0
    Virtual 1600 1200
    EndSubsection
    ...

    Note: Switching resolutions on the fly (w/ gnome-display-properties) appears to be quite broken.

    I haven't tried to get sound working. I don't think they have Shared Folder support yet, but you could NFS if you wanted to. I've been successfully SFTPing between my Mac and my VM to transfer files. Don't think they have mouse integration working either.

    I've configured the VM to use both of my CPUs (and it seems to be taking advantage of them). The VM is also configured to use 768MB of memory (and I think it is). I have the Adaptive Hypervisor enabled and Parallels is optimized for the virtual machine performance. I optimized power consumption for "better performance."

    I'm using Parallels Desktop, Build 4.0.3844. My VM host is a MacBook Pro 2.0GHZ w/ 2GB RAM, running Tiger (10.4.11) with the latest software updates. My installation of Solaris is: SunOS 5.10 i86pc i386, installed from the sol-10-u7-ga-x86-dvd.iso.

    Hope this helps somebody.
     
  4. David Lethe

    David Lethe Bit Poster

    Messages:
    7
    You got solaris 10 to work? Please more details

    Hi:
    I would very much like to know which solaris distribution you used, exactly, and whether it was 32 or 64 bit. I've tried multiple distributions, always took the defaults (with 512MB RAM), and they always blue screened after I install the O/S on the first boot.

    I know you need to change the networking parameters, but I am unclear on where in the process exactly I do it. I.e, do I build the VM before installing Solaris without a network card, or do a default installation, then change the virtual machine before the first boot to the HD to remove all network cards so I can install the add-ons?

    Thanks
     
  5. rhlrx

    rhlrx

    Messages:
    3
    I used the latest 32-bit distribution listed in my previous post (sol-10-u7-ga-x86-dvd.iso). Don't really know what else to add. When I installed it, I just told Parallels to add a new virtual machine and point it at the ISO. Everything went pretty smoothly after that.

    As I recall, I told it I wanted a networked installation from the get-go (just pretend like the network interface is going to work right from the start). Of course, it couldn't find a NIC driver until after I manually installed the RTL8029 driver (which I put off for several reboots, as I recall). I didn't remove ANYTHING from the kernel, particularly any of the other NIC drivers.

    As I mentioned, was getting the virtual screen to be something besides outrageously large (> 1600x1200). One thing different about my installation is that I'm still back in the middle ages running Tiger. From what I can tell, the latest version of Parallels (4) is "a must."
     
  6. Paul Smith @ BB

    Paul Smith @ BB

    Messages:
    1
    Any advice regarding networking if the tools fix isn't working (ie I mounted up the cd and ran the .../SOLARIS/network.sh script)

    Just don't see a network interface (the /dev/ni0 file is there, but won't become active, ie "ifconfig ni0 plumb" etc fail)

    My setup is as follows (and pardon me if I miss anything, state anything too obvious as I'm new to parallels/macs);

    Macbook, Parallels 4, Solaris 10
    Parallels network set as "shared" (I've also tried Bridged ethernet)

    The "network" consists of a crossover cable, connected to a Sun server (the idea being to jumpstart from the laptop).

    Would be very grateful for any advice !
     

Share This Page