Trouble with USB "busy signal" using build 3.5160 and OSX 10.4.10

Discussion in 'Windows Guest OS Discussion' started by sandman, Oct 10, 2007.

  1. sandman

    sandman

    Messages:
    9
    HI,
    Let's see MacBookPro Intel duo core,etc 3gig mem, using Win XP home. Parallels 3.5160 build. (If you really need more info I'll look it up). I have installed Tools.

    I've set up Parallels 3.0 and Win XP (home) just so I can keep the aviation databases current and updated for my Garmin GPS. I know it worked ( earlier 2.x versions) before I upgraded to 3.0 but, since, no joy.

    Parallels does recognise the Garmin GPS (looking under devices and USB) but, then I keep getting an error that says the USB is being used by another device, etc.....

    Whenever I try to run the update software the USB is not found and no connection with the GPS.

    I have tried to search this forum but all I can find is a fix for ver 2.5(?) and build 3134 ( i think).

    Any ideas, or links would be appreciated.

    thanx, dave
     
    Last edited: Oct 10, 2007
  2. Hugh Watkins

    Hugh Watkins

    Messages:
    943
    essentially the Garmin is an external memory unit in this context
    so try

    PD > Menu >> devices >> Shared Folders >> Add

    to make it look like a network folder

    this is a guess
    please reply to say if it works or not

    good luck

    Hugh W
     
  3. sandman

    sandman

    Messages:
    9
    Hugh,
    Thanks for the reply. I have tried a "bunch" of different things, including trying to find my around your suggestion.
    The best, so far is PD recognises a new USB device called "Garmin International" and asks if I want it to be used with the VM (name). I click YES........Then I get the message the device is being used by another application and to disconnect and/or turn it on again...then again...then again, etc.

    If I try any of the update programs themessge are like "USB is not found", "no device connected" kind of message. Thanks anyway...Sure wish Garmin supported Mac's
    thanx, dave
     
  4. Hugh Watkins

    Hugh Watkins

    Messages:
    943
    exactly
    it needs to be shared

    or find it in the Mac OS file system and right click eject
    do not use the Windows "found new hard ware" if a VM

    use Parallels to control the VM

    Hugh W
     
  5. sandman

    sandman

    Messages:
    9
    Hugh, thanx again.
    I am easily confused at times; this being one. I have tried turning on the Virtual Machine with NO programs running in OS 10.4.10. There are NO USB devices plugged into the MacBookPro (the only exception is when I plug in the GPS for the update) Parallels then does recognise the Garmin as a USB device but I only get the "being used by another application" error. There are two separate programs for updating the Garmin neither one of these will recognise a USB device.
    Am I going to have to try and revert back to an older version of Parallels to again get this to work?
    Since I only use Parallels to (try to) update this device, should I see about just using BootCamp and installing my version of Win XP that way? I Really have a need to update my databases to stay current (FAA legal).

    Thanx, dave

    ***Should I post this in another thread? Really a newby here, thanx***
     
  6. Alicia

    Alicia Parallels Team

    Messages:
    683
    Hello,

    sandman, please, check this article.

    Best regards,
    Alicia.
     
  7. sandman

    sandman

    Messages:
    9
    Hi Alicia,
    The first article that I found concerning this problem was the one you linked, thanx.
    Maybe I should go back to version 2.5 ( is there a way?)

    I am using version 3.5160, since downloading the new version, is the start of my problems.

    I need to add that Parallels Does find the USB device "Garmin International" and asks if I want to use it........Then I get the message being used by another application?

    Thanks anyway,
    dave
     
    Last edited: Oct 12, 2007
  8. Alicia

    Alicia Parallels Team

    Messages:
    683
    sandman, please, check your PM.

    Best regards,
    Alicia.
     
  9. sandman

    sandman

    Messages:
    9
    Here is an update of trying to get the USB "being used thing" solved.

    I deleted Ver 3.0 5160 and thanks to Alicia I was able download Ver2.5 and build 3214. This seems to be the version that was clear of the "USB being used by another Application"

    The hardest part was locating my original unlock code to install ver2.5.3214. In installing WinXP again, I found I now have used up all my installs, ha.

    I tried deleting the USB controller and reinstalling;this gave me a box to check, asking if I wanted to turn off usb for OSX and use for WinXP, "yep, that's what I want." Still doesn't work.

    Downgrading to the 3214 build does not stop the USB errors. I'm thinking it has to be a 10.4.10 thing??

    A sidebar to this is, I did find that Garmin now has an updater for the Mac...it works great, but it is only for updating the firmware. I'm using the Garmin 495 for aviation and the FAA is pretty picky about having all your databases current. There are still about 5-6 databases that are only offered in .exe and these are updated as often as every 28 days. These are the ones I really need Parallels and WinXP for.

    Guess I might as well really confuse things and reinstall ver 3.0 5160, downgrading versions, doesn't solve the (my) problem.

    By the way, I have no other problems with Parallels, just this.

    Sure could use some help on this one,
    thanx, dave
     
  10. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello sandman,

    Could you give me a link on Garmin GPS you are using? We'd like to know its technical specifications.

    Best regards,
    Xenos
     
    Last edited: Oct 16, 2007
  11. sandman

    sandman

    Messages:
    9
    Xenos,
    Thanks so much for the interest. Here are a couple of links for the Garmin 496. One for the unit itself and another for the downloadable firmware Updater. For what it's worth I'll include a link for the PC based subscription databases. Thanks again, dave

    The link for the Garmin 496 specs: https://buy.garmin.com/shop/shop.do?cID=156&pID=6426

    This is the download link for the Garmin GPS updater for Mac's:
    http://www8.garmin.com/support/collection.jsp?product=999-99999-27

    This is a link for the subscribable PC based databases: http://shop.garmin.com/aviation/databases/
     
  12. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Sandman, I'm sorry to say that your issue can not be fixed in existing PD versions. Parallels programmers will eliminate the problem in the future version. Please excuse us for the inconvenience caused.

    Best regards,
    Xenos
     
  13. spot the blip

    spot the blip

    Messages:
    19
    sandman, I have exactly the same problem with my Garmin 296. It all worked fine until I ended-up with OS X 10.4.10 and PD 3.0. I scoured the web trying to find a fix but to no avail and would agree that it appears OS X is the weak link and not PD. Tech support finally figured that there was nothing that could be done until PD was updated. I am now just waiting for the next PD update. Anyone know when that will be?
     
  14. sandman

    sandman

    Messages:
    9
    Spot,
    Garmin does have a firmware updater for Mac, try the link above. I'll have to find a Win PC machine, I guess, so I can update databases, temporarily... " Uh, can I borrow your PC for a few minutes? I promise I'll flush..."

    In a twisted way, I am somewhat relieved to know this isn't just my usual incompetance and the issue is not unique to my setup, (heck, it could be), I'm just flummoxed.

    I appreciate the help and suggestions from everyone and eagerly anticipate this being resolved with 3.1 and not 4.0, just jokin'...;-)

    Now, I think I'll go melt some sand and blow some glass.

    dave
     
  15. rklutts

    rklutts

    Messages:
    4
    USb device is busy

    I had just started another thread n this when I found yours. I'm in the same boat and have to use Boot Camp to update my 496. I hope PD fixes this soon.

    Ron
     
  16. Nahum Sloan

    Nahum Sloan

    Messages:
    7
    I also have a Garmin 296 (updated as of 10 minutes ago) a Mac running 10.4.10, Parallels 3.5160 and an open incident with Parallels support. Just to note that there is no problem getting the card recognized for for my wife's Garmin GNSX4XX. I think I've gleaned from this thread that my incident will remain forever open because there is no resolution in the current version of Parellels although I don't know if current means 3.6 or 4.0. It's a shame because the virtualization works so well and the only thing . . . etc.
     
  17. rklutts

    rklutts

    Messages:
    4
    Usb is busy

    I tried VMWare and my Garmin 496 and it works just fine. I wished Parallels would explain why they won't fix this anytime soon.
     
  18. Nahum Sloan

    Nahum Sloan

    Messages:
    7
    Bizarre indeed. In another forum on this site someone noted plugging the Garmin into the USB port on the keyboard worked for him. As a "Mac guy" since 84 the idea of installing VMWare and XP again and both Garmin Map Quest and Streets and Trips was somewhat daunting so I tried the keyboard port and goddamn if it didn't work. I had to plug and unpulg a few times but no "device is being used by another application". Incredible. I hesitate to try it again so I'll for now just go to bed content.
     
  19. Nahum Sloan

    Nahum Sloan

    Messages:
    7
    Anyhow I had to follow through

    This is what mworthin? wrote in USB Problems

    Ensure you have the latest Garmin map Source s/w.

    I had the same prob until I plugged the garmin in to the second usb port on the keyboard - windows detected the garmin device.

    Then realized that I loaded the orig map source disks which are obsolete - goto garmin d/l & install the latest ver. and bingo - everything works fine.
    -----------------------------------------------------------
    So not willing to leave well enough alone I updated Mapsource, September 27 I believe. Everything seems to be cool, I had to reload the USB drivers from my Mapsource disk. I'll check again tomorrow to make sure this wasn't inexplicable wizardry.
     
  20. spot the blip

    spot the blip

    Messages:
    19
    Nice idea, pity my laptop keyboard doesn't have a USB slot :)
     

Share This Page