[Tutorial] How to fix Microsoft apps (Photos, Store, Calculator, etc.) crashing on M1

Discussion in 'Parallels Desktop 16 for M1 Mac Technical Preview' started by teemubohuslava, Dec 18, 2020.

Tags:
  1. Lutz-R.F

    Lutz-R.F Bit Poster

    Messages:
    8
    btw. found most of the apps that atrstuck - only fighting with Movies & TV at the moment ... if someone finds the proper ID, it would be appreciated. Strangly, some apps listed as "arm" already work on my VM ... looks like Microsoft is already working on it
     
  2. RiyazulhaqH

    RiyazulhaqH Bit Poster

    Messages:
    3
    hi ,
    i am getting this error in powershell can someone help.
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF3, Package failed updates, dependency or conflict
    validation.

    attached screeshot
     

    Attached Files:

  3. Lutz-R.F

    Lutz-R.F Bit Poster

    Messages:
    8
    you need to get the package for the UI.Xaml.2.4 aswell (should be in the same appxbundle)
     
  4. RiyazulhaqH

    RiyazulhaqH Bit Poster

    Messages:
    3
    cant get that done could you please explain in detail
     
  5. RiyazulhaqH

    RiyazulhaqH Bit Poster

    Messages:
    3
    Photo app is now running but cant find calculator app with x86.appx
     
  6. BrandonD5

    BrandonD5 Bit Poster

    Messages:
    1
    So I followed the instructions, uninstalling Microsoft Store and downloading the 4 files (Framework, Runtime, VCLibs, and Microsoft.windowsStore_12011.1001.113.0_neutral...) in x64 and x86 and I still have not been able to successfully open the Microsoft Store! Is there something I am missing??
     
  7. ChristopherK12

    ChristopherK12

    Messages:
    1
    Same for me. I have tried x86, arm64 and x64 and could not get any to open.
     
  8. HugoM4

    HugoM4 Bit Poster

    Messages:
    2
    Whenever I try to install the Windows Store I get this complaint about not being able to install due to a dependency on .Net Framework, but then it shows below that it's installed. Am I missing something?

    PS C:\Windows\system32> Add-AppxPackage -Path "C:\Users\echow\Downloads\WinStore_12010.1001.3.0_x86.appx"
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF3, Package failed updates, dependency or conflict
    validation.

    Windows cannot install package Microsoft.WindowsStore_12010.1001.3.0_x86__8wekyb3d8bbwe because this package depends
    on a framework that could not be found. Provide the framework "Microsoft.NET.Native.Framework.2.2"
    published by
    "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x86 processor
    architecture and minimum version 2.2.27011.0, along with this package to install. The frameworks with name
    "Microsoft.NET.Native.Framework.2.2" currently installed are:
    Windows cannot install package Microsoft.WindowsStore_12010.1001.3.0_x86__8wekyb3d8bbwe because this package depends
    on a framework that could not be found. Provide the framework "Microsoft.NET.Native.Framework.2.2" published by
    "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x86 processor
    architecture and minimum version 2.2.27011.0, along with this package to install. The frameworks with name
    "Microsoft.NET.Native.Framework.2.2" currently installed are:
    {Microsoft.NET.Native.Framework.2.2_2.2.27912.0_arm__8wekyb3d8bbwe
    Microsoft.NET.Native.Framework.2.2_2.2.27912.0_arm64__8wekyb3d8bbwe
    Microsoft.NET.Native.Framework.2.2_2.2.29512.0_arm64__8wekyb3d8bbwe}
    NOTE: For additional information, look for [ActivityId] 13f21fb6-f127-0001-3956-f31327f1d601 in the Event Log or use
    the command line Get-AppPackageLog -ActivityID 13f21fb6-f127-0001-3956-f31327f1d601
    At line:1 char:1
    + Add-AppxPackage -Path "C:\Users\echow\Downloads\WinStore_12010.1001.3 ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : WriteError: (C:\Users\echow\...01.3.0_x86.appx:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
     
  9. HugoM4

    HugoM4 Bit Poster

    Messages:
    2

    I think I got this working by enabling the developer version of the Windows insider channel, as that channel appears to have x86 emulation. From there I was able to install the x86 versions of applications.

    I am however, having trouble with anything that requires login with my microsoft account. A window pops up and quickly disappears, so I'm guessing some component must still be arm32 (which is incompatible on the M1 Mac) but i'm not sure what it could be or how to replace it.
     

Share This Page