[Ubuntu 10.10] Parallels Tools installation error

Discussion in 'Linux Guest OS Discussion' started by David Cavalcante, Oct 10, 2010.

  1. Carl Petersen

    Carl Petersen

    Messages:
    6
    Parallels version 5 will ever get Ubuntu 10.10 support? $50 is kinda steep price to get tools running in my Ubuntu vm.
     
  2. joevt

    joevt Kilo Poster

    Messages:
    1,202
    $50 also gives you all the other features of Parallels Desktop 6. It also gives you all the Parallels Desktop 6 updates which may include updates for newer versions of Ubuntu until Parallels Desktop 7 comes out.

    There are usually 2 versions of Ubuntu per year (October and April). Parallels has a new version every year (usually last half of the year Jun-Nov). So most likely Parallels Desktop 6 will have an update for the next version of Ubuntu (11.04).
     
  3. iduff

    iduff Product Expert

    Messages:
    235
    6.0.11826 inline upgrade just fixed it for me on Ubuntu 10.10.
     
  4. TheAshMan

    TheAshMan Bit Poster

    Messages:
    2
    Hat's off to Parallels

    That is a quick update and it fixes the issue. Thanks!!!
     
  5. MaurizioM

    MaurizioM

    Messages:
    1
    Why with the Italian version if I ask to search for update it says me that the last version is 11822?
     
  6. STim

    STim Super Moderator

    Messages:
    942
    Updates appear in update service with a slight delay. First, they get published on our website and in online store and only then become available via updater.

    Italian localization is available now.
     
  7. _JeromeC_

    _JeromeC_ Bit Poster

    Messages:
    21
    Well the last update, which is announced to fix the ubuntu 10.10 tools issue is just turning into a nightmare for me : my ubuntu 10.10 refuses to start, instead it is running a memtest, which cannot be interrupted, it takes a long time to finish, and starts again over and over, impossible to boot the VM, just when it's starting it's running this memtest (it seems to be installed with ubuntu) !!!

    What can I do ?
     
  8. CaptSaltyJack

    CaptSaltyJack

    Messages:
    28
    Are you guys going to patch Parallels 5 so Ubuntu 10.10 works properly?
     
  9. Parallelism

    Parallelism

    Messages:
    4
    I think that's a fair question, but the fact that it hasn't been answered suggests that it wont be. ?

    I just run an older version of Ubuntu on 5. As in most cases, the latest and greatest is only for those who can afford it.
     
  10. Harley_Bernie

    Harley_Bernie Bit Poster

    Messages:
    12
    I run into the sam error: Parallels Desktop 4.0 on Mac OS 10.6.5.
     
  11. MatheoDJ

    MatheoDJ

    Messages:
    2
    I've installed Ubuntu 10.10 (32 bit), but Parallels Tools won't install... the virtual disc mounts, I can browse the contents, then nothing happens. None of the installer files seem to do anything productive either by clicking on them or accessing through the command line. Any suggestions?

    OS X 10.6.4
    Parallels 6.0.11828 revision 615184
    Ubuntu 10.10
     
  12. darreld

    darreld Bit Poster

    Messages:
    1
    Also having a problem installing tools Ubuntu 10.10 under 6.0.11828

    I start the install but get an error message telling me I need 'make' and 'kernel sources'.

    They are both installed.

    Thanks.
     
  13. MatheoDJ

    MatheoDJ

    Messages:
    2
    !!FIXED!!

    OK I spent some time researching this issue, and figured it out for myself. The Parallels Tools installer can be accessed from the command line; running it from the browser doesn't work because root permissions are necessary to run it. Also, it can only be accessed from the /media/Parallels Tools directory; copying the files to another directory will cause a "install: missing file operand" error.

    First, open your Ubuntu 10.10 virtual machine, and select

    "Virtual Machine>Reinstall Parallels Tools"

    This will mount a virtual CD-ROM in your /media/ folder, and it will also show up on your desktop. From the Ubuntu Applications menu, open

    Accessories>Terminal

    Enter the following code, pressing enter after each line:

    Code:
    cd /media/"Parallels Tools"/ 
    sudo ./install
    
    The quotes around "Parallels Tools" are necessary because the path contains a space.

    That will open the parallels tools window. Follow the instructions, and then just wait for a while when it politely asks you to wait during installation (it will look frozen for a while, just wait it out). Reboot your VM and you should be set!
     
  14. DannyVandal

    DannyVandal

    Messages:
    1
    Hmm, I get as far as entering the code above then it fails after attempting to download something:

    "An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information"

    That just looks like a log to me, I can't work out what it might say. Anyone got any ideas?
     
  15. DavenS

    DavenS

    Messages:
    1
    I use VMware Fusion 3 on my work laptop and they have just updated VMware tools to support Ubuntu 10.10. This is a FREE upgrade, it is frankly insulting that Parallels expect us to pay for a major version number upgrade to get support for newer versions of Linux.
     
  16. NikolF

    NikolF

    Messages:
    1
    new

    Hai,
    Thanks for sharing the information.I will try out this on my own.
    Thanks
     
  17. geva420

    geva420

    Messages:
    2
    Another "me too"!

    If I understand things correctly here - in order to get this to work, I need to buy the software again? I only bought the software a few months ago!!! I understand "upgrades"... but this is ridiculous. The software has yet to do what it was meant to when I bought it.
     
  18. CaptSaltyJack

    CaptSaltyJack

    Messages:
    28
    No sign of an update at all, Parallels Tools still will not install on Ubuntu 10.10. I've since ditched Parallels and am now using VirtualBox which is free and has better support than Parallels.
     
  19. wisemagic

    wisemagic

    Messages:
    18
    No More

    I have moved on to VirtualBox too, simply because of this issue. I have bought Parallels 3 times... enough is enough.
     
  20. Josephn

    Josephn

    Messages:
    1
    Workaround for Parallels 5 OS X

    * Download trial version of Parallels 6 and mount DMG
    * Go to terminal and type "cd /Volumes/Parallels\ Desktop\ 6/"
    * Navigate to /Volumes/Parallels Desktop 6/Install.mpkg/Contents/Packages/Parallels Tools for Linux.pkg
    * Extract the prl-tools-lin.iso from the Parallels Tools for Linux.pkg
    * Mount this version of tools in your VM and run the normal install procedure.
     

Share This Page