Ubuntu 11.10: can't see menu bar; other issues

Discussion in 'Linux Guest OS Discussion' started by LloydH, Dec 31, 2011.

  1. LloydH

    LloydH

    Messages:
    4
    I just installed Ubuntu 11.10 32-bit workstation, and Parallels pretty much did everything, including installing the non-supported drivers. After it was done, I was left with not much that I could see to do:

    On the login screen, I can see the headings (ubuntu, person symbol, volume, clock time, on-off symbol), but they don't do anything when I click on them. Clicking on the setting gear symbol next to my name, as well as the Other... and Guest Session doesn't do anything either. All I can do is type in my password and hit Enter.

    After I log in, all I see is the Parallels Shared Folders icon, and what seems to be a menu bar at the top with shading underneath it. There are no words or other visible indicators on the menu bar, and left-clicking doesn't seem to do anything until I get toward the right side of the menu bar, then chat, battery, network, volume, calendar, user account, and system menus pop up. There seem to be no applications that I can otherwise see, though if I click near the left side of the screen, it seems like some things pop up.

    So, how do I get things to appear correctly? Do I need to do some sort of manual install?

    Edit: Parallels version 7.0.15052.
     
    Last edited: Dec 31, 2011
  2. LloydH

    LloydH

    Messages:
    4
    So what I'm hearing from the deafening response is that the solution is to use VirtualBox?
     
  3. JEarles

    JEarles

    Messages:
    119
    Or the fact that, unfortunately, the rest of us have seen no such issue. I have a perfectly functioning 64-bit Ubuntu 11.10 - with Unity and Gnome 3.

    - Have you tried upgrading to 7.0.15054?
    - How did you install Ubuntu - from a downloaded .iso or from within Parallels 7? I downloaded my .iso from the Ubuntu site and installed it through the 'Install Windows or another OS from DVD or image file'
    - Have you looked at the parallels log files to see if any errors are reported?

    Install log = /var/log/parallels-tools-install.log
    Parallels execution log = /var/log/parallels.log
     
    Last edited: Jan 6, 2012
  4. LloydH

    LloydH

    Messages:
    4
    Solved!

    Okay, I seem to have lost the ability to Try Something And See What Happens. Sorry if I was a little snarky there. Yes, I did upgrade to 7.0.15054. I installed Ubuntu 11.10 from a CD that I burned on my Mac from the downloaded iso. I've used that CD on a non-Mac without a problem. Didn't look for any errors in the Parallels errors log; I'll try that next time. But it did tell me that I needed to reinstall the Parallels tools, so I did that... after the below solution.

    Simple solution: when you log in, there's that gear-looking thingy just to the right of the username: click on that and choose Ubuntu 2D (Ubuntu was chosen initially). Logged in with that selected, and I could see the menu items! I guess it had loaded some other drivers that weren't really compatible with my antiquated MacBookPro2,2.

    Aside: I also couldn't take the Unity interface, so I restored the old gnome shell, too, once I got my tweaking skills back. Why Ubuntu thinks that's better is beyond me.

    So we're all good without too much surgery.

    Thanks for the reply, J. I'll remember the logs for the next time.
     
  5. Gary Kellogg

    Gary Kellogg Bit Poster

    Messages:
    36
    I tried building a new machine by downloading the .iso image from Parallels for 11.10 (which as of this writing is their default). Once I got it up and running with the new "Unity" interface it felt like the Linus equivalent to something like Microsoft "Bob" with all these clunky icons on the left side and no apparent way to access settings, etc. that were previously available form the drop down menu bar using Gnome. Heck, there isn't even a drop down menu available. I stumbled around for awhile, discovered that Gnome is officially deprecated or about to be, and asked myself what was lacking in 10.4 that would compel an upgrade? I suppose I will have no choice when support for 10.4 ends and will need to go to 12.04. Hopefully by then the developers will have heard what I understand to be many loud complaints and offer a Gnome-like experience; or maybe a third party will do so.

    Another issue, and it is probably just my unfamiliarity with Linus, I was more or less forced to adopt the user name "parallels" when I installed 11.10 and I cannot figure out a way to open a new account with a name I want or change the name of this one. I am not a Unix command line fluent user, so foo on me, I suppose.
     
  6. Mystic

    Mystic

    Messages:
    3
    Same behavior seen

    For what it is worth, I am seeing precisely the same behavior after I install the latest Parallel Tools into a new Ubuntu 12.04 VM. Prior to installing Parallel Tools, the Ubuntu UI elements are all present and operational, but once Parallel Tools is installed all the UI I have visible is the Shared Folders icon and the shadowed portion of the otherwise-invisible menu bar. If I click on where I know the menubar controls are supposed to be, they do work and the windows appear normally, but the menubar and launchpad always remain invisible. Disabling 3D acceleration on the VM resolves it (but again, disabling 3D wasn't necessary until after I installed Parallel Tools).

    I've built two entirely separate Ubuntu 12.4 VMs in the last day, and have seen the exact same behavior manifested on both.
     
  7. NielsO

    NielsO

    Messages:
    21

Share This Page