Ubuntu 7.10 as Guest

Discussion in 'Linux Guest OS Discussion' started by Roaster, Jun 28, 2007.

  1. Roaster

    Roaster

    Messages:
    74
    Hi,

    I'm trying to run the brand new Ubuntu 7.10 (beta) with Windows Workstation 2.2. I attached the ISO file to one of the drive letters and tried to boot.

    After pressing enter at the start screen and after some lines from the bootloader, a blank, black, screen shows up and nothing happens.

    I used OS Type Linux of course and tried several versions but no luck either.

    So is Workstation 2.2 cabable of booting Ubuntu at all?
     
  2. mgolczewski

    mgolczewski

    Messages:
    7
    FWIW, I'm running Umbuntu 7.04 on build 3188.

    I had upgraded the Umbuntu install from 6.x to 7.04 a few months ago. I seem to remember having to use the .ISO image to do the install.

    Also, check your memory allocation. For some reason the VM doesn't like to allocate more than 512 in memory. I tried pushing it to more and was never able to keep it going. Very odd.
     
  3. MaximS

    MaximS

    Messages:
    715
    Try to set "vga=791" as kernel parameter before booting.
     
  4. birukun

    birukun

    Messages:
    5
    I am trying to install the Release Candidate (RC) using the 'vga=791' kernel option to no avail. I will try other options and see what works.
     
  5. birukun

    birukun

    Messages:
    5
    OK

    When X windows fails to start, I use 'ALT F1' to get to the command prompt. If X windows comes up, then use 'CTRL ALT BACKSPACE' to get the Xserver to shut down.

    Then I edited the /etc/X11/xorg.conf file, removing all references to Wacom drivers.

    I also removed any reference to any video mode > 1024x768.

    (use 'sudo vi /etc/X11/xorg.conf' to edit the file)

    Restarted X using 'startx' and now I get Xwindows up but with a resolution of 1280x1024. I tried to use the System > Preferences > Resolution menu to change resolution, but everything below 1280x1024 gets scrambled.

    I will try an install using this mode and then fiddle with xorg.conf to get it to work on the permanent install.

    In addition, the network connection is not working, works for my other VMs (RHEL and CENTOS)
     
    Last edited: Oct 12, 2007
  6. birukun

    birukun

    Messages:
    5
    After a successful install, I opened a terminal window and ran:

    sudo dpkg-reconfigure -phigh xserver-xorg

    I select VESA for the device and then selected 1024x768 as a default resolution. This automatically overwrote my xorg.conf file.

    Something is funky with the Ubuntu 7.10 default xorg.conf file.

    I also got networking to work simply by clicking on the network icon, which initiated a dhcp request for an IP. (successfully)
     
  7. MaximS

    MaximS

    Messages:
    715
  8. IndyBart

    IndyBart

    Messages:
    1
    Parallels is not for Windows and Linux - let's face it!

    Parallels has never been that great with Windows as the host machine and Ubuntu as the guest. I can't get 7.10 to work at all (after the reboot post installation) even with all of the suggested workarounds. Let face it - Parallels is a Mac company, all of their energy is there, and they should probably come to grips with that instead of disappointing (the only reason I purchased the product was to run Ubuntu in Windows). Even the last response to this string shows evidence of it - the how to do it article is about their Mac product, v3.0.
     
  9. stewarsh

    stewarsh Bit Poster

    Messages:
    20
    Linux Tools - Change Desktop Resolution

    Hi all,

    First let me say that I have had no problem installing Ubuntu 7.10 in a Parallels VM. I am running Workstation 2.2 Build 2222. No workarounds or other changes had to be done.

    Now I do have a couple problems/issues. First, once the machine starts X, I am unable to switch to a text-console. The window resizes correctly but the display is garbled. Before X starts I can switch just fine. This is not a big deal as I can ssh in, but kind of annoying.

    More annoying is the system will not change the desktop resolution when going into/out of full screen mode. I noticed that Ubuntu 7.10 is not listed as supported with Linux tools, but just thought I'd ask anyway.

    Thanks,
    Shawn
     

Share This Page