Ubuntu 7.10 Gutsy Gibbon

Discussion in 'Linux Virtual Machine' started by MitchB, Sep 30, 2007.

  1. pkasin

    pkasin Bit poster

    were you able to install Parallels Tools successfully? I have 7.10 installed, but keep having problems once I install Parallels Tools...
  2. Billy Goto

    Billy Goto Bit poster

    Success (sort of)

    I'm having the X problem described by so many others.

    I wanted to experiment a bit, so I kept careful checkpoints
    as I went through this install procedure. Hope my experiences help.

    I had Parallels Desktop v5160 running a fresh vanilla
    7.4 Feisty (known to work, and no parallels tools yet), upgraded
    my distribution to 7.10 Gutsy through the Ubuntu UpdateManager,
    and had no trouble. gdm and X and everything were fine.
    Then I installed parallels tools and the Xorg restarts hit me.

    However, I took gdm out of the startup procedure with

    update-rc.d -f gdm remove

    and now I can boot okay even with parallels tools. When I log into
    tty1 console, I run startx and I'm fine. Parallels tools work, screen is
    resizable, mouse is free to cross the border, everything. Go figure.

    So for now, I'm sticking with startx and no gdm, and watching this
    thread like a hawk.
  3. Billy Goto

    Billy Goto Bit poster

    Sounds like you are where I was this morning.
    Try removing gdm and using startx to get your X going.
  4. pkasin

    pkasin Bit poster

    Works like a charm...

    Thanks for the help.

    There must be a way to automate this script?
  5. jbartley

    jbartley Bit poster

    Parallels tools needs to be fixed. After intstall of the tools everything goes wacky. 7.10 does not like it. Display error: Flashes with a error from time to time. I can control it with a edit to the default screen resolution config file, but the tools needs to be fixed. Parallels team!!! We have a problem... please say your working on it. Or at least admit there IS a problem. It should be more simple than this. One should not have to edit config files to get your product working for them.
  6. pkasin

    pkasin Bit poster

    Listen folks,
    I too would love for Parallels to "fix" this problem, but let's be fair - this release has been out for what, two days? There are ways to get 7.10 loaded, and even with Parallels Tools (if you want to manually start X).

    Yes, Parallels should communicate more - I agree - but let's not get upset at them for not having a two day old piece of software working... until it was actually released (Ubuntu 7.10, that is), it would be a "moving target", no?

    I have 7/10 working on my MBP 2.33ghz/4gb system running PDM 5160, and decided to load Parallels tools using a method where the X Server as detailed by Billy Goto... works perfectly.


    You'll have to do all of typing "startx" to get Ubuntu started for now - not much of an inconvenience.
  7. swimsy

    swimsy Bit poster


    I tried both the 7.10 .iso file and then going back to 7.04 and upgrading. The upgrade worked, but when I tried resetting the screen resolution, I got the same error message you got.

    I'm chilling until a fix is out.
  8. rickbsgu

    rickbsgu Member

    I tried doing the upgrade, several times, both from network and disk image. They all looked like they completed, but I was still looking at feisty stuff (Kubuntu image).

    Finally, I did a clean install from the alternate disk - it worked fine.

    I haven't tried installing tools - I specified a 1280x800 resolution option during installation, and Paralllels seems to not have a problem with it. From what I'm gathering in this discussion, tools isn't cooked for 7.10. I seems to be plenty fast enough for my purposes - even OpenGL screensavers seem to be working reasonably well, considering it's all software rendering.

    Oh - this is ubuntu (Gnome), not Kubuntu (KDE). Either desktop is fine, I think. I've had a preference for KDE in the past, but the tiny toolbar and transparency of the Gnome upgrades has me entranced...

    White MacBook, Intel DuoCore 2.0gz/2gb/120gb.
  9. Saiing

    Saiing Junior Member

    I'm in swimsy's camp. I'm just going to wait until they announce that they've updated parallels to officially support 7.10.

    I appreciate that they can't answer every comment on this forum, but given the problems people have been having, it would be nice if someone from the company would at least say "yeah we're looking at it".
  10. MitchB

    MitchB Bit poster


    7.10 works when I disable gdm.
  11. thorby

    thorby Member

    Still no joy

    I have a working Feisty under Parallels build 5160. Now I am booting from an Ubuntu 7.10 CDROM in the physical drive -- not doing a download.

    I tried Sidney's very clear and helpful instructions but it still doesn't work. After getting the conf file edited, the symptoms are different than before, but still not useful.

    An ugly gray screen comes up as predicted - and it is huge, much larger than the 1280x720 that I specified as the only custom screen size in the virtual machine configuration.

    Then, when Sidney said I'd get an install screen, the screen changes but it is now a brown/yellow herringbone, and still huge. Undoubtedly the hardware resolution has been set much higher than the software resolution thinks it is, so the install screen image is wrapping like a barber pole.

    I wish somebody could explain why parallels tools figures in this at all, given I am booting from a CDROM. The Ubuntu image from the CD doesn't know from parallels, it's just trying to use the (virtual) hardware. And that is not working as Ubuntu expects.
  12. pgnblade

    pgnblade Bit poster

  13. sidney

    sidney Bit poster

    Much simpler install solution!

    After reading some comments in response to my install workaround and doing more experimenting, I've come up with a much simpler and more foolproof install procedure with the Desktop CD. I'm not currently in position to download the Alternate CD, which seems to solve the problem for some people but not others, so I can't comment on that.

    Here are the install steps:

    1. Make sure your VM is configured for no more than 512MB memory, as people have reported that there is still a bug with Parallels on Debian/Ubuntu systems with more RAM. I have installed with as little as 256MB without a problem, though the Ubuntu 7.10 Release Notes suggest that the install may run slower with that little memory.

    2. Boot the Desktop CD and as soon as the boot menu comes up type F6 to get the alternate boot options. (On my MacBook that key is fn-F6).

    3. The boot command line you will see ends with the options "splash --". Back up to before the "--", delete the word "splash" and replace it with "single only-ubiquity". These changes to the options causes the boot to skip the splash screen, boot into non-graphics single user mode and will cause the install to proceed automatically after step 7.

    4. Type the return key, which will cause the boot to continue in a text console until you get a root@ubuntu:~# prompt.

    5. At the root prompt edit the file /etc/X11/xorg.conf using your choice of pico or vi

    root@ubuntu:~# pico /etc/X11/xorg.conf

    6. Scroll down to the Monitor section and comment out the Option "DPMS" line by inserting a '#' character at the beginning of the line. Then in the Screen Section below it add an Option line and a SubSection so that the two sections look like below:

    Section "Monitor"
               Identifier    "Generic Monitor"
    [color=red]#[/color]          Option        "DPMS"
               HorizSync     30-70
               VertRefresh   50-160
    Section "Screen"
               Identifier    "Default Screen"
               Device        "Generic Video Card"
               Monitor       "Generic Monitor"
               DefaultDepth  24
               Option        "NoMTRR"
               SubSection    "Display"
                     Depth   24
                     Modes   "1024x768"
    7. Save the file, exit the editor, and then at the command prompt type 'exit'

    root@ubuntu:~# exit

    8. That's it! The graphical desktop will come up and the installation will run without having to click on any install icon.

    Note: You can specify 800x600 mode instead of 1024x768, and the former fits my MacBook screen while the latter does not quite, but the first few dialogs of the installation are clipped off at the bottom in 800x600 mode, which means you have to guess blindly that the correct button is selected to advance to the next dialog. I found it much easier to use 1024x768 and do a little scrolling. After Parallels Tools is installed it seemed to adjust to the correct screen size anyway.

    9. After the system is installed and rebooted you can install Parallels Tools. With this install method there does not seem to be a display problem showing up after Tools are installed. Follow the standard instructions by selecting Install Parallels Tools from the Actions menu which will attach and mount the Parallels Tools CD, opening a terminal window, cd /media/cdrom, then sudo ./parallels-tools.run, then reboot.
  14. Xenos

    Xenos Parallels Team

    Dear all,

    We are sorry for not paying attention to the thread for such a long time. Please take into consideration that the forum is the place to share your questions and opinions with other users. We are trying hard to provide you with solutions on the problems you encounter but it's sometimes difficult to monitor all forum discussions at once. Anyway we are grateful for the information you give us to improve our products. For obtaining quick support service from Parallels, please send a request ticket.

    1. To fix the X problem causing display problems (including "The display server has been shut down about 6 times..." error) you should go to /etc/X11/xorg.conf file.
    In the file find ServerFlags Section that looks like this:

    Section "ServerFlags"

    If there is no ServerFlags Section, you should create it and type there:
    Option "Xinerama" "True"

    If the Option already exists but it's "False", change it on "True".

    You should finally get something like this:

    Section "ServerFlags"
    Option "Xinerama" "True"

    Save and restart Linux.

    2. We are sorry to say that display resolution is not changing automatically with the windows size changing, as 7.10 is a fresh release and there are some issues to fix. Our developers are working hard on the matter.

    Still you can change the resolution by the Guest OS means. In Ubuntu go to System -> Administration -> Screens and Graphics and set the resolution you need. Please note that for 1024х768 you should set suitable monitor type first (Screens and Graphics - Model unit).

    Best regards,
  15. Frank STENGEL

    Frank STENGEL Junior Member

    Interesting. I tried sidney's solution and it works as advertised. There is no visible problem. The VM starts/stops without any problems and the VM window resizes and the X server changes resolution...
  16. sidney

    sidney Bit poster

    Easiest workaround of all

    I finally got the Alternate Install CD, did some experimenting, and tried out Xenos' suggestion and a few other things, and I think I have the easiest way to do the install.

    First of all, it is worth it to use the Alternate CD instead of the Desktop CD. With the latter you will have to mess with the X server problem popping up when you start installing. With the Alternate CD you just select the "install in text mode" option when you boot up the CD and then don't worry about the X server until the installation is mostly done.

    Xenos' suggestion has a problem that you cannot resize the screen dynamically even after installing Parallels Tools. The method I'll describe here does retain that feature. You can always fall back to Xenos' way if mine doesn't work.

    1. Use the Alternate CD to install on a virtual machine with no less than 256MB and no more than 512MB of RAM. The larger RAM size may make the install go a bit faster. When you boot the CD, select the first option to install in text mode.

    2. When the install gets to the point of asking you to select a screen resolution, be sure to select exactly one screen resolution, and make sure that it is the same as the current resolution of your monitor. I'm guessing that this is why some people found Alternate CD working and some did not. You may worry that such a resolution can't fit in your window when you are not running in full screen mode, but that's ok -- When you eventually install Parallels Tools, you will gain the ability to resize the window and have the screen resize withi it.

    3. The installation should complete and you should be able to boot the virtual machine into Ubuntu. At this point the Parallels window will have scroll bars because the virtual screen is the same size as your full monitor. Login to Ubuntu, then select Action | Install Parallels Tools from the Parallels menu. That should connect the Tools CD and mount it, opening a file browser folder on it. Use Accessories | Terminal to open a terminal window with a command line prompt, then type
      cd /media/cdrom
      sudo ./parallels-tools.run
    and answer appropriately to prompts.

    4. Click on System, Quit, Restart in the Ubuntu menu.

    If all went well, you should have a working Ubuntu system with Parallels Tools.

    If instead you get the old X display problem, try the following:

    5. Reboot the virtual machine and quickly, when Grub says to press Esc to get it's menu, press the Esc key.

    6. Select recovery mode and type Return

    7. This will boot into a terminal window command line with a root prompt. Edit the file /etc/X11/xorg.conf using your choice of editor, nano, pico, or vi

    root@ubuntu:~# pico /etc/X11/xorg.conf

    8. Scroll down to the Parallels Screen section and change the Modes line to some different screen resolution that your monitor supports. Try "1024x768" if you haven't already. If you don't find a resolution that works, then set it to "800x600" and do step 9, otherwise skip step 9.

    9. If you did not succeed in finding a working screen resolution, follow Xenos' suggestion instead by adding the following to the end of the file:

    Section "ServerFlags"
          Option    "Xinerama"    "true"
    10. Save the file, exit the editor, then reboot by typing

    root@ubuntu:~# shutdown -r now

    That should do it.
    Last edited: Oct 30, 2007
  17. epkphoto

    epkphoto Junior Member

    The advice from Xenos did the trick. I have Parallels tools installed and Gnome starts up just fine. The mouse moves off the Parallels window as well. Now I can wait patiently for an update to support window resolution resizing.
  18. madsteer

    madsteer Bit poster

    This fix worked for me to. Interestingly enough, I found it on a SuSe thread, so it seems to be a common issue with this version xorg and all Linux Distro's on Parallels. Hopefully a future version of Paralles will have this in the parallesl tools.
  19. sgodun

    sgodun Bit poster

    The same, but different.

    Running the current model iMac, 2.8GHz 2/4GB RAM and OS X 10.4.10 w/all updates.

    Had Ubuntu 7.0x (whatever the latest version was prior to 7.1) running fine under Parallels 5160. Did the 7.1 upgrade and got the same errors that others in this thread have been having.


    Eventually, all by itself, it just started working. I got the "The display server has been shut down about 6 times in the last 90 seconds. It is likely that something bad is going on. Waiting for 2 minutes before trying again on display" message. I hit RETURN to dismiss. Got the same error again. This time I waited about 5 minutes before hitting RETURN again. And this time, Ubuntu came up with the login and password screen. I was able to login, but Ubuntu was weirding out.

    Specifically, when I was waiting that 5 minutes I resized the Parallels window and moved it off to the side of my screen. When Ubuntu's login/password thing came up, it seemed to "remember" the screen size I had set the window to and filled the rest with black. Even after I logged in, it was only showing that sized area:


    Notice the words in the menu bar are missing. However, once I clicked on the appropriate areas in the menu bar the menus and their contents returned. I changed the resolution to 1024x768 and Ubuntu returned to normal.

    To see if this "stuck" I restarted Ubuntu. This time I got Ubuntu's text-only login request (no GUI login screen):


    When I entered my username and hit RETURN, Ubuntu's GUI login screen appeared asking for my username again. I was able to enter my username and password and Ubuntu seems to be looking and working the same as it was prior to the 7.1 update. And Parallels Tools IS installed.
  20. Raphael

    Raphael Bit poster

    I have a MacBook 2Ghz with Superdrive CD/DVD-ROM r/rw. Ubuntu 7.10 and Parallels 3.
    I have the "alternative" Ubuntu installation.
    Everything works until it CD-ROM mounting, this fails. It can't mount CD-ROM. This happens after the keyboard layout-selection. It tries to detect the CD-ROM hardware and fails.
    Suggesting that I should try to put the CD in again... well, no luck.


Share This Page