Ubuntu Dapper fullscreen on MBP 15" not working

Discussion in 'Parallels Desktop for Mac' started by milomindrbindr, May 12, 2006.

  1. milomindrbindr

    milomindrbindr

    Messages:
    3
    Hi,

    Ive been reading the forums and never really found an answer to this question: I went into the prefs and checked to not change the mac osx screen resolution, which worked great for my xp vm, but when i attempt to put ubuntu dapper into full screen, i get a small screen surrounded by all black. if anything, i think the OS screen is smaller than when it is not in fullscreen. The screen resolution inside of ubuntu is set to 1024x768, but it definitely doesn't get close to getting that big when i try to go full screen, if anything, i think it goes to 800x600 or maybe smaller.

    Has anyone else encountered this problem? Thanks for the help. Oh yeah, I'm running dapper drake and parallels beta 6 with 2 gb of ram and 2.0ghz.
     
  2. Steven Jomiel

    Steven Jomiel

    Messages:
    3
    Is everyone else getting the text-mode install with Ubuntu, or just me?

    I never get far enough (using server 6.06) to try and run the desktop full-screen, but I am wondering if it could be related to why I can't get the startup installation to be happy with the 'virtual' video, I get a quick error about the framebuffer that goes by so fast I can't read it, then I'm stuck with the text-mode install.
     
  3. pogi

    pogi

    Messages:
    31
    You have to edit your /etc/X11/xorg.conf file to include the 1440x900 or whatever resolution is full screen for your mac. You'll see a list of resolutions and color depth settings inside that file. jsut add the "1440x900" to the lines, save and reboot. be sure to set your permissions up correctly.
     
  4. psychoboogie

    psychoboogie

    Messages:
    15
  5. gblakeman

    gblakeman

    Messages:
    6
    1440x900 is the only option in my xorg.conf file and yet i'm somehow stuff on 1280x800 with only the option to go lower. Any ideas? I'd prefer not to have to download the alternate and reinstall...
     
  6. suntzu

    suntzu

    Messages:
    9
    I got weird resolution problems, I can get the 1440 x 900 resolution but I can't change it to anything else (for Windowed Mode). It justs logs out and nothing changes.
     
  7. Jon

    Jon

    Messages:
    9
    Have a look here .. http://forum.parallels.com/showthread.php?t=2350&highlight=ubuntu

    that might solve your problem =).
     
  8. dialo

    dialo

    Messages:
    6
    So has anyone gotten this working? If so, could you please post your xorg.conf file along with your VM memory setting?

    The best I am able to do is get 1440x900 at the splash screen, but when I try to log in it just brings me back to the splash screen.

    I have the same issue with GNOME in Fedora Core 5.

    FYI, my memory setting is 512 or less. I won't boot with any more.

    edit: I've gotten it working and posted the info here
     
    Last edited: Jun 8, 2006
  9. trygve

    trygve

    Messages:
    6
    Strange. Running through the alternate installer, I selected 1440x900 as one of the supported resolutions, and everything else "just worked". I'm surprised others are having so much trouble.
     

Share This Page