Ubuntu hangs on restart

Discussion in 'Linux Guest OS Discussion' started by DerrickA, Aug 29, 2016.

  1. DerrickA

    DerrickA Bit Poster

    I've just done a clean install of Ubuntu 14.04 and upgraded that to Ubuntu 16.04. The virtual machine is now stuck part way through rebooting after the upgrade doing a disk check. I don't know if there is any way of aborting the disk check, or whether it's an indication that the virtual disk is corrupt in some way, and if so, how do I fix it?
  2. PedroC4


    Same problem here, Parallels 12, macOS Sierra, Ubuntu virtual machine 14.04 LTS, executed the upgrade to 16.04 LTS and Ubuntu hangs on restart, last line displayed was

    /dev/sda1: clean 237092/4128768 files, 2052157/16514816 blocks
  3. RikM


    I'm stuck with exactly this problem:
    /dev/sda1: recovering journal
    /dev/sda1: clean, 266730/4128768 files, 3423474/16514816 blocks.

    Is there any solution?
  4. GeneM1

    GeneM1 Bit Poster


    Initially, restart was hanging with the same messages as PedroC4 or RikM.
    Now its getting stuck in a start Job:
    /dev/sda1: recovering journal
    /dev/sda1: clean, 291978/4128768 files, 2303300/16514816 blocks.
    Starting Hold until boot process finishes up...

    There are known problems when upgrading Ubuntu from 14.04 to 16.04, and some suggested fixes can be found here: http://askubuntu.com/questions/760825/cannot-boot-system-due-to-start-job-running-for-hold
    Now, the various fixes says "Go in your safe mode by hitting SHIFT key or ESC."
    One problem is that I can't find the right moment during restart to hit SHIFT key or ESC. I.e., Hitting ESC repeatedly from the beginning usually displays random startup messages. Only once did it get me into the safe mode selection menu.
    In any case, hitting Ctl-Alt-F2 I give me the login prompt. From there I was able to sudo to root, and tried to follow the various fixes. Unfortunately none of them fixed the hang problem.
    Now, when I reboot I just see:
    /dev/sda1: clean, 329795/4128768 files, 2565580/16514816 blocks.
  5. BrianH2

    BrianH2 Bit Poster

    To upgrade from Ubuntu 14.04 to 16.04, try the following:
    1. Start the Ubuntu 14.04 virtual machine.
    2. Uninstall Parallels tools via the command line:
      sudo /usr/lib/parallels-tools/install -r
    3. Shutdown the Ubuntu 14.04 virtual machine.
    4. Turn off 3D acceleration.
    5. Start the Ubuntu 14.04 virtual machine. The screen size will be limited to 800 x 600. While uncomfortable, it will be large enough to upgrade via the GUI.
    6. Upgrade to Ubuntu 16.04.
    7. Reboot once the upgrade completes.
    8. Install Parallels tools.
    9. Shutdown the Ubuntu 16.04 virtual machine.
    10. Turn on 3D acceleration.
    The upgrade procedure listed above has worked successfully in Parallels 12. I have tried to upgrade from Ubuntu 14.04 to 16.04 in the past and received the same errors mentioned in this thread. I posted this upgrade procedure a few days ago in a similar thread regarding Ubuntu. While the upgrade procedure listed above will not fix a broken 16.04 upgrade, it will hopefully work if you can retry the upgrade from the original 14.04 virtual machine.
  6. birba

    birba Bit Poster

    OK it work thanks.

Share This Page