Ubuntu in Parallels: stuttering, jumpy mouse cursor

Discussion in 'Parallels Desktop for Mac' started by pojala, Jul 11, 2006.

  1. pojala

    pojala

    Messages:
    3
    I've purchased Parallels to run Linux on an Intel-based iMac. Installing Ubuntu 6.06 went flawlessly and the Parallels UI both looks nice and is instantly accessible, so congratulations to the Parallels team for that!

    However, when running Ubuntu, responsiveness is lacklustre. Every 1-2 seconds, the VM seems to pause for a fraction of a second, which is very noticeable. It makes the mouse cursor jumpy, and even the Linux terminal cursor blinks at an uneven rate -- very annoying.

    I noticed there's "Parallels Tools" which offers smooth mouse movement and presumably fixes these issues, but it's only for Windows. Are there any plans to offer this fix for Linux?

    With the stuttering, Parallels just can't be used doing any real work in Linux... I'm rather disappointed.
     
  2. BrentB

    BrentB

    Messages:
    60
    Yeah, we need Parallels Tools for linux to smooth things out. IIRC someone from Parallels posted that it's coming up soon on their roadmap. Unfortunately, they haven't given us a timeframe.

    In the meantime, if you can live without fullscreen, you can enable XDMCP on the Ubuntu side, then run Xnest under OSX to export a "native" X11 session. You'll basically trade off some GUI stuff (smoothness of animations and the like) for much smoother mousing and a bit more responsiveness.

    Alternatively, if you don't need a full X11 session, you could start up X11 under OSX and forward X11 via SSH from Ubuntu. Then start your apps from that xterm, and they should export to your display as "native" X11 windows.
     
  3. sloosley

    sloosley

    Messages:
    25
    BrentB, your last two paragraphs went over my head (i'm a rookie). But, I sure agree with pojala's statement "with the stuttering, Parallels just can' be used for doing any real work in Linux."

    I couldn't decide whether it was me, Linux, or Parallels, but I found Ubuntu to be a big disappointment. Why would anyone mess with Linux if they had a mac ...

    I think that my disappointment (aside from my inexperience and ignorance) is in part due to Pojala's and your observations about Linux's performance in Parallels.

    I've been thinking about trying to repartition and install Ubuntu native. quite a challenge for me!
     
  4. BrentB

    BrentB

    Messages:
    60
    I'll throw together a HowTo when I get home from work tonight (if the wife doesn't have other plans). It's really not that difficult, just a bit alien if you haven't done it before.

    Simple test, forwarding X11 back to OSX:

    Start your Ubuntu VM, get its IP.
    On OSX, start X11.app. You should (by default) get an xterm.
    In that xterm, execute the command:
    ssh -Y [your Ubuntu username]@[Ubuntu VM's IP]
    You'll be asked to confirm that you really do want to connect, then be asked for your password.
    Once that's done, you'll be in a shell session, connected to your Ubuntu VM.
    Now, from the xterm, start up an X11 app, and it should be "forwarded" back to OSX =)

    Xnest is a little more complicated, as you need to edit the gdm.conf file to enable XDMCP (a fancy acronym ("X Display Manager Control Protocol") that essentially means "Let remote X sessions connect"). Then in the xterm on OSX, instead of sshing, you use:

    Xnest :1 -geometry 1024x768 -query [Ubuntu VM's IP]

    ...which gets you a full X session, in a 1024x768 window (you can modify the command to get other resolutions, just remember it's in a window, not fullscreen). Nice if you need a full GNOME or KDE environment.

    Hopefully that makes sense. =)
     
  5. pojala

    pojala

    Messages:
    3
    Thanks for the info BrentB.

    If Parallels' VM currently only works properly with Windows, they should mention that somewhere in their marketing material. Instead, they use copy like this:

    "Parallels Desktop for Mac is the first solution that gives Apple users the ability to run Windows, Linux or any other operating system and their critical applications at the same time as Mac OS [...]"

    In its current state, it's hardly a solution for running any "critical applications" unless they happen to be for Windows.

    I feel like I was cheated into buying a broken beta version with no assurances the product will ever do what it promised. Of course I only lost $50, but it still stings...
     
  6. BrentB

    BrentB

    Messages:
    60
    Not a problem, hope it helps!

    For the record, "...only works properly with Windows..." seems a *little* harsh to me, although I can certainly understand your frustration with things not being quite "perfect"!

    Running a Windows VM without Parallels Tools will produce similar results as we're seeing under linux (choppy mouse, etc...). So, at a base level, the choppiness is "normal" (at least so far as I can tell), it's just that under Windows, you have Parallels Tools smoothing things out on the GUI side.

    So what we really need is the same for linux - but doesn't seem to have much to do with the virtualization itself, as it's just a shim layer on top that smooths things out.

    I spend most of my day in a CentOS 4 VM, doing "real work". (Although I poke my head out to read the forums...my one vice ;P ) As such, I'll be very happy when Tools for linux gets released! But I'd rather see Parallels take their time and do it right than release something before it's ready (although, let's be honest, I'd be first in line if they released a beta this afternoon ;P )
     
  7. pojala

    pojala

    Messages:
    3
    I guess my expectations were too high, due to all the hype about Parallels using virtualisation on the CPU level (Intel VT).

    I guess I'll have to get a "real" PC to run Linux. For my work I currently need a PowerPC Mac, an Intel Mac and a Linux machine, but 90% of my work is on the PowerPC machine. So I was hoping that Parallels would save me from yet another box that will sit unused most of the time...
     
  8. BrentB

    BrentB

    Messages:
    60
    From what I can tell, it's not CPU-related. CPU-bound tasks seem to be fine, and right quick to boot (especially in comparison to VPC (on PPC) or Q). We're seeing sluggishness of the GUI, which is due to either the way Parallels virtualizes the video card, the translation of the GUI to quartz, or both. We know it's "fixable", since Parallels Tools fixes it under Windows (this is what leads me to believe the translation to quartz is the slow part, with Tools acting somewhat as a shim). We just need the same for linux.
     
  9. namery

    namery

    Messages:
    45
    Just to say, My Ubuntu 5.84 runs smooth as my windows installation. No choppy mouse or sluggishness
     
  10. sted

    sted

    Messages:
    1
    I am having the same problems with Ubuntu 6.06.
    I have reported them to the Support Team.

    For the record, a friend of mine did not encounter any problem until he did the first live update.
    I don't remember if I had the issues before.
     
  11. Jerry

    Jerry Bit Poster

    Messages:
    78
    Same here: mouse was fine in Ubuntu 5, but sluggish/stuttering in Ubuntu 6
     
  12. BrentB

    BrentB

    Messages:
    60
    Ubuntu 5 used Xfree86 rather than Xorg, didn't it? Might that be (a part of) the problem?

    ::scrounges around looking for an Ubuntu 5 CD::
     
  13. cbpara

    cbpara

    Messages:
    3
    Any resolution to this issue?

    I was wondering if anyone had a reslution to this issue. I am running Debian on a Macbook Pro and for the most part it works without any problems. Occasionally it gets choppy. It seems to happen most when the cursor goes over screen items that have some kind of rollover functionality. Like a checkbox changing color or a rollover dropdown, etc.

    Thanks
     
  14. dailo

    dailo

    Messages:
    79
    Does anyone else have this problem? When I add the 1440x900 resolution to the xorg.conf file when I get to the login screen everything looks okay. But when I try to login it logs me right back out to the login screen. As soon as i take the resolution out it works. Any idea why this might be?
     
  15. dailo

    dailo

    Messages:
    79
    Does anyone else have this problem? When I add the 1440x900 resolution to the xorg.conf file when I get to the login screen everything looks okay. But when I try to login it logs me right back out to the login screen. As soon as i take the resolution out it works. Any idea why this might be?
     
  16. mykmelez

    mykmelez

    Messages:
    29
    It might be that X thinks the virtual display driver can't handle 1440x900. I think you have to add that resolution to the virtual machine configuration in Parallels in addition to the xorg.conf file.
     
  17. majortom

    majortom

    Messages:
    98
    Same for me with 6.0.6.
     
  18. kwojniak

    kwojniak

    Messages:
    16
    Ubuntu 6 runs so slow and choppy 1898 that I can't even get to the first install window. Any ideas?
     
  19. itsdapead

    itsdapead

    Messages:
    177
    Ubuntu under Parallels

    Ubuntu 6.06 seems to work fairly well for me - but I am using a Mac Pro :) . A few tips:

    1. I prefer the "alternative" Ubuntu install CD, which has a good old-fangled text-mode installer (installs the same system but without the eye candy while it does it and with more options).

    2. You could try XUbuntu (get an xubuntu CD or install xubuntu-desktop from an existing installation) - this uses the more slimline xfce desktop instead of the eye-candy-heavy Gnome.

    3. To use Apples X11 server running on the Mac side instead of running it on the virtual machine:

    (a) From Ubunto, go to System->Administration->Login Window->Remote and set "Style" to "Same as Local" - this enables XDMCP

    (b) Start Apple X11 (Applications/Utilities/X11) - go to Applications->Customize Menu and add:
    Menu Name: Ubuntu
    Command: xnest :1 -geometry 1024x768 -query ip-address-of-your-virtual-machine -once

    (c) Now choose the new "Ubuntu" item from the menu and you should be in business. If not, go to ubuntu in the parallels console, open a terminal and "sudo /etc/init.d/gdm restart" - then try again.

    (d) If it works, you don't need to run X server on the parallels side any more, so - in Ubuntu -
    System->Administration->Login Window->Security->Configure X Server and delete everything from the "Servers to start" window. You will need to do a "sudo /etc/init.d/gdm restart" now - after which the parallels console should show an old-fangled text "login:" prompt.

    I find using Apple's X11 is a bit less responsive (xubuntu is better) - but its worth it not to have all the "capture input" hassle. What you don't get is desktop sound effects (although Rhythmbox works OK).


    Challenge

    Has anybody got Gnome or XFCE working smoothly in Apple X11 without using xnest?
    I've tried just doing "DISPLAY=mymac:0 gnome-session" and (provided you do xhost +* on the mac side first) the result is tantalisingly close to working (but it interferes with the mac desktop and spews out loads of errors as it starts) - and much more responsive (and partially aqua-fied) than in XNest. Anybody with a black belt in X-windows come up with a way to configure gnome to work more gracefully and play nicely with the Mac's window manager?
     
  20. cajetanus

    cajetanus

    Messages:
    11
    I am writing this with Firefox on UBUNTU 6.06 on my MacBook Pro, 2Ghz, 2Gb running Parallels (at 512mb) in fullscreen at 1440x900 = magnificent !!! No problems with cursor or screen - in fact the performance is so good that I hardly ever touch my linux partition anymore.

    I think the real problem is that the standard install CD does not recognize the video card emulated or at least the Xorg configuration tool doesn't work. With the alternate install CD (see here, 'alternate install') you only get a text base installer, but it is works quite well and is quite simple. You should just add at the end for the Xorg the different resolutions of your monitor. (which you can see if you go to your Preferences > Displays). You will then be able to go to 1440x900 or whatever your monitor supports at fullscreen.

    However, the movement from fullscreen to window does not shift the screen resolution automatically, at least not yet. I am still trying to find a way to do this through some sort of script, but am having trouble detecting when parallels goes fullscreen or exits fullscreen - anyone know how to find this? Is there some 'parallels' api ?

    For the X11 solution, that works also - but why add another layer between the machine and the user - especially since X11 on the Mac is not all that great? I have also tried VNC, which works actually quite fast as well, but really why bother, especially if the alternate install CD works admirably well....


     
    Last edited: Sep 26, 2006

Share This Page