Unable to Access Hard Disk 1 - Undefined Error 0.

Discussion in 'Installation and Configuration' started by frogracer, Nov 23, 2008.

  1. WHirsch


    Ynot, any idea when this could happen (informing me...) ?
  2. brooksy


    Parrallels 5 unable to access hard disc 1

    I have just had the same problem after upgrading to 5 - could you let me know where to find help on this?
  3. WHirsch


    getting no response from parallels support

    I just don't know what's more annoying:

    - not getting responses for weeks from parallels support staff
    - clicking away that nonsense error message boxes several times a day
  4. Ynot

    Ynot Kilo Poster

    I'm not a support staff )

    Unfortunately, i can't reproduce it here... Do you use any other virtual machines? Are there same errors?

    If you have such ones and there are no errors, you can try to create new virtual disk and copy all data from old disk to new one. Via Acronis tools or linux dd command.
  5. BoboTR


    Mee too

    This is an old post about parallels 4. But I just did the upgrade to 5 and I am having the same issues.
  6. WilbertH


    I have the same problem as well.... would appreciate a clear plan of action.
  7. NicoleH


    Unable to access hard disk 1

    I am having the same problem but i am using Vista as the VM... Any suggestions please!!!
  8. WilbertH


    My 'solution'

    I tried hard to find a solution, but was unable to fix the disk as such, below my findings.

    It appears to be a corrupted configuration file on the disk (not related to Vista or XP). It is as such not a hardware problem, not an OS problem.

    In a posting I found a script that should have fixed it, but it did not work for me. I also found some UNIX commands that would do the tric, but also that was not a success.

    Although I was not able to start the VM, I was able to mount the disk and copy all the information away to a newly created virtual disk. After that all worked fine.

    I could also load older VM via time machine that worked fine.

    In short, consider the virtual disk as lost and try to recover the data and create a new disk.
  9. Tim Tomassi

    Tim Tomassi

    I was having this problem with a Jumpbox VM, and got past it by resizing both the root and data hds - running Parallels v5.
  10. jwt4th


    running hds_setNeedFix script

    How exactly would I run this same script for myself?

    I get the following output from terminal:

    FCI-iMac:winxp.hdd John$ cd /Users/John/Documents/Parallels/WinXP.pvm/winXP.hdd
    FCI-iMac:winXP.hdd John$ ls -la
    total 104
    drwxr-xr-x@ 8 John staff 272 Feb 15 22:59 .
    drwx------@ 8 John staff 272 Feb 15 23:12 ..
    -rw-r--r-- 1 John staff 2061 Feb 15 22:58 DiskDescriptor.xml
    -rw-r--r-- 1 John staff 2024 Feb 15 22:57 DiskDescriptor.xml.Backup
    -rw-r--r-- 1 John staff 16896 Feb 15 22:57 PhysicalGpt.hds
    -rw-r--r-- 1 John staff 16896 Feb 15 22:57 PhysicalGptCopy.hds
    -rw-r--r-- 1 John staff 512 Feb 15 22:57 PhysicalMbr.hds
    -rw-rw-rw- 1 John staff 0 Feb 15 22:57 WDC WD3200AAJS-40VWA1 (disk0).hdd

    I've downloaded the script and placed it in my home folder.
    I've changed the path to my user folder "John" but what should I place for the number string at the end?

    cd /Users/John/Documents/Parallels/winXP.pvm/winxp.hdd && chmod a+x /Users/John/hds_setNeedFix && /Users/John/hds_setNeedFix winxp.hdd.0.{d29c5a5a-2890-40dd-bbff-46bfb46

    PD 5.0.9376. Snow Leopard 10.6.6
    It's a bootcamp partition, but I've tried everything else on the forums such as creating a new VM.

    Problem Reports: 7894287, 7914875
  11. Ynot

    Ynot Kilo Poster

    This script can not be used for boot camp partitions.

    i've checked your report. Looks like your mac HDD is dying. I see lot of errors in your system log
    Feb 15 23:29:34 FCI-iMac kernel[0]: disk0s3: I/O error.
    Feb 15 23:29:51 FCI-iMac kernel[0]: disk0s3: I/O error.

    It is not Parallels error, you need to contact your mac service center.
    Last edited: Feb 16, 2011
  12. troll-op


    Since this evening I've started getting a pop up while having Parallels open which read:
    Unable to access hard Disk 1
    An error occurred when accessing the hard disk. Error ID: Undefined error:0.

    I'm running OS 10.6.5, with Paralells Desktop 5.0.9370 The virtual box is XP SP3. I've read the thread and assume you will need the following info from me.

    Andis-MacBook-Pro:~ andi$ cd Documents/Parallels/Windows\ XP\ SP3.pvm/
    Andis-MacBook-Pro:Windows XP SP3.pvm andi$ ls -la
    total 3603584
    drwxr-xr-x@ 12 andi andi 408 Mar 4 23:10 .
    drwxr-xr-x 5 andi andi 170 Mar 1 23:55 ..
    drwxr-xr-x@ 18 andi andi 612 Mar 4 23:12 Applications Menu.localized
    drwx------ 2 andi andi 68 Aug 22 2010 Snapshots
    drwxrwxrwx 75 andi andi 2550 Mar 2 21:00 Windows Applications
    drwxr-xr-x 6 andi andi 204 Mar 5 00:09 Windows Disks
    drwx------@ 7 andi andi 238 Mar 4 23:11 Windows XP-0.hdd
    -rwx------ 1 andi andi 13645 Mar 4 23:10 config.pvs
    -rwx------ 1 andi andi 13645 Mar 4 23:10 config.pvs.backup
    -rwxrw-rw- 1 andi andi 98696392 Mar 5 01:01 parallels.log
    -rwx------ 1 andi andi 1474560 Feb 12 2009 unattended.fdd
    -rw-rw-rw- 1 andi andi 1744830464 Mar 5 00:59 {c70880a8-be65-40f0-a9e2-1f946141c030}.mem

    Seeing that the previous script listed was for v4, I take it the same approach won't work. Even launching Parallels without the virtual machine, I end up with the same error... and after a few seconds I have the wonderful beachball, but only for Parallels.

    Can you please give me a helping hand to solve this?
  13. troll-op


    Whoops, just spotted my listing is incorrect you would probably want this :p

    Andis-MacBook-Pro:~ andi$ cd Documents/Parallels/Windows\ XP\ SP3.pvm/Windows\ XP-0.hdd/
    Andis-MacBook-Pro:Windows XP-0.hdd andi$ ls -la
    total 13343992
    drwx------@ 7 andi andi 238 Mar 4 23:11 .
    drwxr-xr-x@ 12 andi andi 408 Mar 4 23:10 ..
    -rwx------ 1 andi andi 1186 Mar 4 23:11 DiskDescriptor.xml
    -rwx------ 1 andi andi 1186 Mar 4 23:10 DiskDescriptor.xml.Backup
    -rwx------ 1 andi andi 0 Feb 12 2009 Windows XP-0.hdd
    -rwx------ 1 andi andi 6832078848 Mar 5 01:13 Windows XP-0.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}.hds
    -rwx------ 1 andi andi 33040 Mar 4 23:11 Windows XP-0.hdd.drh
  14. troll-op


    No worries, seems to have corrected itself. No clue what was wrong. Launched it today, no errors, started XP, and works. Thanks anyway....
  15. KevinClarke

    KevinClarke Product Expert

    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
  16. KevinClarke

    KevinClarke Product Expert

    I had the very same problem two weeks ago, after Installing Windows 7 Service Pack 1 which has just come out.. I was on Version 5 then. I have since upgraded to Version 6 and completely rebuilt my Virtual Machine. Can you advise if Service Pack 1 for windows is safe to install?

  17. Toño


    I solved.

    I was the same problem...
    Solution: format type of target disk have to be same like format type of pvm file containing disk, that's all.
  18. Francisco_Gallardo



    Hi all:

    I'm going to add another "Same problem here" to the thread.

    I tried with the script, after it said "everything ok, now run PD4 and everything will be fixed!"
    I started Parallels Desktop and the error remains. If PD4 stands for Parallels Dektop 4 then I should say that I have PD5.
    Is this the issue? Is there any PD5 script version?

    BTW: I'll try to create a new virtual machine and take all the info from the last VM (I can mount the disk (or access it from terminal)). Nevertheless I have a HUGE issue here; I installed some engineering software in the VM that is locked to the MAC (MAC of the NIC) number (which I saw that I can change in the Parallels menu in order to make it meet the last number that I had in the broken VM) but =>> How can I change the hard disk serial number? <<==

    I mean, is it the REAL serial number (so I won't have any issue due to the fact that I'm using the same real HD) is it a fake serial number (so, I'll have to change it somewhere in the Parallels menu)?

Share This Page