Unable to allocate virtual machine memory

Discussion in 'Parallels Desktop for Mac' started by Rod_H, Dec 22, 2006.

  1. Rod_H

    Rod_H

    Messages:
    4
    This is the error message I am getting after upgrading to the 3094 Beta 2 for Mac.

    I have plenty of memory, over 25 Gb. Also my other Windows XP virtual machine is working.

    Any ideas?

    TIA

    Rod
     
  2. DerekS

    DerekS

    Messages:
    60
    Same Here - Mac Pro

    I've been getting this error fairly consistently since build 3036 on my Mac Pro.

    I love all the new enhancements too much to downgrade! :)

    I have tons of disk space, so that's not the issue. Usually rebooting will fix it, but that kind of hacks me off...Macs shouldn't require daily reboots.
     
  3. Rod_H

    Rod_H

    Messages:
    4
    I think I fixed it by cloning the VM. Lo and behold the clone works!
    Wish I new why.
     
  4. Alexey

    Alexey Parallels Developers

    Messages:
    14
    How much physical memory do you have?
    I think more than 2 GB.

    If so you need reboot your Mac Pro.
    You need reboot Mac Pro one time only directly after Parallels Desktop installation.

    Further launches of Parallels Desktop will not report the message.
     
  5. SirRichard

    SirRichard

    Messages:
    11
    I don't think that a simple reboot helps. I have Parallels 3094 Beta 2 on a Mac Pro with 4GB RAM, 3.5 GB assigned to Parallels. My setup consists of three VMs, each with 1G RAM assigned, so it should fit perfectly into the assigned 3.5 GB. Starting one VM always works, but even the second VM won't start, telling this "Unable to allocate virtual machine memory" error message. I have rebooted multiple times after Parallels installation, my hard disk has 200 GBs free, so this can not be the reason.

    What I do not understand is: what reason should it be that after rebooting the memory allocation should do. Memory fragmentation? Isn't that an issue from times long ago? The ages of i286 protected mode and such things? Don't we live in modern times with page tables for memory allocation? So, why should rebooting help anything?
     
  6. hotmop

    hotmop

    Messages:
    2
    Delete the winxp.mem file in /Users/{username}/Library/Parallels/{vmname}/

    Mine was zero K in size. I deleted it and then my VM started just fine.
     
  7. Sir Atilla

    Sir Atilla

    Messages:
    10
    Ditto for me

    I have a Mac Pro with 4GB of RAM and I can only start one machine. As soon as I try to start an additional VM I receive this message regarding unable to allocate virtual machine memory.

    Carlin Smith
     
  8. hotmop

    hotmop

    Messages:
    2
    The crucial issue is HD space. What do you have for space? And, each VM will create a *.mem file when it starts. If any have a zero K file, something has gone wrong and it should be deleted.
     
  9. Sir Atilla

    Sir Atilla

    Messages:
    10
    I have about 800GB free so that would be an unlikely issue. I have 2 500GB drives in a 1TB Raid 0 configuration.
     
  10. joem

    joem

    Messages:
    1,247
    Check your RAM allocations. In Parallels preferences, you must set total RAM to about 100 MB more than the sum of the RAM allocations for the VMs you want to run simultaneously. Then Allocate VM RAM in the VM consoles appropriately. You don't need to be terribly generous with VM RAM since VMs seem to work well with less RAM than the same setup seems to need on raw hardware. This may be because some of the virtual memory swapping to the virtual HD is actually to RAM because of caching in the host.

    For example, running a single Win2k VM on a 2G Mac, I found best performance at 768 Meg for the VM. More or less was slower. (Tested in the beta just before the 1970 GA release).
     
  11. Pete2006

    Pete2006

    Messages:
    1
    Memory Preferences solved it for me.

    Problem:

    1) Unable to allocate virtual machine memory! -- This was true for only one of my virtual machines, both running different (and valid) licenses of XP Pro.
    2) Did NOT find any mem file to delete.
    3) Had plenty of disk space and RAM.
    4) Creating clone didn't work.

    Solution (for me):

    1) Startup virtual machine. Get error message.
    2a) In the Parallels Desktop menu, select Preferences...
    2b) Click on "Memory" tab. Note that Reserved memory limit is set to 2548, but slider is set to 96 MB.
    2c) Set memory to 3072 by typing it in (I have 3GB MacBook Pro). Get error that 3072 isn't divisible by 4. **BUG**
    2d) Slide memory to max of 2548.
    2e) Click OK.
    3) Startup virtual machine. Now it works.

    Path to problem?:

    I suspect that the path that lead to this problem is that I left my virtual machine open in the configuration edit screen and then shut down without closing it, but I don't have time (or interest) in trying to verify the repro steps.
     

Share This Page