Unable to Compress / Compact virtual hard disk

Discussion in 'Installation and Configuration of Parallels Desktop' started by fiopa, Jun 27, 2007.

  1. fiopa

    fiopa Bit poster


    I have installed Windows XP SP2.
    I'm not able to compress or compact virtual hard disk;
    the messages sond like:
    " ... because the virtual machine has Undo Disks option enabled
    or the hard disk is used in snapshots ... "

    The Undo Disks is DISABLED, and I have create and DELETE all snapshots!
    I also have deleted Snapshots.xml file and Snapshots dirctory, but nothing ! :mad:

    Within Windows the C: disk is 8GB, but on Mac the virtual machine is 15 GB !!! :eek:
  2. fritzkarma

    fritzkarma Bit poster

    Unable to Compress; Snapshot/Undo-Disk Error

    I'm experiencing the same problem (no snapshots and undo disk is disabled); any support/assistance here would be much appreciated, as I'm rapidly running out of disk space on the main Mac drive.
  3. jackybe67

    jackybe67 Pro

    Why don't we get any help with this problem. My C has 20 gb, but my virtual 40 gb....want to compres!!!!!!!!!!
  4. fiopa

    fiopa Bit poster

    Can we help Parallels staff to find this program bug ?
    What are yours bug experience ?
    My experience is that I created some snapshots,
    then i deleted one intermediate snapshot (not the first, not the last);
    the delete process was very slow, then I stopped Parallels (option+command+esc).
    Then I repeated snapshot deletion, and, again, after some minutes
    I stopped Parallels.
    At that poit, I was not able to compress / compact this virtual machine.
    I have deleted Snapshots.xml file and Snapshots directory, but no result !
    Within Snapshot Manager there are no snapshots, so why do not work compression ?
    How can I make compression / compactation without delete virtual machines ?
  5. jackybe67

    jackybe67 Pro

    Did an email to parallels. They said there was a problem, but there working on it. Update will be released soon.

  6. levo

    levo Bit poster

    looks like the new build didn't solve this problem.
  7. Leonard

    Leonard Member

    I compressed my Win XP Sp2 VM last night bringing it from 15GB to 9.5GB using the new build.
  8. levo

    levo Bit poster

    Strange, because it doesn't work for me.
  9. Leonard

    Leonard Member

    Doesn't run, runs but errors out, completes but doesn't shrink? Something else entirely?

    My compression took 2+ hours to complete, but I appreciate shrinking the image 5+GB. I can confirm that the previous 3.0 version ran for 12+ hours and did not compress anything for me.
  10. jackybe67

    jackybe67 Pro

    They told me it would work in 4560, but it doesn't

    on windows side 20 gb installed 10 gb free

    on mac side growing to 42 gb !!!!!!!!

    Need space !!!!!!!!!!!
  11. JoTho

    JoTho Bit poster

    I too am having the same issue. Upgraded to 3.0 Build 4560, made a few snapshots, and now am unable to compact my 40 GB vm. I have deleted all snapshots from the Manager, have deleted the snapshot.xml and snapshot folder. It seems that somewhere else it believes there are snapshots, as that is what the message says even when I try using Transporter. As a school with multiple licenses, this can be a significant issue for us.
  12. ekellow

    ekellow Bit poster

    Unable to Compress - possible workaround until Parallels fixes the problem

    I have had the same problems not being able to compress my .hdd, both before and after upgrading to build 4560 despite having deleted all Snapshots and disabling Undo Disk. After some web searching, I decided to try another VM compressor that says it works with Parallels .hdd. It is MakeVM, which you download, install and run within your Windows VM (it only occupies 998 Kb on my Windows XP machine). It has a clone option that you can use to copy your hdd, and, in the copy process, optimize it. It took a very very long time, so I let it work over night. But it seems to have successfully compressed my Parallels hdd from 40GB+ on OS X down to less than 9GB in OS X, which is consistent with the space size XP reported as being in use. Hopefully, the new one is still an expanding disk (I think it is). Because I changed the hdd name for this copy, I still have my ginormous hdd to go back to if anything goes wrong. Here's a link to the MakeVM website: http://www.sysdevsoftware.com/soft/makevm.php. It costs $19.95. On that site, scroll down to see the instructions for Custom Clone and Optimize Disk to do what I did. It takes many hours, like I said. Then, mount the new optimized clone as a second hdd in your Parallels VM, temporarily disable your hdd #1 (uncheck the enable box in the Configuaration panel for hard drives), which will cause your new, smaller hdd to become the hdd #1, and you're off to the races. Note if you're using Parallels 3.0, when you open this new hdd for the first time, Parallels will tell you that it needs to convert it to be compatible with 3.0. I let it convert, and all is well.....so far! I plan to move my old, larger hdd off to an external storage just in case and preserve disk space on my MacBook Pro. Good luck!
  13. jackybe67

    jackybe67 Pro

    Finally somebody with a sollution.

    I hope that parallels also is working to solve this problem !
  14. jackybe67

    jackybe67 Pro

    Found out that there are working on an update to solve this problem
  15. rob545

    rob545 Bit poster

    I have had a similar experience with a slight twist. My HDD images were plain so they should never have expanded in the first place. Even if the bug is fixed the compressor wont work on plain image files.

    But I came up with another work around. Anyone who has ghost a similar imaging app should be able to do this.
    - I created a new HDD file (an expanding one this time) & added it as another hard drive to my guest OS (XP SP2)
    - After setting it up as a pri partition I ghosted from the bad plain HDD file to my new HDD file
    - Then I shutdown the guest OS, went into config & removed the 2nd HD, then pointed HD1 at my new HDD file.

    So far so good - no issues.
  16. flyfishdaddy

    flyfishdaddy Bit poster

    Same issue and some other weird stuff

    I also get the

    "Process of compacting of the virtual hard disk /Users/.../Documents/Parallels/..../winxp.hdd was abnormally terminated due to the unrecoverable error."

    whenever I try to compact the drive.

    I'm doing it from the config editor / hard disk 1 / advanced / compact button.

    I wonder if this has to do with the way our hd was originally setup? Mine was a transporter from a WinXP box. It was during this time that I was originally using it that my Parallels updated to build 5160. I've also been trying to get the Image Tool to break my file into 2 gb chunks and I get this bizarre error:

    "Image Tool is unable to process this file. The format of the hard disk image file you selected is not supported in this version. Please open the virtual machine that is using this virtual hard disk in Parallels Desktop to change the format."

    Bizarre since i've been running this disk image daily for several weeks in the Parallels desktop.

    I've tried changing it to a plain disk image but the partition is 71 GB and there's no way the 120 GB HD on my macbook will handle that. So I get a related message.

    I think i'll try converting the disk BACK to the "old format" and then see if I can't change it back to the new.

    In my view its apparent that i'm running a 3.0 5160 build disk, but there's some parts of parallels tools that don't believe me!

  17. Eru Ithildur

    Eru Ithildur Forum Maven

    I just got that issue yesterday while trying to compress. Not a biggie for me, although I would like to see it fixed for when it does become more important.
  18. cbell

    cbell Bit poster

    I ran into the same problem despite having deleted all Snapshots and disabling Undo Disk. I was able to find a solution that worked for me.
    I created a brand new expanding virtual hard disk and had everything from my original disk copied to it using a free program called clone maxx. After that I was able to run compressor successfully. To do this you do need enough disk space available to make a full copy of the original virtual disk though.

    I added a new virtual hard disk (expanding) to the Parallels config as a second hard drive. I made the max size of this new virtual drive the same as my original drive.
    I downloaded freeware Clone Maxx pci_clonemaxx.iso from this site:

    I setup the Parallels config to boot from CD using the clonemaxx iso.
    The system boots up using clone maxx and has a very simple interface to clone the entire disk to the new disk.

    It takes about an hour, but afterward you should be able to set your newly cloned drive as 'disk 1', and from there I was able to finally run the compressor from the actions menu. Hope this works for others.
    Last edited: Sep 25, 2007
  19. flyfishdaddy

    flyfishdaddy Bit poster

    1 small step towards stability


    A million thanks - you're solution works great and straightforward too! The tip on clone maxx and using Parallels power to boot from an ISO image is slick.

    1 caveat though - I tried to make my new disk size smaller than the original and upon startup of the new image I received

    "the NTLDR is missing. Press a key." error - I think windows realizes the disk image was moved, the solution was simple - I created a new disk image exactly the same size as the original then cloned over to it and it worked. clonemaxx was a find! Free and it works.- Sweet.

    This should be a sticky note or a FAQ for others with similar issues - apparently many of us are using disk images that for whatever reason (import with transporter? upgrade from 2.5? degradation?) don't work with the tools in 3.0.

    I can now run compacting from the config editor / hard disk 1 / advanced / compact button and I no longer receive the

    "Process of compacting of the virtual hard disk /Users/.../Documents/Parallels/..../winxp.hdd was abnormally terminated due to the unrecoverable error."

    I also am now able to use the disk image tool of 3.0 to operate on my disk image - I just broke the 7.2 gb disk image into multiple parts (took 10 mins or so). I no longer get the old error saying

    "Image Tool is unable to process this file. The format of the hard disk image file you selected is not supported in this version. Please open the virtual machine that is using this virtual hard disk in Parallels Desktop to change the format."

    I am also currently running the compressor - we'll see if that works - previously to this fix compressor ran for 5 days on my 7.2 gb used / 70 gb max expanding virtual disk and never finished (the disk image size actually grew a bit, too!). I'm hoping I can actually get some compression this time.

    In any case, I have a more stable disk image now, I think. Thanx!
  20. CelticTech

    CelticTech Junior Member

    OK after testing this and much research I finally have a sulotion that I know works so here it is.

    First everyone upgrade to build 5160 you will need the image tool that comes with that build. next

    To fix this Follow these steps

    1. Open Parallels and start windows
    2. go to the Actions menu and click on Create Snapshot
    3. In the snapshot window just click the OK Button

    4. Shut down windows using the shutdown feature in windows
    5. Turn off Parallels

    6. Go to Applications/Parallels and open Parallels Image Tool
    7. Click Continue on the Introduction Page
    8. Click Choose on the source image page.
    9. Select your HDD
    10. Click Continue

    11. Select Manage disk Properties in the action screen, Click continue
    12. In the Operations screen put a checkmark in the Merge snapshots item only. And click the Start button.
    13. A warning Message will drop down, Click Yes
    14. The Image tool will start to process your HDD this can take a long time be patient
    15. When The process completes click finish

    Next boot the VM:
    It is normal for this to take a little longer than usual.

    Finally Run Disc Compressor:

    18. Go to Actions on the toolbar and select Run Parallels Copressor......
    19. A dropdown menu will appear with a message on it click ok
    20. A countdown will begin, allow it to start automatically
    21. The Compressor will start the first set of operations this can take some time.
    22. After the first operations have completed Click on the restart button
    23. After the restart the next set of operations will start again this will take some time to complete. When the compression is completed the compacting of the disk will begin automatically. This can take hours to complete. Do not interrupt it, suspend your Mac or put it into sleep mode during this process.
    24. When Compacting is completed click on the OK button.
    25. Click Finish on the Compressor Window.

    Clean Up
    26. Go to the Macintosh HD/Users/your user name/documents/parallels/your virtual machine/ and delete the Snapshots folder and the Snapshots.xml

Share This Page