unable to open disk image Boot Camp!

Discussion in 'Parallels Desktop for Mac' started by chalkie666, Dec 4, 2006.

  1. chalkie666


    Hi All,
    I followed the instructions in the manual get get parallels to make a new virtual machine, using the winXP install on my boot camp made partittion, but its not working:

    I booted in to XP via boot camp first (restart holding option key, select windows) then installed the parallels for boot camp thing,
    or at least tried to , there was a hang the first time while it was unpacking sometihng with a file name inding in 1050 (or such like).... so i had to kill it. Then I resinstalled and uninstalled twice and reisnatalled it again, just to make sure all was well.

    Now when i rebbot into windows with boot camp, I get the boot menu option to load parallels config.
    So I suppose that is a good thing.

    However, then i made the new virtual machine in parallels and told it to use boot camp image,
    when i power on the virtual machine it get the error message from parallels:

    unable to open disk image Boot Camp!

    any clues

    15" MacBookPro A 2GHz 2Gb RAM
  2. rprather12


    Same exact experience!

    I have wasted enough time on it at this point that I am just going to wait for the next version!
  3. nycruza


    Did you format WinXP as FAT32 or NTFS?

    In the Parallels configuration editor what your settings for "Options" and Hard Disk 1?

  4. Redhawk44


    Unable to open disk image Boot Camp

    I'm having the same problem as chalkie666. Installing the tools for Boot Camp seemed to go smoothly. But once booted back into OSX, I get the above message. My Boot Camp partition is formatted FAT32. In the configuration editor, Options are Windows and Windows XP. Hard disk 1 format is shown as Boot Camp, connect to IDE 0:0.

  5. dEViL SK

    dEViL SK

    Problem is that current build is not supporting FAT32 for Boot Camp installations - it is possible to convert FAT32 to NTFS, but... no way back and if you want to see your Windows partition in OS X you cannot go this way.

    With the build 3036 Parallels become interesting for me and I want to spend my money for it, but... not for now - till existing FAT32 issues and questionable reactivations of WinXP (maybe must)...

    I hope that Parallels guys will fix it soon and we could use it - I'm pretty interested in running MS Project and Visual C# in OS X and drag and droping of files between Win and OS X folders and ... everything else :)
  6. Lars137



    I had this problem, too. Can someone else verify that this only works with NTFS? Could there be any other reason to get this error message. What kind of loser programmer doesn't put a more descriptive error message into a beta build?

    If this only works with NTFS, it defeats a major purpose of using the Boot Camp partition, since OS X won't be able to read data off of it normally.
  7. dynai



    had a fat32 bootcamp didnt work converted it with "convert c: /FS:NTFS" to NTFS now it works
  8. Atomic_Fusion


    You can see your NTFS patition just fine in OS X. You just can't write to it. You can READ from it all you want, though.
  9. gat89


    I don't get this. If I reformat to NTSF and this means I can't write to the Windows XP sector, how can Parallels do it?
  10. Atomic_Fusion


    gat89 wrote: "I don't get this. If I reformat to NTSF and this means I can't write to the Windows XP sector, how can Parallels do it?"

    Parallels doesn't do it. Windows XP does it. If you installed a Windows ME virtual machine in Parallels, it wouldn't even be able to see an NTFS partition, let alone write to it. OS X is not allowed to write in the NTFS format. Call Microsoft and complain. However, it doesn't need permission to read it -- so it does.
  11. tom27


    Hi folks,

    having an NTFS partition definitely is not the real solution to this problem. I have a MacBook Pro here with 1 disk and NTFS BootCamp but still get the "Unable to Open Disk Image..." message upon first boot of my system.

    All I can do is manually re-launch the VM and then, all of a sudden, it works magically...

  12. joem


    If the VM only launches properly if you try twice after a system start, I have to wonder what would happen if you boot, and then wait three or four minutes before launching Parallels the first time. It may be taking time to get its infrastructure started.
  13. Daschle Xavier

    Daschle Xavier

    Fat32 Works

    Just letting you guys know that I have Windows XP installed in bootcamp as a FAT32 partition, and it DOES boot and work propery as a Parallels VM AND Bootcamp bootable with the latest RC.


    I installed Windows XP on a 10 gig partition in FAT32. Silly me. I want to convert the sucker to NTFS, and then resize the partition when I get a new hard drive to 80 gigs. Is there a way to do this or am I just asking for trouble?

  14. Atomic_Fusion


    Backup from FAT32 and restore it to NTFS

    Don't know if you're up to the challenge, but if so...
    The way I did it was to make myself a BartPE Boot CD with the DriveImage XML plug-in. Then I booted into the CD, ran the DriveImageXML plug-in, backed up my Bootcamp partition to an external drive. Formatted the Bootcamp partition to NTFS. Then restored the image I had created to the new partition.

    BartPE is based on WindowsXP's environment, so it supports firewire and USB2 drives, and can read and write FAT32 and NTFS partitions. The only tricky part is figuring out how to make a bootable CD with it (don't forget to add the DriveImage XML plug-in to the package first.)

    Anyway, it's all free, and just has a slight learning curve. But once I figured it all out it has obviously become a great valuable resource for backing up. Be aware, however, that the size of the partition you want to restore your backup to cannot be smaller than the partition you made the backup from. It can be the same or bigger, though.

    Search the web for DriveImage XML and BartPE, and you will find all the downloads and information you need to use the utility. Don't forget to include the D.I. XML plug-in to the thing, though.
  15. sotl


    I am running windows xp on an NTFS partition.
    I shut down windows normally through the start button and before it fully shut down i got some error saying that boot camp did not properly close. I didn't think much of it so I don't remember exactly what it said. Now I get "Unable to Open Disk Image Boot Camp!" constantly. I've restarted my pc many times and even deleted the pvs file and set up a fresh machine, but I can't get it to load anymore no matter. :(

    Edit: hmm. it just kinda fixed itself today after reinstalling bootcamp and parallels several times. I reinstalled bootcamp 1.1.2. for parallels i reinstalled 3150 rc2 and then reinstalled 3170 rc3. It loads again.
    Last edited: Feb 20, 2007
  16. It works on the second try

    I saw exactly the same behavior. Boot camp partition is 40 GB, formatted with NTFS.

    On launching Parallels, I get the error message and the NTFS partition gets unmounted from the Finder. If I then hit the play button on the VM, two things happen. First, the eject mechanism on my MBP's optical drive cycles. After that, the VM starts up normally. Shutting down Windows and the VM does not remount the NTFS partition.

    I can remount the NTFS partition in OSX via Disk Utility without a problem.


Share This Page