Unable to uninstall "Parallels Tools for Boot Camp"

Discussion in 'Parallels Desktop for Mac' started by vladoc, Jan 3, 2007.

  1. vladoc

    vladoc

    Messages:
    1
    Hi,
    I can't uninstall "Parallels Tools for Boot Camp" from the previous beta. Seems like something went wrong when I tried to uninstall. The new beta asks me to perform the uninstall but there is no trace of "Parallels Tools for Boot Camp" in XP Pro SP2 any longer. I am quite desperate as "Parallels Tools for Boot Camp" killed 'MacDrive' functionality and I need to work on my BootCamp installation. Please help!
    Thanks, vladoc
     
  2. don montalvo

    don montalvo

    Messages:
    111
    i'm having the same problem along with a few other people. waiting for parallels team to come back with something. i can revert to beta1 or beta2 and i can boot into bootcamp...just can't use beta3.

    don
     
  3. nycruza

    nycruza

    Messages:
    224
    I assume you are directly booting into Boot Camp by holding down the OPTION key!

    Boot into SAFE Mode and go to the control panel and try again.
    If it does not appear in the Remove Program window; reinstall PTfBC.
    Reboot into SAFE mode and try again to uninstall.

    ajm
     
  4. don montalvo

    don montalvo

    Messages:
    111
    i've already tried that. :)

    don
     
  5. 0rca

    0rca

    Messages:
    1
    I had the same problems. First I couldn´t get rid of a failed installation of the Beta 1 tools. Since it didn´t install correctly, uninstall wasn´t possible.
    I skipped Beta 2 and installed Beta 3 right away. Parallels then asked me to remove the Tools under XP, which I thought I couldn´t.
    I tried a lot of things, searched many places in windows, erased the one existing Parallels key from the Windows Registry and tried again to boot XP through parallels.
    It worked this time (dunno if it was the registry key or just the second try). Parallels then told me it was installing the Tools and I shouldn´t touch anything until its finished. it never finished though and after some waiting I rebootet. Tried installing in safe mode, but that didn´t work either. But there I saw, that Parallels mapped its tools as drive D: which is otherwise my DVD-Drive.
    So I rebootet again (still under Parallels) and startet the Tools installation from the Parallels menu.
    It mapped the installation image to D: again, but windows didn´t recognise the change and still displayed D: as a DVD drive - that´s why I haven´t found the PT image before. I suppose it should autostart, but either it doesn´t work, because I have turned off autostart in XP or its simply a bug on my system.
    However, after manually opening the image under D: and starting the .exe the Tools installed just fine and now everything is working perfectly.

    I thought I write this in case anyone gets new ideas out of this.

    Have fun
     
  6. lh99

    lh99

    Messages:
    7
    Confirmed! Sort of...

    Removing the Parallels Key from the Windows registry got me one step closer. If you're having this problem, this looks like the solution:

    1. Boot Windows in BootCamp.
    2. Uninstall Parallels Tools (if you haven't already). It fails, but just keep going.
    3. Press Start, Run...
    4. Enter 'regedit' into the run dialog box and press enter.
    5. In the registry editor, go to Edit...Find and search for Parallels.
    6. Regedit should highlight a 'folder' in the registry tree called Parallels. Delete it.
    7. Boot back into OS X and try Bootcamp in Parallels.

    NOTE: Messing around with the registry can be dangerous. Make backups, don't change or delete anything else while you're in there unless you know what you're doing, it's not my fault if something goes awry.

    Unfortunately, this only fixed part of my problem:

    Now, instead of telling me to uninstall parallels tools every time, it actually tries to boot. Which is great news. Parallels thinks that Parallels Tools are gone. The 'Parallels Tools Installing' message comes up on the screen, but it doesn't actually do anything. When attempting to boot, Windows says that the NTFS.SYS file is missing or corrupt and that I need to repair it using the Windows CD. My NTFS.SYS file is fine and Bootcamp still boots normally. I found references to this issue in the forum, but no solutions, although for some it seems to have gone away with an upgrade to the latest beta of Parallels (which I have). Anyone else get to this point?
     
  7. don montalvo

    don montalvo

    Messages:
    111
    i did the regedit edits the other day and i'm able to get in using beta2. things get messy when i try to get back to beta3 so i'll stay here for now. i'll try the next beta, if it works it'll be great, if not i'll just reinstall windows on my bootcamp partition. :)

    don
     
  8. btg

    btg

    Messages:
    4
    I'm not sure my problem was the same as some of you are experiencing now, but here was my solution:

    I had set XP to automatically choose a profile during startup (there were 2 seemingly indifferent entries), and that's what caused the uninstall of Parallels Tools for Boot Camp to have problems.

    So my suggestion is to right click (hahaha) My Computer > Properties > Hardware > Hardware Profiles. Near the bottom, make sure "Select the first profile..." is not used in conjuction with 0 seconds. If this is the case select "Wait until I select a hardware profile" and reboot. I had "Profile 1" and "Parallels" as options, and "Profile 1" was actually the one I had to select to be able to uninstall Parallels Tools for Boot Camp. You might have to reinstall then uninstall the Tools if you've hacked around a lot like I did.

    After I did this everything worked (and is still working) very well. Hope this helps at least one of you!

    Fantastic update Parallels team! w00t!!11!! (maybe if we get 64-bit support I'll upgrade you to three 1's after the w00t :D )
     
  9. manceelee

    manceelee

    Messages:
    1
    i have the same problem

    no idea.....
    i try very thing, but still doesn't work....
    anyone have good idea.
    plz share...lol
     
  10. Mrik

    Mrik

    Messages:
    1
    That was a good Idea Orca, Parallels is now able to boot from boot camp, but now I've got another problem : my mouse and my keyboard both don't work :s ...
    Don't know what to do...
    If someone's got an idea, share it please lol

    My computer is a Macbook Pro 1st Gen, 2,16Ghz core duo, 1,5Gb RAM 100Gb hard drive ...
     
  11. topalli

    topalli

    Messages:
    4
    can't uninstall parallel tools for boot camp

    I have the same problem and cannot uninstall parallels tools for boot camp. Restarted in safe mode. Surely there is some way around this BS.
     
  12. chack

    chack

    Messages:
    7
    I was having this problem. I deleted the folder from the Program Files folder, went into the registry and deleted everything having to do with Tools for Boot Camp (searched for Parallels). Everything seems to be work normally now... fingers are firmly crossed.
     
  13. georgeglaser

    georgeglaser

    Messages:
    2
    Obtaining another copy of Parallels Tools for Boot Camp Beta 1

    Can someone tell me how to locate a copy of Parallels Tools for Boot Camp Beta 1. I seemed to have misplaced my copy and am ready to pul my remaining hair out :) Thanks.

    - George
     
  14. georgeglaser

    georgeglaser

    Messages:
    2
    MacBook Pro
    OS 10.4.8
    Parallels build 3120

    Since I have not heard from anyone about locating Parallels Tools for Boot Camp (beta v1), let me expand my question. It appears that PTBC was never fully installed, so I am having trouble uninstalling it as mentioned in previous posts on this thread. I successfully deleted the Parallels profile as suggested by btg, but I still get a message stating "It appears that PTBC is installed on your Boot Camp partition and will need to be removed before... (whatever). I have no idea how to delete the registry data mentioned earlier in the thread. So I am stuck in the water here. I suppose one option is to reinstall Windows. I ass ume that would take care of the partially installed PTBC files. Am I correct about that?
     

Share This Page