Uncontrolled VM Shutdown - is it safe to use afterwards?

Discussion in 'Windows Guest OS Discussion' started by pemoz, Nov 7, 2022.

  1. pemoz

    pemoz Bit Poster

    Messages:
    17
    Hello,
    While using Parallels Desktop v18.1.0 (5331) (running Windows 10 on macOS Monterey 12.3.1, on a 27 in 5K Intel iMac), I experienced a crash:
    There was white noise (?) on the left side for a moment, and my Mac froze and force-restarted after about 20 seconds.

    When I got back in, I tried starting the VM again. While starting up, it said:
    "Checking the disks after improper shutdown. Please wait... Don't quit the app to prevent data loss."

    When this message went away, it stayed in the screen with the Windows logo and turning white dots for over 24 hours. At that point, I didn't think it'd get done, so I suspended the VM and reverted to a previous snapshot. When trying to start this, the above message didn't appear and I was able to get in just fine.

    Now, my question is - even though it seems to work again, could it be that something is corrupted? Did this issue only affect the "Current state", or the entire VM? I do have a backup of the VM (500+ GB), but I would prefer to continue using my current one if it isn't corrupt.

    Any help would be greatly appreciated.
    - pemoz
     
  2. MatthiasE5

    MatthiasE5 Kilo Poster

    Messages:
    107
    I've had some experience with various problems pertaining to the PVM / Windows, and my advice would be this: Next time, insteaf of reverting to a previous snaphot, try this: 1. Shut down / STOP the VM. 2. Copy the PVM file to an external drive to be on the save side. 3. Start Windows normally (no old snapshot). If it does not work, copy the externally saved pvm to the internal drive and try to start one. I have made the experience that it will start then. You can then delete the other copy. It seems to me that copying back and forth ensures data integrity in some way (caveat: I'm a layperson) 4. If you feel unsure about continuing to use the pvm, I would advise to continue using in simply on the grounds that it is de facto working, and perhaps do some simple checks such as rebooting 3 times, suspending, running all programs once, checking your documents folders, to see everything looks ok at least superficially. 5. Then do what one should do in any case: make a backup at least every 3 days. The actual problem is that one has to copy the full PVM to external every time, unless one can find a VM/ARM compatible backup software.
     

Share This Page