Unreachable virtual machines between Lion spaces

Discussion in 'Installation and Configuration' started by bill.raynor, Aug 14, 2011.

  1. bill.raynor

    bill.raynor

    Messages:
    6
    I just had the odd experience of having my virtual machine show up between the OS Lion spaces.

    System: Mid 2011 MacBook Pro, 8GB Mem
    1. Upgraded to Lion
    2. Start Paralells Desktop
    3. Attempt to start one of my machines (Win 7 - tiny, Win 7 Pro, Ubuntu, Chrome)
    4. Machine list shows me the thumbnail of but no full size image.
    5. When I switch between spaces, the full size desktop is between spaces. For example, if I move from Lion desktop 2 to Lion desktop 3, the Windows desktop briefly flashes up during the switch. This happens between every pair of Lion Desktops.
    6. Attempt to kill the machine from the menu bar (can't reach the window, remember): The vm pops up a requestor, but I can't access it (can't reach it).
    7. Try to quit Parallels, and it takes the command and grays out all the commands, but doesn't quit.
    8. Force quit.
    9, Restart: problem reappears, go to step 8 and then reboot. Problem reappears.
    10. Start a different, previously untouched machine (Ubuntu) from the icon. it works normally. Start one of the others, same problem appears.
    11. Change the names of the offending pvm files, and double click those. Everything starts fine but now I have new entries in the virtual machine list
    12. Delete the old list entries, and rename the new one. Everything seems to work.
    Time spent: 3-4 hours

    My questions:
    1. What the heck just happened?
    2. How do I stop it from happening again?
    3. How do I recover more efficiently if it does happen again?

    thanks
    Bill
     
  2. BennettD

    BennettD Bit Poster

    Messages:
    40
    This might help...

    I had a similar issue, but with my configuration screens...

    This fix from my thread worked for me:
    http://kb.parallels.com/111682

    Here is my thread, it links to a video showing my configuration screen doing what I think your describing your VM doing...
    http://forum.parallels.com/showthread.php?p=455283
     
  3. bill.raynor

    bill.raynor

    Messages:
    6
    BennettD,
    Thanks. That is much simpler than the rename delete sequence I tried.

    Bill
     

Share This Page