Upgrade 3.0 to 4.0 nightmare

Discussion in 'Installation and Configuration' started by ecologisto, Jun 10, 2009.

  1. ecologisto

    ecologisto

    Messages:
    12
    I am angry. Really.

    I have tried to update since yesterday evening and it is just a big massive mess.
    First I got the problem with hal.dll. And no, I didn't crash windows neither in bootcamp nor in Parallels previously. It just came up with the upgrade. After spending quite a lot of time to find out how to solve this, I could finally fix it.
    Then I got stuck in the middle of step 2. Again googling and searching this forum and finally got it passed with the magic and secrete combination of keys and closing the dialog boxes. In the end, after a few automatic restart plus one forced (windows stuck saying "please wait") I got the parallels tools installed and windows working.
    Well, I should not have been too happy about that. This morning, after I booted my computer, Parallels decided that my VM had to be updated. Again. Reminder : it was working yesterday evening, and shut down in a clean way. And then it just got blocked. Pressing ctrl-cmd-alt-R, I could see that it was stuck at the beginning of windows startup, when there is a raw progress bar on a black background. Since then I couldn't do anything. I am now re-installing windows. Once again. Indeed, at each update of Parallels, even small ones, I had problems. Sometimes it would kill Windows, some time it would just need me to take random (for me) action that I would prefer never have known about.

    This is poor software. I am engineer, I know what I am talking about. This is very sad that an upgrade can mess up things like this. I wouldn't have already paid for this software, I would definitely try a competitor to see if it goes smoother.

    I don't ask for help, at least for the moment, as I don't even know how to describe the symptoms. Let's hope that Windows will work after the re-installation.
     
  2. rfranks

    rfranks

    Messages:
    1
    Should I be worried if I'm about to upgrade our work V3.0 to 4.0?

    Does anyone else have similar stories?

    How long ago did v4.0 come out?

    We'll be upgrading it next week and we've verified and repaired the mac and bootcamp disks, ready for the upgrade. Is there anything else we should be doing before the upgrade?

    Thanks in advance.
     
  3. hmolen

    hmolen

    Messages:
    58
    Yes, you should be worried, I have upgraded about 3 weeks ago and am still suffering.
    I have had 3 cases opened and closed 2, the last one is still open.
    I had to go through numerous changes in config.
    I have 2 Mac's, one I upgraded from Parallels3.0 to 4.0 and especially the conversion of the old VM to the new one was extremely cumbersome.
    It hung somewhere in the middle, forcing me to hard reset (power off/on) and I had about 3 blue screens in windows during boot.
    The other Mac I did a "vanilla' install as it was brand new but had blue screens too, guess this is normal with this 4.0 (3844) version.
    After 3 weeks I have it workable now but it is still nowhere CLOSE to Parallels3.0 that I never had real problems with.
    I don't want to spook you too much but make absolutely sure you have a full restorable (please check) backup available on 2 different devices.
    I was ready to go back to 3.0 when I realized I couldn't go back because the VM was converted and I lost the old (3.0) version in the process.
    I am running 4.0 but if you can avoid it, I would recommend you avoid it.
    I have not seen any difference between 3.0 and 4.0 except for the version number :)
    The UI looks a bit more slick but that's basically it.
    I couldn't use the WebCam in MSN in 3.0, I still cannot use it in 4.0, to name one issue I upgraded for.

    If you go do it anyway, GOOD LUCK, and do not loose your head over it, it is just software....(when you have a backup).
     
  4. ecologisto

    ecologisto

    Messages:
    12
    Just to add up to what I said at the beginning of the thread :
    I can now start windows in Parallels. However, iSight stopped working (see another thread I started about this specific problem) and I can't boot on Windows anymore !
    I think I will simply wipe out the partition and start again with Vista, anyway I am wasting my time.
     
  5. JuergenP

    JuergenP

    Messages:
    1
    Let me add another story. I use 3.0 German for 2 years now for business and it works quite well. Last week I bought a 4.0 English version via Amazon, got the CD and after inserting Setup forced me to download a actual version 4.0.3844.
    The conversion of my 3.0 image started and get stuck with a message to continue manually because of issues.
    I logged into my XP Prof image and then the journey began. PD does not recognize my Macbook Pro drives, Parallels tools could not be installed and the doc says it is no longer needed in version PD4.0. OK, but screen resolution is not adjustable right now and several dialogs within the configuration tabs rely on Parallels tools.
    Finally I opened a sev 1 ticket yesterday afternoon because a need my XP for business reason tomorrow.

    Lets see
    regards
    JPF
     
  6. galochka

    galochka

    Messages:
    187
    Hello JuergenP,

    Can you please provide me with ticket ID?
     
  7. StephenF

    StephenF

    Messages:
    2
    Similar story - can't upgrade from v3 to v4

    I've made a similar post in a different thread.

    Basically, the first time I tried to upgrade v3 to v4 - using a retail-purchased original disk (but an early one), the install totally trashed my hard disk - to the point where neither Disk Utility nor Disk Warrior would even recognize the disk! I had to reformat and start completely over.

    After several months of being gun-shy, I downloaded the latest Parallels 4 update and tried to install it. It actually installed fine ... but as soon as my computer (MacBook Pro) re-booted, the Parallels Starter took 100% of my CPU. This same situation exists today with the latest Parallels 4 build. The only solution is force-quitting Parallels Starter in Activity monitor.

    However, I now have a worse situation - as noted by others in this thread: my VMs are converted to the Parallels 4 format, so I cannot 'downgrade' to Parallels v3. I actually have Parallels v3 running (build 4560) with a VM that had not been converted ... but when I try to upgrade to a later version, it tells me "Please uninstall Parallels Server". I found out from a Parallels technician that this can also mean there are residual Parallels 4 files on my system. I have tried to delete every associated file, and still cannot upgrade v3.

    Of course, after paying retail (and being an early adopter), I'd sure like Parallels 4 to work ...
     
  8. Lord Brixton

    Lord Brixton

    Messages:
    3
    You think YOU've got it bad!

    I only bought a 4.0 upgrade because the little alert box advertising the new version kept hanging my Parallels 3.x startup.

    Eventually, I figured 'I paid for it, I may as well use it'

    Install seemed to be going OK, and of course removing my working 3.x install.

    Got an error message as it completed, telling me that the install failed.

    Parallels 4won't launch, can't go back to 3. Boot Camp partition seems to have taken a hit as well. Where on earth is the link to email support now? It seems to have disappeared from the site.

    Even, in desperation, emailed Sales but no response from them either.

    At this point I have no working XP solution on my Mac, and I'm about as unhappy with Parallels as a customer can be.
     
  9. Grandpa Jim

    Grandpa Jim Bit Poster

    Messages:
    18
    Locked up, Virtual Memory Minimum Too Low

    This is scary. The marketing of 4.0 upgrade enticed me. I should know better to buy so early with untested software.
    I had troubles with earlier versions of Parallels ending up spending hours finally getting them going.
    3.0 was working fine. 4.0 sounded wonderful... faster, etc, etc. Now I'm stuck in middle of Upgrade to 4.0 and need this working for business on Monday. Had I seen this forum ahead, I would have never bought in. Shame on me for not checking around first!

    My problem currently (please offer suggestions! I did start a trouble ticket but it says I'll hear in 24 hours)

    In the process of converting Windows XP to 4.0 stalled. No action after 2 hours.
    On Article advice did Ctrl Option Cmd R to select Manual. Next I get message in Windows view saying "Virtual Memory Minimum Too Low". When I try to click on OK nothing happens. Cursor disappears. If I bring it back with Ctrl Alt, same thing happens again. Memory Min Too Low box won't go away. Stuck. Help!
     
  10. Grandpa Jim

    Grandpa Jim Bit Poster

    Messages:
    18
    Need help too, locked up

    In the process of converting Windows XP to 4.0 stalled. No action after 2 hours.
    On Article advice did Ctrl Option Cmd R to select Manual. Next I get message in Windows view saying Virtual Memory Minimum Too Low. When I try to click on OK nothing happens. Cursor disappears. If I bring it back with Ctrl Alt, same thing happens again. Memory Min Too Low box won't go away. Stuck. Help!
     
  11. Grandpa Jim

    Grandpa Jim Bit Poster

    Messages:
    18
    Changed the Memory Preferences to Restore Defaults and at some point the "Virtual Memory Minimum Too Low" box went away, but now stuck on "Windows Product Activation" error box that I can't close. Cursor disappears if I click. If I bring it back with Ctrl Alt, same thing happens again.

    MacBook Pro 2.4ghz processor, 4 GB memory, OS 10.5.7, 23.9 GB available on HD, backed up on External HD
    Help!
     

Share This Page