Upgrade from 4560 to 5160 killed BootCamp

Discussion in 'Installation and Configuration of Parallels Desktop' started by fwong, Oct 2, 2007.

  1. Ansel

    Ansel Junior Member

    I have one hard drive, it is partitioned in two . one side for the normal Macintosh HD.
    and the other for my windows. partition created by boot camp, it is a fat32 partition of 32GB.

    concerning the BSOD, i do not see ANYTHING.
    once i select the windows partition with the "option" key , the screen goes black for 3 seconds. then a " _ " (without the " ) blinks 5 times. then a black screens appears again for 3 seconds,then the underscore blinks 5 times again, and then i get a final black screen where nothing happens. the computer's fan start blowing like mad, and won't stop unless i manually turn off the computer.
    the keyboard doesn't answers when i have the black screen, or at least the "caps lock" and "num lock" lights of my keyboard won't turn on/off. So i suppose the keyboard has frozen.

    I remind you that I can turn on windows via parallels , so i was able to do all diagnostics on windows. i have tried most solutions that i have seen on this forum, with no help.
    i have uninstalled parallels, no help.

    would someone have a link to a Bootcamp help site ? i can't seem to fin any Apple website for it ... i might as well explain my problem to them , you never know.
    but i have checked the Apple database and faqs, but haven't found my error.

    thanks for the effort Alicia,
    best regards,


    EDIT: pls see following post to see update on my BSOD.
    Last edited: Oct 24, 2007
  2. Polvo

    Polvo Bit poster

    In my case, I have a MacbookPro with another external drive, but I use bootcamp on the MBP HD...
    When I try to boot on Parallels I have no problems at all. It's when I try booting with bootcamp. It all seems to start ok, but before the Windows login occurs the computer freezes or it reboots on its own... its just that.. I reinstalled but the problem is still there... same problem
  3. Ansel

    Ansel Junior Member

    update on my status, i don't get the black screen anymore.

    I had some time to spare, so i decided to look around for more errors on my windows. i therefor decided to defrag my computer, you never know. i noticed that a few Windows files were fragmented, so i decided to defragmente my computer until no more windows files were fragmented.

    once that done, i did a check disk with windows. no errors found.

    anyhow, i decided to start windows with boot camp, you never know.

    guess what ? now i finally get an error. actually two errors, but they are probably related.
    when i turn on windows via boot camp, i have the choice in between "windows XP" and "Parallels" ( those are not the exact names) .
    -when booting with the Parallels version, i get a "File missing or corrupted : windows/system32/hal.dll"
    -when booting with the Windows xp version, i get a blue screen with this error : "STOP : 0x0000008E ( 0XC0000005, 0x0001272E, 0xF78E63D0, 0x00000000)"

    i am currently looking into both of those errors, i am also going to uninstall parallels and see what happens.
  4. Alicia

    Alicia Parallels Team

    Hello again,

    for those who have this problem, could you please provide me some more information:

    1. Can you boot Windows in a safe mode?
    2. After the error number in the error message there should be a name of the file that caused it. What are they?
    3. Is there any antivirus software installed in bootcamp? If there is one, which exactly?
    4. If there is any antivirus in bootcamp, uninstall it.
    5. Please, send us your log-files C:\Windows\Minidumps\. Send them to beta-testing@parallels.com with [Dump Logs] in the heading.

    Best regards,
  5. fwong

    fwong Member

    >>fwong, have you already reinstalled Vista? Does the issue still occur?

    Yes - I've already reformatted and reinstalled Vista and all applications using Parallels Desktop 5160. And I've been using this set-up all-day for the past 5 days and already experienced 1 blue-screen/mysterious reboot while running Vista under Parallels (4560 was rock-solid and I never had any blue-screens for 2 solid months).

    >>For those who have the same problem. Please, could you tell me, how many hard drives does your Mac have, and try to describe your BSOD - can you catch anything from it? Any error name? Are there many lines on the screen? It would be very useful for our developers and testers.

    I just have the main-drive that shipped with my MBP (and an external drive I connect via USB only when making backups). I took notes about my BSOD - but I saved my notes on the drive that I reformatted -- so I lost them. But I recall the message when I was able to read the BSOD -- it was very generic and did not identify a specific file but said something along the lines of "...there may be corrupted files...run chkdsk /F...."

    I ran chkdsk /F - and it did find one error which it automatically fixed. But I still received the BSOD - and the BSOD continued to recommend that I run chkdsk /F. It was at this point - I gave up and reformatted everything and started from scratch.

    I have a theory though -- does this type of problem only occur to people upgrading from 4560 to 5160? If I had to upgrade from 4560 to 5160 again - I would uninstall Parallel tools from Vista, then uninstall Parallels from Mac OS X. Upgrade Parallels, then re-install parallels, install Parallels onto the Boot Camp partition and re-install parallels tools into Vista. My problems only started after the upgrade. so my anectodal evidence points to problems with the upgrade.
  6. fwong

    fwong Member

    (my answers when I had the problem before reinstalling)

    1. Can you boot Windows in a safe mode?


    2. After the error number in the error message there should be a name of the file
    that caused it. What are they?

    No error number or file. Just a message on BSOD telling me I may have corrupt files and to run chkdsk /f

    >>3. Is there any antivirus software installed in bootcamp? If there is one, which

    Yes - AVG Free Edition

    >>4. If there is any antivirus in bootcamp, uninstall it.

    Too late for me to try...

    >>5. Please, send us your log-files C:\Windows\Minidumps\. Send them to
    beta-testing@parallels.com with [Dump Logs] in the heading.

    I wish I knew to do this - but my partition is already wiped. I did try to enable Boot Logging to try and find the file causing the issue. I turned on boot logging, but nothing was ever logged. this file never got created on the machine having the problem.
  7. John Boyd

    John Boyd Bit poster

    windows roots\system32\hal.dll is missing or corrupted

    I am running Windows XP Home edition under parallels build 3214 on a Mac Book Pro 2ghz machine.

    OS 10.4 is running on one partition and windows is running on the other.

    I can boot into XP under parallels no problem and until today I could boot into XP using bootcamp directly.

    Today I tried to boot into XP directly through bootcamp and received an error screen telling me that windows roots\system32\hal.dll is missing or corrupted and must be reinstalled.

    I have checked for the file and it IS where it should be.

    I also checked my boot.ini configuration, which is as follows:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINDOWS=Parallels configuration /fastdetect /NoExecute=OptOut
    multi(0)disk(0)partition(3)WINDOWS=Microsoft Windows XP Home Edition /noexecute=optin /fastdetect /kernel=ntkopvs_.exe /hal=halopvs_.dll

    When I click on check all boot paths in the boot.ini window I receive the following message:

    It appears that the following line in the BOOT.INI file does not refer to a valid operating system: multi(0)disk(0)partition(3)WINDOWS=Microsoft Windows XP Home Edition /noexecute=optin /fastdetect /kernel=ntkopvs_.exe /hal=halopvs_.dll Would you like to remove it from the BOOT.INI file?

    Do I need to modify the partition value to 1 or 2 instead of 3?

    I hate the thought of reinstalling windows for fear that this will just occur again.

    Any suggestions for a fix?

    Does anyone know what causes the problem in the first place?
  8. Alicia

    Alicia Parallels Team


    fwong, thank you for this information.
    Now I'm waiting for Polvo and Ansel.

    John Boyd, try to repair Windows installation.

    Best regards,
  9. visdes

    visdes Bit poster

    similar problem

    After installing 5160 on my leopard system, when I now restart into XP via boot camp, and attempt to use macdrive to access my os x partition, I'm suddenly unable to do so. This was working fine before 5160. Uninstalling Parallel Tools and then parallel desktop, has no effect on resolving the issue.

    In the disk management console of XP, the os x partition is now seen as Macintosh HD healthy (unknown partition) with no drive letter.

    Neither Alcohol, nor STPD, nor DaemonTools are or have ever been installed. To the best of my understanding, the only thing that could have introduced this error is PD.

    Anyone else seeing anything like this?
  10. Alicia

    Alicia Parallels Team


    we're already investigating this issue and for that, please, provide me some more information that I asked here and here.

    Best regards,
  11. visdes

    visdes Bit poster

    1. yes.

    2. there isn't a boot error. actually, there was. XP was defaulting to the parallels startup configuration. it was missing a hal file and couldn't boot. i just switched to the standard XP config and bootcamp started up without errors.

    3. Trend was installed. I ran the trend uninstaller from a bootcamp boot, rebooted into os x, reinstalled PD, reinstalled PT into XP, shut down the virtual machine/quit PD, rebooted the machine via bootcamp, uninstalled macdrive, rebooted, reinstalled macdrive, rebooted. still no drive letter on my os x partition and no antivirus software is installed. i doublechecked my services and hidden devices to make sure the antivirus software is completely gone. it is.

    so, i don't think that's the issue.

    4. done. i'm naked in the big, bad world.

    5. will do.
  12. visdes

    visdes Bit poster

    no applicable dump files

    my last dump file is from august. this problem with the missing drive letter just began this weekend. it hasn't resulted in any BSODs or crashes. it's just an inexplicable side effect of something PD did.

    hey, looking thru my registry, does PD install WINE?
  13. Ansel

    Ansel Junior Member

    I am able to boot into two windows, i do not know why , as i have installed only one.
    so i will specify for each boot.
    one is called "Parallels Configuration" or something like that
    and the other is called the typical "Microsoft Windows XP Pro"
    (see boot.ini file lower )

    1. [Parallels] => no
    [Microsoft ... ] => yes, but keyboard and mouse are NOT detected.

    2. [Parallels] (with and without safe boot) => "This file is missing or corrupted : windows\sysem32\hal.dll" it is on the partition, so i supose it is corrupted.

    [Microsoft] (without safe boot ) => no file, just an error code :
    " STOP : 0x0000008E (0xc0000005, 0x0001272E, 0xF78E63D0, 0x00000000 )

    3./4. The only anti virus installed is parallels's anti virus ( Kaspery ), should i still uninstall it?

    5. No such folder exists on my computer. could it be in a different folder ?


    my hard drive is partitionned in two, one for MAC OS X. and one for windows. the windows partition is in FAT32 and is 32GB
    Last edited: Oct 30, 2007
  14. visdes

    visdes Bit poster

    ansel, those are just 2 differently configured versions of the same windows install.

    alicia, the only way to solve my problem was to remove PD and PT, reinstall windows and reinstall all of my applications.

    after doing that--and NOT reinstalling PD--macdrive can see my os x partition. the problem was definitely caused by something that PD did to the boot camp partition. so, the devs should check out anything they've done to PD which would alter the way that an HFS partition's drive letter would be seen by macdrive--because it used to work just fine.

    i should also say that macdrive--under both the virtual machine and in boot camp--was able to mount mac thumbdrives and cds. it just wouldn't get to the os x partition--which i really need to do this week.
  15. Ansel

    Ansel Junior Member

    any updates from the parallels team ?
    even if it is to say "no help possible at the moment" it would be better than no answers at all.

    thanks for your efforts! if we can help anymore, please give a buzz.
  16. rth

    rth Bit poster

    Hi folks,

    I'm experiencing similar issues. I'm on a macpro with 11GB memory MacOSX 10.5.1. I've been around the loop a couple of times, reinstalling Vista via boot camp a couple of times now. This time I decided to be rigourous to see if I could find the combination that causes my issue.

    I have installed Vista via Boot Camp. Rebooted. Checked I could boot into Vista via Boot Camp.
    I allowed Vista to use Windows Update to current (3 reboots all fine)
    I used the MacOSX 10.5 install DVD to install the Apple drivers (reboot fine)
    I booted into MacOSX. Okay
    I booted into Vista w/ Boot Camp. Okay

    Back to MacOSX. Uninstalled the the BETA (build 5540). Restart. Okay.
    Installed the supported/recommended Build 5160. Restart. Okay
    Boot into Vista using Parallels (Build 5160). Allow the automatic install of parallels tools.
    It automatically restarts. But here I encounter my first problem. Windows shuts down to a black VGA/DOS style screen with an underscore character top right corner, and Parallels hangs here. I've left it for a while, but it's definitely hanging. I have to force quit the parallels app.
    Booted into Vista w/ Parallels, okay. Reran the parallels tools install. Restart = app hang
    Force quit.

    Now tried native boot into Vista w/ Boot Camp. Vista startup screen appears, green dot animation bar begins, then hangs. I have to force power cycle (hold the MacPro power button >5 seconds).

    Now try boot into Vista w/ Boot Camp, selecting the boot options menu (F8). I selected safe mode. Booting continues showing components loading, gets to crcdisk.dll and then hangs. Force power cycle.

    I've been through various recovery attempts, e.g. repair from the Vista DVD. Most unsuccessful. I did get to the missing/corrupt hal.dll once.

    I've researched on the net. When I built Vista this time I made a backup copy of the boot configuration data using bcdedit because the symptoms are pointing me to the parallels-BCD not being removed/repaired on shutdown due to the app hanging. BCD replaces boot.ini for those that don't know what I'm talking about.

    I'm going to see if I can restore this BCD backup by running the recovery from the Vista DVD. I'll post the results later.

    To summarise then: Parallels builds 5160 and 5540 have both killed my ability to boot Vista w/ Boot Camp. Parallels can still use the boot camp partition as a guest OS/VM.
  17. rth

    rth Bit poster

    Hello everyone,

    I just noticed an error in my post above. It should read crcdisk.sys (not .dll).

    Also, I tried to restore my BCD but that didn't work, either.
  18. Alicia

    Alicia Parallels Team

    Hello all,

    we're still investigating your issue. For everyone who experienced it - please, try to do the following steps:

    First try - Clear operation

    1. Run your VM.
    2. Manually uninstall Parallels Tools. Shut down your VM.
    3. Go to configuration editor, Hard Disc tab, then choose Advanced tab and press Clear button.
    4. Then go to System Preferences ->Startup Disc and choose your bootcamp partition to boot from it at the startup. Reboot your Mac.

    Second try - Repair Windows Installation
    1. Insert Windows Installation Disk into your Mac CD/DVD Drive and restart the Mac.
    2. When you see the Apple picture please press C button on your keyboard and hold it until you'll see Windows setup.
    3. When prompted press any key to boot from the Windows CD.
    4. Windows Setup should start loading, wait till it loads completely then press Enter (Return) key.
    5. Press F8 to accept Windows License Agreement.
    6. Now Windows should scan your VM for the existing Windows installation - wait for it to finish and choose to repair existing installation.
    7. Wait till the repair operation finishes.

    If you've already done both this things and there's no improvement, please, provide me with some additional information. Go to terminal and run ls -la /Library/Parallels/.bc_backup/ command. I need you to write the output for this command.
    And please go to Applications->Utilities->Disc Utility. In the left side of the window that will open please, activate your bootcamp partition (Windows Installation) and make a screenshot. Attach it here.

    Best regards,
  19. rth

    rth Bit poster

    Hi Alicia,

    Thanks for the instructions. I have some good news, I have recovered my ability to use Boot Camp :)

    I am using Vista Ultimate, so I followed your instructions, modified appropriately for Vista.

    1) I booted into the guest OS w/ Parallels and uninstalled the Parallels tools. Okay.
    2) Shutdown the VM. Okay.
    3) Used the config editor as described to Clear the Parallels data from the Boot Camp partition. Okay
    4) Attempted to boot w/ Boot Camp directly. Failed with the same symptoms: The Vista startup screen appears, the green block animation starts for a few seconds, and then hangs.
    5) Booted from Vista DVD. Ran through the Repair sequence, at this point Vista repair popped up a dialogue suggesting the use of system restore (which I presume attempts to go back to the 'last known good configuration'), I selected yes. Finished the repair and restarted.
    6) Booted directly from the hard drive w/ Boot Camp. Failed, again the same symptoms.

    During my previous methodical rebuild, I had made sure that I created a system restore point after each build/update step. So I knew I had a good restore point after all the Vista updates had been applied and after the Apple drivers had been installed, but before I had installed the Parallels tools. I decided to try a system restore to this point.

    7) Booted from Vista DVD. Entered the repair tool. (HINT: the repair tool finds and selects the Windows installation on drive C:, I click away from this selection), clicking next takes me straight to the repair tools list of tools.
    8) Select the Command Prompt tool.
    9) Run the system restore tool from here by typing 'rstrui.exe /offline:c:\Windows'
    10) I selected the restore point I described above.
    11) System restore completed successfully. Okay.
    12) Restart: Okay

    Wow! I recovered my Vista Boot Camp partition.

    I presume that the issue is therefore related to the Parallels Tools installation in some way. Now that I am confident that I can recover the situation, I am willing to help debug further. I'll try installing the Parallels Tools again through the VM. If it breaks Boot Camp, I'll run through the recovery steps again to see if the whole thing is repeatable.

    If there's anything you want me to look at in particular, then please let me know.

  20. rth

    rth Bit poster

    Hi Alicia,

    I've done a little more investigating. The good news is that the issue is repeatable, and can be corrected repeatedly. Here's what I did, starting with the recently recovered and working Boot Camp partition:

    1) My VM is configured to use the physical CD/DVD drive.
    2) Boot the VM, get the 'first time' warning.
    3) Wait for the first time install to complete and the VM restarts
    4) Interestingly, the VM hangs at the restart, and I have to Force Quit the Parallels app.
    5) Boot the MacPro into Vista natively via Boot Camp
    6) The startup animation starts (green blocks), then hangs

    Oops it's broken again! Now I assume that the initial Parallels install has caused the issue. Interestingly, I don't think the full tools install has happened yet (because the physical CD/DVD is configured and the prtools image hasn't been used/mounted yet.
    (I also tried a start with boot logging, [F8]. Whatever happens causes the system to halt before the bootlog.txt file can be created, it's not there!).

    Anyway, it's broken.

    7) Force shutdown the MacPro (hold the power button).
    8) Restart from the Vista install DVD.
    9) Choose Repair.
    10) Unselect the windows installation (click anywhere away from the selected item)
    11) Click Next to go to the repair tools
    12) Start a command prompt
    13) type 'rstrui.exe /offline:c:\Windows'
    14) go to the list of restore points
    15) click on the show restore points older than 5 days
    16) scroll down the list to find the restore point before the Parallels tools install (or a restore point you know to be good)
    17) Restore to this point
    18) Restart (into Windows directly)

    This works for me.

    As I said above, it would appear from this test that the issue is introduced by the first time parallels install.

    All of my tests are done with the following configuration:
    MacPro Quad 2.66 (MacPro1,1), 11Gb RAM, and loads of disk
    MacOSX 10.5.1
    Vista Ultimate
    Parallels 3 build 5160
    The only other piece of software that might have an impact is macfuse core 10.5 1.1.1

    I hope this helps the Parallels team, and others experiencing similar issues.

    Last edited: Nov 24, 2007

Share This Page