Upgrade from v16 to v17 lost USB to serial port compatability

Discussion in 'Mac OS X Guest OS Discussion' started by PaulA2, Oct 22, 2021.

  1. PaulA2

    PaulA2 Bit Poster

    Messages:
    21
    I use Parallels to program Motorola radios, which require 32 bit addressing for their USB and serial port programming capabilities to work. Been using my VMs for years for this, in fact the only reason I have bought Parallels for the last 6 years. Updating to v17 in preperation for my new M1 Macbook, I have now lost the ability to program my radios. The Prolific and FTDI USB to serial adapters appear in COM PORTS as before, but attemptting to utilize them leaves the programs not responding and the VM crashes to BSOD if I manually shut them down with the X or task manager. This is using my trusty old Windows 7 32 bit VM. I installed VitualBox and a fresh install of Windows 10 32 bit and it was able to operate fully with the adapters and programs, but Virtualbox is not M1 compatible. I then took that ISO and made a fresh Windows 10 32 bit VM in Parallels, but the issue persists.

    If I can't fix this, then Parallels is of no use to me. I really don't want to have to revert to a 10 year old Dell craptop. Any sugestions?

    Paul
     
  2. PaulA2

    PaulA2 Bit Poster

    Messages:
    21
    Someone on a Motorola forum suggested I go to the VM hardware tab and + add Serial Port. I did so, and was given a drop down selector for available devices that I can point at to become COM 1. Saw the USB to Serial port as well as my BT, selected the USB adapter, and all works now. :)

    Seems like when building v17 they either forgot to default that operation to how it worked previously, or intentionally changed it for some unknown reason.

    Paul
     
  3. MuratA1

    MuratA1 Bit Poster

    Messages:
    5
    I've got the same problem. All my day gone, dame parallels. we are not your beta tester. fix this problem asap.
     
  4. mmika

    mmika Kilo Poster

    Messages:
    488
  5. StaceyE

    StaceyE Bit Poster

    Messages:
    9
    I have exactly the same problem. I am unable to fix this by adding a port, etc. I've updated several machines and they all have this problem. Please fix ASAP!!!!!
     
  6. StaceyE

    StaceyE Bit Poster

    Messages:
    9
    I should add that the port shows up in windows and I can connect to it but there is no data transfer.
     
  7. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    416
    Hello @PaulA2, please downgrade to v17.0.1 , and check if USB issue will get resolve. Thanks, Parallels Team.
     
  8. StaceyE

    StaceyE Bit Poster

    Messages:
    9
    Where do I find/download v17.0.1 ?????
     
  9. StaceyE

    StaceyE Bit Poster

    Messages:
    9
    I found v17.0.1 link above and it works!
     

Share This Page