Upgraded to P7 - Games no longer work

Discussion in 'Windows Guest OS Discussion' started by Hussman, Feb 7, 2012.

  1. Hussman

    Hussman

    Messages:
    7
    Hi,

    I have a 2.66 intel core 2 duo Mac Mini Server running Snow Leopard.

    The machine has 8GB RAM

    I enjoyed playing Command and Conquer Generals, a Windows based game, via Parallels.

    I recently upgraded to the latest version of Parallels and now my game refuses to work.

    The error message states the game needs DirectX 8.1 to work, and that the video card needs 64MB to work.

    Using DXDIAG I see I am running DirtectX9.0c. My video memory is set at 256Mb.

    It worked fine before, and now it doesn't.

    Any help would be appreciated as I love this game!

    Many thanks in advance

    Hussman
     
  2. serv

    serv Parallels Developers

    Messages:
    810
    Hussman,

    Can you post screenshots of DXDIAG Display tab and Device Manager with opened Display Adapters branch?
     
  3. Hussman

    Hussman

    Messages:
    7
    Thank you for your response.

    Screen grabs attached, as requested.

    Thank you in advance for any help you can provide.

    Hussman
     

    Attached Files:

  4. Hussman

    Hussman

    Messages:
    7
    These screen grabs may help too...

    :)
     

    Attached Files:

  5. Hussman

    Hussman

    Messages:
    7
    The error message I get when trying to run the game....
     

    Attached Files:

  6. Hussman

    Hussman

    Messages:
    7
    I comply with your request to provide relevant screen shots and don't receive the courteous of a reply.

    Come on Guys...
     
  7. serv

    serv Parallels Developers

    Messages:
    810
  8. Hussman

    Hussman

    Messages:
    7
    Thanks, I will try that this weekend and report back.

    Appreciate your help.
     
  9. Hussman

    Hussman

    Messages:
    7
    In the end the solution was to do a fresh install of windows.

    The game now works again.

    Regards,

    Hussman out
     
  10. Oclair

    Oclair

    Messages:
    16
    Hi,

    Why does the video adapter state only 256mb when we know that a new feature of Parallels 7 was allocating up to 1GB of video ram?

    Please see attached files!

    It seems that Windows XP does not register any updates made to the computer's hardware once the OS has been installed. For example, windows reports the wrong VRam, Installed Memory, disregards over clocked CPUs etc. They system environment can be updated and Parallels can be configured to allocate more or less resources and yet DxDiag (Direct X Diagnostic Tool) does not reflect what Parallels states it is allocating the Operating system.

    There are major repercussions impacting all types of software here!!

    Thanks in advance,
    Oclair
     

    Attached Files:

Share This Page