Upgrading to 4.0 - XP - Just get black splash screen

Discussion in 'Installation and Configuration' started by w3sustainable, Nov 11, 2008.

  1. w3sustainable

    w3sustainable

    Messages:
    1
    I updated to the newest version of 4.0. I have an imac, 2.33ghz core 2 duo with 4GB of ram, running 10.5.5. I created a backup of my xp partition (thank god) NOT running in bootcamp. When I click start, it goes through step one of four, then it shows the code screen for .1 seconds, then it goes back to the black Microsoft Windows XP screen. Help! I'm stuck and can't move forward. Not even a command line to run queries in.
    -Mark
     
  2. Same here

    Tried to perform upgrade, didn't make it past step one before fading back to the XP splash screen and stopped the booting process.

    This VM was working in version 3.0 this afternoon, then I shut down Windows in version 3.0 before upgrading Parallels to version 4.0. Now when I start the VM, I get "Preparing to upgrade your virtual machine (step 1 of 4), then a black screen that looks like Windows screen where you choose whether to start normally or safe mode or safe mode with networking, but in less than one second that is replaced with the VM's WindowsXP splash screen (the same one that displays before clicking the Start button for the VM). Nothing works.

    This is miserable.
     
  3. prefabsprouter

    prefabsprouter

    Messages:
    4
    I am getting the exact same error. I'm at a loss!
     
  4. acardinale

    acardinale

    Messages:
    3
    Same problem here, won't get past step 1 of 4. Just kind fails. No info. No Nothing.
     
  5. billc80015

    billc80015

    Messages:
    21
    Yep, got the same error. Using Mac book with Leopard, was running ok on 3.0 version then foolishly decided to go for this disastrous 4.0 version. I was getting to the same screen that does not give any response just as you all described above. Then in desperation I just kept on clicking on start which restarts the upgrade image process and finally it came up with the "you need to manually continue the upgrade process," window ... had an "ok" button ... I clicked that and got to a dos like screen that says, "No boot device is available". Unbelievable ... just wasted my whole day with Parallels ... funny how your own $80 can get you into a real bind. Was working with 3.0 before getting a good ol' Parallels advert on 4.0 and all its new greatness ... fell for it they totally destroyed my working image ... bad part is I didn't even do the backup option ('too much faith in dear Parallels team') ... now I've tonnes of work on the image that I cannot even begin to recover ... Oh, and since i am in a bind at work to release my code which is stuck on the Visual Studio on the image ... now I have no option but to pay another $30 tomorrow to at least get the great opportunity to talk to a tech support guy at Parallels so at least I can see how I can try to recover just my data ... As for trusting my data again on those Parallels images ... well, that's another story for another day and another blog ... but for serious windows development work or serious business data or anything mission critical .. definitely don't follow my lead, let me be your example of what not to do ... I just think a general rule of the thumb for anyone in the business of critical OS related software is to be open with tech support through all channels at least 24/7 .. maybe its just me but OS is pretty critical software type business because it can really put some of us out of commission ... and to do it with 3 day type response times via email only or pay per chat says a lot about commitment to customers ...
     
  6. eliotw

    eliotw Bit Poster

    Messages:
    15
    Same here..

    Windows XP VM that was working fine in 3.0. Shutdown the VM prior to upgrade Parallel Desktop.

    First time the 'upgrade' started, it went from step 1, to step 2 "searching for new devices", then after a bit it show step 1 again until it just went back to the black screen with the name of the VM.

    Trying to Start the VM again starts the 'upgrade' process but before getting to step 2, I briefly see the white on black Windows text screen warning that is didn't start successfully last time. I managed to grab this window grab of it.

    I've tried restoring the HD disk image file several times but with the same result.

    Any one having success ? Any way to force it to allow a manual upgrade ? Clearly the automation of the upgrade is broken in many cases.

    Help
    -E

    [​IMG]
     
  7. billc80015

    billc80015

    Messages:
    21
  8. eliotw

    eliotw Bit Poster

    Messages:
    15
    Got through it finally...

    I managed to get my VM upgraded. Here's what I did:

    1) Shutdown Parallels
    2) Restored VM HD image from a backup I made before 4.0 was installed
    3) Started Parallels and clicked Start on my VM
    4) On the upgrade screen, I hit Control+Command+Option+R (the secret code to get out of the automation and see the VM screen)
    5) I ignored any and every request that Windows gave regarding new hardware (clicked cancel mostly)
    6) Finally the Parallels upgrade program was running the VM. At one point I had to tell McAfee to allow a file change (maybe this was the problem all along)
    7) Parallels rebooted the VM and I had to use the Control+Command+Option+R combination a few times to stop the automated process which kicked in again
    8) After another reboot it auto logined with a user called '_parallelHelper0' or something and when through the whole Windows user personalization (ugh). The task bar was missing. (complaints at start up about missing winin, urlm, brow, webc -- but only once)
    9) Eventually a 'Complete upgrade' application started and another reboot took place
    10) More new hardware msgs ignore and manually selected 'Install Parallels Tools' from the "Virtual Machine" menu.
    11) This took about 20 minutes and there was another file change I had to tell McAfee to allow
    12) after the final reboot it logged me in as my original user again and everything seems fine

    Automation is great but only if it works. And it should be easy to disable - not the case here.

    Good luck -- make a backup before you start...

    E
     
  9. mediated

    mediated

    Messages:
    1
    Thanks for the detailed info

    That escape sequence worked for me. I think Parallels gets hung on the XP activation screen. It just sits there until you enter Manual mode and next past that screen. I had to do this three times to finally past to the 'Tool installation' screen. (step 4 of 4). It stalled on step 2 of 4 and step 3 of 4 and step 4 of 4.

    Cheers!
     
  10. thank you! my upgrade process got stuck on the activation screen as well. That escape sequence saved the day.

    gentle nudge to the parallels team to take care of this case. very grateful for community support!
     

Share This Page